Welcome to Geeklog Monday, December 09 2019 @ 07:05 pm EST

Geeklog Forums

glmenu 3.1 and Geeklog 1.8.0


Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Just a feedback :

The glmenu 3.1 upload breaks the plugins admin page. So to install glmenu I needed to visit the admin/plugins/glmenu/install.php page. Then the plugins admin page works nice.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1384
Did you want to fix that and create a new version? We could add the source code to the same repository as the forum so others at some point could do some work as well.

Tom
One of the Geeklog Core Developers.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Sorry I would like but I do not get enough time today to take care of the glmenu plugin.
All my free time will go first to paypal plugin, classifieds plugin, multi plugin, maps plugin, captcha plugin, flickr plugin.
Maybe in september...

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
I installed glmenu by hand and got it working. I think I've got a file misplaced though. Please see included screen cap. Notice the blown out tool tip? Any ideas?



Thanks,
~Bob
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Check the presence for the tooltip class in your theme css.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Bazinga!

I'd copied files from an older version auto-install with different table prefixes in the DB which carried into the css.

Fixed.

Thanks Ben,
~Bob
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Quote by: ::Ben

Just a feedback :

The glmenu 3.1 upload breaks the plugins admin page. So to install glmenu I needed to visit the admin/plugins/glmenu/install.php page. Then the plugins admin page works nice.

Ben



Hello,

Been away from GL lately, but did some upgrading on a site and got this error.
Using the direct link to the menu-install gave the same error.

Has anyone a fix for this?
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Thete is also the issue "PHP Formatted Code
Deprecated: Assigning the return value of new by reference is deprecated"

See here

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Hello Ben,

I have no return at that line, this was fixed some year ago.
Or is there something Im missing?

The error:
PHP Formatted Code
array(3) {
  ["sql"]=>
  string(48) "SELECT pi_version FROM  WHERE pi_name = 'glmenu'"
  ["ignore_errors"]=>
  int(0)
  ["result"]=>
  bool(false)
}


After disabling glmenu via sql, when reenabling the whole menu is missing on the site....
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Bob sayed
I'd copied files from an older version auto-install with different table prefixes

and the table name is missing in your quote
string(48) "SELECT pi_version FROM WHERE pi_name = 'glmenu'"

Could it be related?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Hmm...
Thanks for your reply Ben,

I see there are something missing, but..
I try this on a fresh install, and the error appears as soon as I put the glmenu-folder in my plugin-directory.
So, before any install of glmenu it still asks for info from my database that cannot be there?
I do not have any old version, so cant try another file either..
 Quote

Status: offline

mystral-kk

Site Admin
Admin
Registered: 19/03/06
Posts: 100
Location:Japan
Quote by: casper

Hello Ben, I have no return at that line, this was fixed some year ago. Or is there something Im missing? The error:

PHP Formatted Code
array(3) {
  ["sql"]=>
  string(48) "SELECT pi_version FROM  WHERE pi_name = 'glmenu'"
  ["ignore_errors"]=>
  int(0)
  ["result"]=>
  bool(false)
}
After disabling glmenu via sql, when reenabling the whole menu is missing on the site....

This can be fixed by adding the following line to the top of "plugins/glmenu/config.php":

PHP Formatted Code

global $_TABLES;
 

However, glMenu plugin won't install with Geeklog-2.0.0, because of changes in blocks.


-- mystral-kk, "Every cloud has a silver lining."
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
This can be fixed by adding the following line to the top of "plugins/glmenu/config.php"


Yes I forgot this change. Thank you for the reminder.

There also alternatives to glmenu :

- A nice solution from suprsidr
- Menu plugin

Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Thanks for your help.
Its now fixed.

And thanks for the other suggestions, will take a look.
Glmenu have never been a favourite, its functions make me Sick
 Quote

All times are EST. The time is now 07:05 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content