Welcome to Geeklog Tuesday, October 22 2019 @ 02:44 pm EDT

Geeklog Forums

UTF-8


Status: offline

Zippo

Forum User
Chatty
Registered: 08/07/11
Posts: 53
confused
FYI
After I installed the dokuWiki plugin, I could not make a proper Wiki while my special characters did not converted properly by DokuWiki.

Dokuwiki Forum support, told me to change the browser setting to UTF-8. No result.

This evening: Idea
I renamed the geeklog language file dutch.php into dutch_org.php.
I copied the geeklog language file dutch_UTF8.php into dutch.php.

Problem Solved!

-=-=-=-=-=-
But was this the right way I supposed to do it?
I could nowhere find an option in geeklog configuration panel to choose UTF-8.
Also in My account / language list... only 1 dutch language.
-=-=-=-=-=-

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
In step 2 of the Geeklog install is the option to select UTF-8.

To manually change it for a site you are already running you will have to edit siteconfig.php found in the public_html directory.

PHP Formatted Code
$_CONF['default_charset'] = 'utf-8';


You should also then convert your database to utf-8. Take a look at this article. There also was a good forum post about this from a few years ago but I can't seem to find it at the moment.

Tom
One of the Geeklog Core Developers.

Status: offline

Zippo

Forum User
Chatty
Registered: 08/07/11
Posts: 53
Thanks....

I searched on "utf_8", that's why I missed it Frown

Ok.. have some work tot do... Wink

Thanks again,

Grtz.
Zippo

Status: offline

Zippo

Forum User
Chatty
Registered: 08/07/11
Posts: 53
Hmmm....

When I click on localhost in myphpadmin, I see:
==================
Server: Localhost via UNIX socket
Serverversie: 5.0.92-community
Protocolversie: 10
User: xxxxxxx@localhost
MySQL Karakterset: UTF-8 Unicode ( utf8 ) (Note: I did not changed it, was already like this)
===========

But In All the databases/tables I see: "latin1_swedish_ci" everywhere..
Should I change this??

So yes....
Can somebody post a query to run... or post a solution to change this in a batch.

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
You can find a tutorial here.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

Zippo

Forum User
Chatty
Registered: 08/07/11
Posts: 53
Sorry Ben,

That is not a tutorial, but a puzzle in Chinese for me.
(BTW. I can not read Chinese)

Geeklog = dutch_utf8 now.

Only all the SQL tables give latin.... (and I have over a hondred tables)
Tutorial says: I used the "replace commando" but does not say how to use it.

Just type:

REPLACE latin1_swdish_ci UTF-8 Unicode

Won't work, at least I am afraid to experiment with it.

-=-=-=-
It looks that everything works fine.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
Is this a new site? If so it would be better to just copy the information you need and then just delete the database and start fresh.
One of the Geeklog Core Developers.

Status: offline

Zippo

Forum User
Chatty
Registered: 08/07/11
Posts: 53
It is a fairly new site.

I have no strange characters anymore... so I will change the table settings in slow manual mode. (no hurry)

But I will not install GeekLog for the 4th time (twice: I have 2 sites running) Evil

All times are EDT. The time is now 02:44 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content