Welcome to Geeklog Tuesday, September 17 2019 @ 06:42 am EDT

Geeklog Forums

Manual Migration problem


Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Having probs migrating Geeklog/Gallery2/G2Bridge conflation to new server. (Auto migration didn't work, trying to do it by hand.)

Copied all files to new location.
Moved database and updated table: gl_conf_values.
Updated: public_html/siteconfig.php
Updated: public_html/gallery/config.php
Updated: notpublic_html/db-config.php

When accessing url I get the error "error selecting database" and that is all on the page.

Have I missed any files which needed updating? Any other ideas?

Thanks,
Bob

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Did the database credentials or name change? If so, you need to update the data in db-config.php

bye, Dirk

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Yes sir, all info did change and the db-config file was updated accordingly.

When I just accessed baseurl/admin/install and tried to "update", I used the same info as in the new db-config file and GL tells me my DB is already up to date and I probably ran the upgrade before... so I'm pretty sure THAT file is correct.

But now it's throwing the error: Unfortunately, an error has occurred rendering this page. Please try again later.

Thanks (for the expediency as well)

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
The actual error should be in your error.log, see Unfortunately, an error has occurred rendering this page. Please try again

bye, Dirk

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
This make any sense?

Fri Jul 22 14:13:07 2011 - Unable to unserialize s:36:"/home/ma500/ma500_blab/system/pear/"; for Core:path_pear

Thanks, and sorry for the amateur hour questions.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: bweber

This make any sense?

Fri Jul 22 14:13:07 2011 - Unable to unserialize s:36:"/home/ma500/ma500_blab/system/pear/"; for Core:path_pear


Yep: The 36 is the length of the string inside the quotes. But that path is 35 characters long. So change that to a 35 and try again.

bye, Dirk

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Well duh, thanks. I also think I have ALL the paths incorrect (I just moved to a new reseller host and am still learning their structure.)

Thanks, I'll letcha know when I have the next, inevitable question.

~B

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Good luck - it's a pain doing it this way. That's why we have that Migrate option in the install script ... If you get a chance, I'd be interested to hear what exactly didn't work for you there.

bye, Dirk

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
Dirk, I'm convinced my auto-migration problem stemmed from the fact that I was trying to move the site before I pointed the site the the new location. I was using a temp URL based on the IP. I'm at the point, being the amateur I am, that I think it's easier to finish up this way rather than start over with a real migrate. I dunno, I'm half clueless about how this all works and my DB is 800 megs, not very easy to move around. And I'm moving FROM GoDaddy, that in itself is enough to turn my brains to jelly.

I have another one I'll be trying to move next week. I'll make more of an effort to do it the right way.

In any event, it was most likely operator induced.

Thanks,
~B

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
Bob, I also have a script that makes it easy to edit some key $_CONF values and enable/disable blocks and plugins.
You'll likely have to disable G2Bridge and un-install/re-install as the paths/urls will be wrong

@Dirk, this could be included in the distribution.
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

bweber

Forum User
Chatty
Registered: 22/07/11
Posts: 36
My DB may be FUBAR at this point with all the fiddling I've done with that table. I dunno. Maybe we can chat and you can give me some specifics about your suggestion.

Thanks bud,
~B

All times are EDT. The time is now 06:42 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content