Welcome to Geeklog Monday, November 18 2019 @ 01:25 am EST

Geeklog Forums

Can't Browse Pass index.php from internal network connection


Status: offline

touchstek

Forum User
Newbie
Registered: 09/03/11
Posts: 4
I have just installed a Geeklog download onto my Debian Server.
All went on well with the installation.
Except =
I can browse on the debian server, but when i try to browse this using another computer on the network (Internal Network) The main page opens but without any images,also its not reading the css of geeklog. I have checked all permissions and they seem correct.
I have re-installed five times but will still not get this resolved.
I have checked settings on the DocumentRoot and others.
DocumentRoot /var/www
DirectoryIndex index.php.

Everything seems fine on the Debian Webserver, but when i launch the website from another computer on the network i get the same error.

Also,when this page loads, i can still not get any other pages I click on.

Please has any of you got a clue as to why this keeps on happening.

No virual host installed

Version used is

Geeklog version geeklog-1.7.1sr1.tar.gz
Debian 6.0.0 Squeeze.
Apache2
Php5

I look forward to your speedy response as usual

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
What did you set to the site_url?

Do a "view source" for the index page and check the URLs for the images and stylesheet. They probably contain a hostname that the other machine can't reach or doesn't know about.

bye, Dirk

Status: offline

touchstek

Forum User
Newbie
Registered: 09/03/11
Posts: 4

Thanks Dirk,

I will do that and get back to you with my findings.

Much appreciated

Status: offline

touchstek

Forum User
Newbie
Registered: 09/03/11
Posts: 4
confused
Hi Dirk. Sorry to be a pain, but i can't still figure out what's wrong.
Also how do i set the site_URL ? For let me do this first and see if it makes a difference. Thanks

Status: offline

Roccivic

Forum User
Moderator
Registered: 19/05/10
Posts: 136
I'm not sure where the site_url is defined, but you can override this setting by adding the below line to the file "public_html/siteconfig.php" (somewhere in the middle, not at the very end)

PHP Formatted Code
$_CONF['site_url'] = 'http://mysite.com/';


But the best way to define the site url is during the step 2 of the install, in the last and second last text inputs.

Rouslan

Status: offline

touchstek

Forum User
Newbie
Registered: 09/03/11
Posts: 4
confused
Hi Dirk. Sorry to be a pain, but i can't still figure out what's wrong.
Also how do i set the site_URL ? For let me do this first and see if it makes a difference. Thanks

All times are EST. The time is now 01:25 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content