Welcome to Geeklog Saturday, October 19 2019 @ 12:58 pm EDT

Geeklog Forums

Purepro Theme for Geeklog 1.7.2


Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Hi,

Quote by: kobab

An error was happened as 'header.thtml was not found' when I uploaded purepro_base files and change theme to purepro.
I uploaded header.thtml of professional theme and became fine so far.



Make sure you dowload the last Purepro base for geeklog 1.7.2 and a fresh copy of your theme from the theme maker. You need to get a $header_type setting in your data/purepro/1/theme.php file.


Quote by: Laugh
"The security token for this operation has expired. Please authenticate again to continue."


I can not reproduce this with fresh purepro base and fresh theme from the theme maker.

Important : Purepro base 1.7.2 is for geeklog 1.7.1 and 1.7.2. Purepro base 1.8.0+ is for geeklog 1.8.0+

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

kobab

Forum User
Regular Poster
Registered: 22/02/10
Posts: 73
Thank you, Ben.

Purepro base I downloaded yesterday consists of;
Purepro_base_1.7.2
/data
/public_html
readme

The new one consists with a normal theme directory of;
Purepro
/admin
/article
/comment
..................................

Anyway, I try to overwrite all the files at public_html space and the one at /private/data.

Status: offline

kobab

Forum User
Regular Poster
Registered: 22/02/10
Posts: 73
Quote by: kobab

Quote by: Laugh

"The security token for this operation has expired. Please authenticate again to continue."

when I try to update my blocks when I am using the purepro theme under Firefox only. The blocks also do not save if I enter the correct information.


I am having the same problem with Chrome, not yet checked other browsers though
Not only blocks, every updates of configuration etc with purepro theme leads to the same symptom.


Same symptom occurred. Need install again......
Let me try later.......

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Quote by: kobab



The new one consists with a normal theme directory of;
Purepro
/admin
/article
/comment
..................................



Sorry I forgot to add the data part in the archive. It's now corrected, but I still can not reproduce the symptom on a site running geeklog 1.7.2. Could it be a server side issue?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
With Geeklog 1.8.0 Google Chrome seems to be working fine for me now under the professional theme with the authentication issue. I am not sure what changed

The Purepro theme works fine in IE9.

The Purepro theme still has problems under FireFox and Google Chrome. I was looking into this a bit and for some reason the token in the code is not the same as in the database. It appears somehow that SEC_createToken gets executed again...

This happens with JavaScript enabled and disabled.

Also if you view the source under FF or GC it seems to request the information from the web server again which updates the tokens so you get different ones again which confused me for a bit. Big Grin

If I find any more info I will post it.

Tom
One of the Geeklog Core Developers.

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Very strange because since few days I'm working on a 1.8.0b1 test site and do not notice any issue on FF, IE or GC.

An error was happened as 'header.thtml was not found' when I uploaded purepro_base files and change theme to purepro.
I uploaded header.thtml of professional theme and became fine so far.


This is an issue on the config page. When you change $_CONF['theme'] from purepro to professional and your theme is purepro the system is looking for a purepro/header.thml file which do not exist.
What can I do: add the missing file or report a bug?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
I will download the base and files again and just double check.

With your header bug I would report it and put a link to this forum in your report.
One of the Geeklog Core Developers.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
Very strange because since few days I'm working on a 1.8.0b1 test site and do not notice any issue on FF, IE or GC.


The Authentication issue is still their for me. I made sure I had the latest purepro theme base and I downloaded my #23 again, I even tried it on another computer. IE works fine but the others (FF4 and GC) have problems with the authentication request coming up when ever I try to update the blocks, etc...

Tom
One of the Geeklog Core Developers.

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
ok I was able to reproduce the issue on my test site. As you said Tom FF, SAFARI or GC loaded twice the page content and then the SEC_createToken gets executed again but everything was fine with IE.

I made an update for Geeklog 1.7.1 and 1.7.2:

Download Purepro base 1.7.3

Thanks,

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1381
Quote by: Laugh

Hey Ben,

I tried unzipping the file again that I downloaded from Purepro using both Winrar and 7-Zip and I get notified of a corrupted file by Winrar and 7-Zip extracts one useless file . Do you have the same problem?

Tom



Hey Ben,

I am having this problem again which I fixed last time by using Firefox. Now I get a corrupt zip file if I download with IE, FireFox or Chrome. I am not sure what is happening here.

Tom
One of the Geeklog Core Developers.

All times are EDT. The time is now 12:58 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content