Status: offline

Pushkar

Forum User
Regular Poster
Registered: 14/04/09
Posts: 99
Quote by: suprsidr

Forget my previous query, we can figure this out here.
go to yoursite.com/admin/mail.php
paste the contents of one of your newsletters there, and send it to yourself.
This cuts newsletter out of the equation.

-s


I did it, and I received in a letter all links and images in right format. I think there is problem only in Newsletter plugin, maybe some settings

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Newsletter uses phpmailer which has far more flexibility and an advanced feature set beyond php's mail function.
I'll update newsletter to the latest phpmailer.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Updated to phpmailer 5.1 give it a shot http://www.flashyourweb.com/filemgmt/index.php?id=19 and let me know.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

Pushkar

Forum User
Regular Poster
Registered: 14/04/09
Posts: 99
Quote by: suprsidr

Updated to phpmailer 5.1 give it a shot http://www.flashyourweb.com/filemgmt/index.php?id=19 and let me know.

-s



Thank you very much!!!! :banana: it's working correctly!

but I nave another problem: Subject of letter display in wrong charset :
PHP Formatted Code
Ïðîâåðêà Ðàçíûå èíòåðåñíûå øòó÷êè

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
plugins/newsletter/functions.inc line 1362 add:
PHP Formatted Code
$mail->CharSet = $_CONF['default_charset'];

just after:
PHP Formatted Code
$mail = new PHPMailer(true);


-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

Pushkar

Forum User
Regular Poster
Registered: 14/04/09
Posts: 99
Quote by: suprsidr

plugins/newsletter/functions.inc line 1362 add:

PHP Formatted Code
$mail->CharSet = $_CONF['default_charset'];

just after:
PHP Formatted Code
$mail = new PHPMailer(true);


-s


it's doesn't helps. this problem is only in subject and sender name of letter

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
I don't know what to tell you. The newsletter plugin is not setting any charset anywhere.

That was my only thought.

Localization is my weak point, so maybe Ben or Dirk have an idea.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Page navigation