Welcome to Geeklog, Anonymous Thursday, December 01 2022 @ 09:34 pm EST

Geeklog Forums

G2Bridge - How to embed Gallery 2 into Geeklog 1.7.1?

Page navigation


Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
working
I am hoping that this is an easy one so i will keep it simple.

i have an older geeklog site with a custom theme that has gallery 1 embedded in it. The user can navigate throughout the whole site with the same interface seamlessly.

I want to move the Geeklog install to 1.7.1 and the Gallery to Gallery 2.

I have migrated both successfully and they are running fine.

HOWEVER, I can find no means of EMBEDDING gallery 2 into the Geeklog theme. I thought g2bridge was going to do that (and maybe it does, i cant find how though) so I am hoping someone can tell me if i am missing something really obvious. The docs for G2Bridge are a bit higgledy piggledy...

Thoughts? Anyone?
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
As the author of the G2Bridge plugin, insults will get you nowhere.

And including information like... a url or anything helpful would just be ridiculous right?

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
Oops! No offense intended - I didnt mean it as an insult - I was just having trouble with the docs as the documentation of simple stuff is hard to find so I am a bit frustrated. Installation went smooth, but I dont even know if G2Bridge is what i needed, but there is no info anywhere on how to embed Gallery 2 into geeklog like you could gallery 1.

This is the old site and they like the way it works we just wanted to upgrade function to a newer Geeklog and Gallery http://www.erotasbuildingcorp.com/

You can have a look at the new site under construction (with an incomplete theme) at ...
http://www2.erotasbuildingcorp.com

...the gallery is at http://www2.erotasbuildingcorp.com/gallery2
...the g2bridge is at http://www2.erotasbuildingcorp.com/G2Bridge

But I dont know how this would be useful information if I cant figure out if it is supposed to do what I want to do which is why I didnt post it before.
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
So when you installed G2Bridge, it brought your site down?
Make sure the imageBlock module is installed in gallery admin -> plugins
I swear I added a check for that.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
BTW, to answer your question, G2Bridge is intended to wrap your gallery into your Geeklog site.
Like mine

But G2 can also be easily embedded anywhere - a few samples.

I've literally done hundreds some as slideshows, some as lyteboxes some ajax....

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
No the site is not broken. www2. is a development site for me to migrate the stuff at the www. location and work out the bugs. I am in the early stages of recreating the theme that is on www. on www2. so www2. is a mess...

Have a look at the way http://www.erotasbuildingcorp.com/gallery looks - and the fact that there is no gallery logo or gallery sidebar navigation... That is what I want. What am i missing.
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
Give my clear theme a shot.
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
Actually used the matrix theme on this construction site, edited the gallery logo out, bgcolors etc.
I think Dan ultimately released the theme we developed here on geeklog.net as "Builder Theme"

BTW, I'm one of the builders in CU-Underconstruction

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
Very cool - I am not sure what you did there or how or why... Clearly you have the gallery embedded in a custom interface but how? I think I get that I am going to need to edit some files in gallery 2 itself. Is that correct? if so, which? I looked at an archive of the old gallery embed setup and there were files replaced so that gallery would use the geeklog theme...

Also - on the http://www2.erotasbuildingcorp.com/G2Bridge/index.php page it looks like the gallery is being scaled down a bit. Am I right?
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
No editing of gallery files necessary.
G2Bridge embeds gallery.

You keep linking to http://www2.erotasbuildingcorp.com/G2Bridge/index.php
but for me the whole site is down "Unfortunately, an error has occurred rendering this page. Please try again later."

-s


FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
Now this is getting annoying - I can only access the page from one computer in my house. Since when did geeklog lock out users based on macID's. you saw it last night though didnt you?
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
Since when did geeklog lock out users based on macID's

It does not. check your settings in siteconfig.php

you saw it last night though didnt you?

Nope

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
God i hate computers - I am not going to explain, but I will concede to being an idiot at times... So - have a look and review my posts for my problems, if you would... Sorry... sheesh...
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
Gallery is not scaled its width is 100% of the available space, but I'd use a theme without a static sidebar as long as you plan on showing geeklog's left sidebar.
Like I mentioned above, try my clear theme for Gallery.

It has a slide in sidebar eg. http://www.flashyourweb.com/gallery2/erotasbuildingcorp.php?g2_itemId=32&g2_theme=clear

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
happy
I have waited far too long to do this. THANK YOU.

The g2bridge is working well despite my lamenting the learning curve to get it running. i know I could do it with ease now (I had to do it 3 times to make my content upgrade properly. Don't know why, but I don't think it was the g2bridge).

Anyways - THANK YOU supersidr for this plug-in.

Now that i have said that maybe you could help me with one more little problem I am having so I don't have to do it from scratch a 4th time. When anywhere in geeklog the path to the random images is off by one level. It works when in the gallery but not anywhere in geeklog. To see what I mean, have a look at http://www.erotasbuildingcorp.com and click on the random image block on the left. It does NOT go to the gallery page for that image.

In a nutshell, where is the path for the random image block specified?

Thanks for your help.
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
It's actually a bug in gallery's imageblock module:
gallery2/modules/imageblock/classes/ImageBlockHelper.class line 199:
Text Formatted Code
$ImageBlockData['forceFullUrl'] = 0;

to:
Text Formatted Code
$ImageBlockData['forceFullUrl'] = 1;


Glad you got it working.

Looks pretty good in my new theme too Wink

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
Ill bet that is it indeed but I cant edit the file - since the installer installed it it has the installer as its owner and not my user - I got a request in to my server admin to change the ownership on the file so I CAN edit it. I might be bugging you about changing your clear theme a little to suit my clients needs...
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 12/29/04
Posts: 555
Location:Champaign, Illinois
The preinstaller has a utility to fix filesystem permissions.
OR you can delete the file and upload a new copy.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

webbadass

Forum User
Chatty
Registered: 05/20/03
Posts: 49
The preinstaller requires opennasedir apparently... Ill wait for my admin.
 Quote

Page navigation

All times are EST. The time is now 09:34 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content