Welcome to Geeklog Tuesday, July 16 2019 @ 06:48 pm EDT

Geeklog Forums

Can't upgrade from 1.4.1


eisGeist

Anonymous
Dear Sirs,

I inherited a website running on release 1.4.1 and would like to upgrade it to the latest version of Geeklog.

I read in this forum about important changes passing from 1.4.* to 1.5.*
On my hard disk I saved the 1.5.0 and *.2, the 1.6.0 and *.1 and also the 1.7.0 tar.gz archives to move forward in more steps.

The point is I never made to complete the first step to 1.5; when I pointed the browser to: admin/install/index.php I've been walked through a few steps that ended anytime on a page with errors. Last one had this:
Notice: Undefined index: tokens in /web/htdocs/www.fips-skipatrol.org/home/geeklog/sql/updates/mysql_1.4.1_to_1.5.0.php on line 31
1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '( token varchar(32) NOT NULL, created datetime NOT NULL, owner_id me' at line 1

Thanks to the buck-up I reverted the web site to its previous status, but I now can't figure out how to complete the upgrade.

Did I miss any post or how to with the answers I'm looking for? Please let know.

Kind regards,

-- eG.


Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Sorry, not sure what would have caused the problem.

Can I suggest you do the upgrade in one step? It's not necessary to install all the intermediate versions. Just download the 1.7.0 tarball and then run the install script in upgrade mode. It'll take care of all the steps in between.

Since you're upgrading from a pre-1.5.0 version, make sure you have all your old config.php files (for Geeklog and for all the plugins) in place when you do the upgrade so that all your settings will be picked up.

bye, Dirk

eisGeist

Anonymous
I forgot to ask about the plugins.

The web site is using these:

calendar ; 1.0.0 ; 1.4.1
forum ; 2.6 ; 1.4
links ; 1.0.1 ; 1.4.1
mediagallery ; 1.4.8b ; 1.3.11
polls ; 1.1.0 ; 1.4.1
spamx ; 1.1.0 ; 1.4.1
staticpages ; 1.4.3 ; 1.4.1

I didn't read about this but, when upgradind, should they be disabled unchecking the check-box in the plug-in page?

Many thanks once more!

-- eG.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
To be on the safe side, you could disable the 3rd party plugins (Forum and MediaGallery) before the upgrade. The others are part of Geeklog and will be upgraded with Geeklog, so leave them enabled.

bye, Dirk

eisGeist

Anonymous
Quote by: Dirk

Sorry, not sure what would have caused the problem.

Can I suggest you do the upgrade in one step? It's not necessary to install all the intermediate versions. Just download the 1.7.0 tarball and then run the install script in upgrade mode. It'll take care of all the steps in between.


Thank you for your reply Dirk!
I'll try this way.


Since you're upgrading from a pre-1.5.0 version, make sure you have all your old config.php files (for Geeklog and for all the plugins) in place when you do the upgrade so that all your settings will be picked up.



I forgot to say this before, and I remember about it when I read "all your old config.php files [...] in place".

The geeklog directory it is in the home direcotry not one level above because the provider doesn't allow user to do that. It is protected with .htaccess and .htpasswd files. Could this be reason of all the mess?

Thanks in advance!

-- Luca.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: eisGeist

The geeklog directory it is in the home direcotry not one level above because the provider doesn't allow user to do that. It is protected with .htaccess and .htpasswd files. Could this be reason of all the mess?


No, this shouldn't cause any problems. Just make sure you replace all the old files so you don't end up with a mix of old and new files. The install script will probably ask you where the base Geeklog directory is - just point it to the password-protected directory then.

bye, Dirk

eisGeist

Anonymous
Quote by: eisGeist

Quote by: Dirk

Sorry, not sure what would have caused the problem.

Can I suggest you do the upgrade in one step? It's not necessary to install all the intermediate versions. Just download the 1.7.0 tarball and then run the install script in upgrade mode. It'll take care of all the steps in between.


Thank you for your reply Dirk!
I'll try this way.


Dirk, many thanks again: it worked!

I turned off the Forum and Media Gallery plug-in before starting the upgrade to 1.7 with no intermediate steps.

Along the process I decided to "upgrade" only and not "upgrade and configure plug-ins". Likely this choice took me to the plug-in errors when trying to activate MediaGallery e Forum plug-in; I can't tell, but those two releases are --maybe-- too old for GL 1.7: I'll dig into this, but I'd like your advice.

Kindly regards,

-- Luca.

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Luca,

About plugins, the last official releases are mediagallery plugin 1.5.1 and forum plugin 2.7.2

::Ben
I'm available to customise your themes or plugins for your Geeklog CMS

eisGeist

Anonymous
Quote by: cordiste

Luca,

About plugins, the last official releases are mediagallery plugin 1.5.1 and forum plugin 2.7.2

::Ben


Thank you so much, Ben!
I'm downloading them right now.

-- Luca.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Sorry, didn't see this earlier: The current Forum version is 2.7.3, which fixes a security issue.

bye, Dirk

Status: offline

rastereyes

Forum User
Newbie
Registered: 22/04/08
Posts: 2
hopeful
Greetings, All
I am the owner of a Geeklog website presently running version 1.4.1 and strongly realize my need to upgrade. My only concern is my lack of Terminal or Command Line experience. I am presuming that the 1.7.1 tar ball is similar to a self-extracting app? If someone could provide me the necessary UNIX commands in order for me to unpack the 1.7.1 tar.gz via my Mac into the correct directory upon my remote servers, I would attempt the upgrade myself. However, I would prefer chat or SKYPE assistance while performing the upgrade. Any takers?!?

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
A tarball is not self-extracting. You need an application to extract it. StuffIt Expander or The Unarchiver on a Mac (both free) can do that. Or use "tar" from the command line.

As for the actual upgrade process, did you try reading the documentation? It's not perfect, so feel free to ask specific questions.

bye, Dirk

All times are EDT. The time is now 06:48 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content