Welcome to Geeklog Tuesday, April 07 2020 @ 10:32 am EDT

Geeklog Forums

Export / Import Users from DB


Status: offline

gdl

Forum User
Chatty
Registered: 13/03/08
Posts: 39
Location:USA
I was unable to find the cause of the error that was described in this forum post. I have had to reinstall a clean version of Geeklog 1.6.1, a new database and rebuild the theme from the professional theme. All seems to be working well except for a few custom features that I am working on.

Rather than going through the old installation now and manually entering the 50 or so users that joined the website, is their an easy way to export the Users and their perms from the old Database using phpMyadmin so it may be imported to the new Database? This way all of their passwords are kept and I don't need to notify all users that they will need to retrieve their passwords again.

Thanks for any help you can offer.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Tricky. The users / groups / permissions in the database are pretty much intertwined. The IDs from the various tables have to match properly or you'll end up with odd effects and permission problems. To make things even more complicated, a fresh install will probably use different IDs for the default groups, for example, since we renumbered them in recent Geeklog versions (which is not a problem normally, since the Geeklog code identifies groups by name).

I still have no idea what may have caused your original problem. If you can provide me with a copy of your original database (the one that caused the problem with stories and static pages not showing up on the front page), I'll take a look and try if I can spot the problem.

bye, Dirk
 Quote

Status: offline

gdl

Forum User
Chatty
Registered: 13/03/08
Posts: 39
Location:USA
Thanks Dirk.

I sent you a private message with file / login info. It would be great to finally get this resolved.

I appreciate you taking a look.

-gdl
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Found it: You have multi-language support enabled, but your story IDs don't follow the required convention. I guess that was an accident?

Go to

Configuration > Geeklog > Languages and Locale > Language

and disable both the "Language Files" and "Languages" options by clicking on the (X) behind them.

Should have thought of that sooner, but the fact that the stories showed up in their topics irritated me ...

bye, Dirk
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
Go to

Configuration > Geeklog > Languages and Locale > Language

and disable both the "Language Files" and "Languages" options by clicking on the (X) behind them.


That fixed it... brilliant thanks.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

gdl

Forum User
Chatty
Registered: 13/03/08
Posts: 39
Location:USA
Wow! Thanks to the both of you for helping with this. Looks like all is well again. It's great going to sleep and waking up to an answer.

Thanks again.

-gdl
 Quote

All times are EDT. The time is now 10:32 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content