Welcome to Geeklog Tuesday, July 23 2019 @ 03:04 am EDT

Geeklog Forums

Older version


Status: offline

bcbrock

Forum User
Chatty
Registered: 04/02/03
Posts: 64
A geeklog site I have is running an older version (1.4.0sr2.) I've been hesitant to upgrade as I have written an external php application that calls many of the geeklog library functions, and I didn't want to run the risk breaking my other application by upgrading GL.

Well, I'm now looking at connecting to an Oracle database from within my custom app and in order to do that, I'm learning that I will need to upgrade my version of PHP.

My question is this: considering the fact that I'm on GL 1.4.0sr2, what is the highest version of PHP that I should be able to install without running into problems with GL?

Thank you!
~Brian

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Okay, first of all, you should upgrade to at least 1.4.0sr6. It shouldn't break anything(*) but will give you an extra bit of security. But then again we're talking about a version that's over 3 years old and not supported any more. Some of the recent security issues may also lurk in that version.

As for your actual plan: Geeklog 1.4.0 should work with PHP 5, without any special requirements (no register_globals or register_long_arrays needed). It worked with the PHP versions current at the time. Wether or not it works with PHP 5.3.0 - no idea, frankly. I can't think of a reason why it shouldn't but can't guarantee it.

bye, Dirk

(*) Strictly speaking, it will break uploading through the old version of FCKeditor included in that version. But that's a security fix and therefore a good thing ...

All times are EDT. The time is now 03:04 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content