Welcome to Geeklog Friday, September 20 2019 @ 08:33 pm EDT

Geeklog Forums

Migrating to new server


Status: offline

ofey

Forum User
Full Member
Registered: 18/03/05
Posts: 213
Location:Dublin, Ireland
I am attempting to migrate to a new server. I wanted to migrate the gl version 1.4.1 first and then update. That's seems like it should be simpler but perhaps not.

I have made a tar ball of the public and private directories and also saved the database.

I uploaded these two directories to the new server and the database also.

Then I changed config.php and lib-common.php to reflect the new settings and started an install by using 'upgrade Msql database'.

I get the following error:

Warning: require_once(/hsphere/local/home/shanegib/geeklog/system/databases/mysql.class.php) [function.require-once]: failed to open stream: No such file or directory in /home5/simongib/geeklog/system/lib-database.php on line 117

Fatal error: require_once() [function.require]: Failed opening required '/hsphere/local/home/shanegib/geeklog/system/databases/mysql.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php'Wink in /home5/simongib/geeklog/system/lib-database.php on line 117


/hsphere/local/home/shanegib/geeklog.... is the old server pathname and
/home5/simongib/geeklog.... is the new server pathname.

Line 117 of lib-database.php reads,

require_once($_CONF['path_system'] . 'databases/'. $_DB_dbms . '.class.php'Wink;

Is there something else I should be doing?

Shane
Those who say it can't be done, are usually interrupted by others doing it.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: ofey

That's seems like it should be simpler but perhaps not.


You may want to try our spiffy new Migrate option in 1.6.0.

The old way (pre-1.6.0) is documented here: Migrating a Geeklog site


In your case, it looks like you did not update all the paths properly in config.php. Double-check that.

bye, Dirk

Status: offline

ofey

Forum User
Full Member
Registered: 18/03/05
Posts: 213
Location:Dublin, Ireland
Hi Dirk,

Yes I did have errors in my config.php file. I am getting to step 2 of 2 with this,

Geeklog Database Settings (Step 2 of 2)

Now we are ready to add the necessary data structures to your Geeklog database. If you are upgrading, please be sure to select the current version of your Geeklog database below. If this is a new installation, just hit the 'Next' button. We hope that at this point you have already backed-up your existing database (if you have one). If you haven't then do so before clicking the 'Next' button below. You've been warned.

Database already up to date!

It looks like your database is already up to date. You probably ran the upgrade before. If you need to run the upgrade again, please re-install your database backup first!


However, there is only a 'back' button and no 'next' button. This is odd.

Thanks,

Shane
Those who say it can't be done, are usually interrupted by others doing it.

Status: offline

ofey

Forum User
Full Member
Registered: 18/03/05
Posts: 213
Location:Dublin, Ireland
Site now works if I stick index.php on end of url like so.

www.domainname.com/index.php

Thanks for your help Dirk, I am ok now

Shane
Those who say it can't be done, are usually interrupted by others doing it.

All times are EDT. The time is now 08:33 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content