Welcome to Geeklog Sunday, May 19 2019 @ 07:19 am EDT

Geeklog Forums

Errors: Cannot modify header information


Asiya

Anonymous
I upgraded from 1.5 to 1.6. Everything went fine. I then read about the updated 1.6 features on this website and so I set my Compressed Output setting to True. It was the only setting I changed in response to the upgrade. Now, every page of my website returns multiple error messages and I cannot get into the Admin area.

My url is www.asiya.org, and you will see:

Warning: Cannot modify header information - headers already sent by (output started at /home/asiya/public_html/layout/pure/functions.php:367) in /home/asiya/public_html/lib-common.php on line 6718

Warning: Cannot modify header information - headers already sent by (output started at /home/asiya/public_html/layout/pure/functions.php:367) in /home/asiya/public_html/lib-common.php on line 6719
Unfortunately, an error has occurred rendering this page. Please try again later.


I have read about this error and removed the white space from both pages mentioned (layout/pure/functions.php and lib-common.php). I have attempted to find within the files a way to turn off Compressed Output, but I can't locate it. I have also completely re-installed 1.6 to my web space. None of this has worked. How can I fix this?

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Must be something in the Pure theme's functions.php file, as can be seen from this part of the error message:
output started at /home/asiya/public_html/layout/pure/functions.php:367

I'm not familiar with that theme. Anything out of the ordinary in that line in this file?

bye, Dirk

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Everything seems to work now. Line 6718 is for error message when you get a 500 Internal Server Error.

::Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

stuffdone

Forum User
Newbie
Registered: 05/09/12
Posts: 1
Question: The program I installed gives me this error and white screen.

I read the info on this error regarding white spaces added when editing. After install and configuration, when I logged out of admin then tried to log back in again I get the error and a blank white page as described here.

I have not touched any files at all other than to replace the header logo image.

Since I have not manually edited any files how do I determine what is causing this error and how do I fix it?

All times are EDT. The time is now 07:19 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content