Welcome to Geeklog Thursday, September 19 2019 @ 03:05 pm EDT

Geeklog Forums

Story Title Missing on index.php


Status: offline

DiRT

Forum User
Newbie
Registered: 13/04/08
Posts: 13
confused
OK... *deep breath*

So I added Geeklog to another site I'm working on http://thatnewtoysmell.com/index.php and while the original site they built is available at the index.html, I'm working on Geeklog so then can migrate over and get rid of the static html site they've been making in Frontpage. They have GL 1.5.X and really wanted the Stainless-Raven theme layout. The only problem is that SR is a 1.4.X theme and didn't play well with the admin pages in 1.5.X, so I tried mixing it with some files from clean_black which was modified to work with 1.5.X, and the results have been pretty good. One small thing is that the topic icon is on the left and I'd like it on the right of the story posts, but that's no big deal. The bigger issue is that the title of the story doesn't appear on the index.php page, but it does appear on each story page. I've done so much in the last 24 hours that I can't even remember where to even look to try to fix it!

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
1.5 relies more on CSS to position things like the topic icon. Compare with the Professional theme - you're probably missing a CSS class.

Which version are you on exactly now? There was a bug that could make the story title disappear. You may want to upgrade to 1.5.2. Otherwise, you could change the theme to use some of the other template variables to get the title back.

bye, Dirk

Status: offline

DiRT

Forum User
Newbie
Registered: 13/04/08
Posts: 13
It's running 1.5.1. But I found that my attempt to update Stainless Raven to 1.5.X was the failure. Where can I find how to update it correctly? We really need a dark theme for this site and apparently very few dark Geeklog themes have ever been attempted.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
I fixed the above link now (sorry) to point to the list of theme changes. However, it doesn't list the CSS changes.

If you check the HTML, you'll notice that the topic icon uses a class "floatright"(*) that you're probably missing. Refer to the style.css from the Professional theme for details.

bye, Dirk

(*) You can actually set the topic icon alignment in the configuration. Right is the default, but it could also be left-aligned, in which case the class name would be "floatleft".

All times are EDT. The time is now 03:05 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content