Welcome to Geeklog, Anonymous Sunday, July 21 2024 @ 06:40 am EDT

Geeklog Forums

I just installed and got this error:


Status: offline

darren

Forum User
Newbie
Registered: 09/12/08
Posts: 3
Results of the Security Check
Good! You seem to have removed the install directory already.
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
Good! You seem to have changed the default account password already.

Please advise: thanks.
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 01/14/05
Posts: 1569
Location:la rochelle, France
Hi Darren,

Can you clear the situation?

Thanks.

::Ben


I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
That's the output of admin/sectest.php. It tries to check if certain files and directories are accessible from the web (when they shouldn't be).

Never seen that specific error message before, though. A quick Google search seems to indicate a problem with the webserver setup (maybe even deliberatly for security reasons) when trying to open a socket.

Darren, if you set up your site such that db-config.php, the logs, plugins, and system directories are not accessible from the web (i.e. through a URL that you can type into a browser), then you should be fine.

Need to check if we can fail a bit more graciously here (and with more informative error messages) ...

bye, Dirk
 Quote

bellatorisopacus@nomenarcanum.com

Anonymous
curious
I just installed as well and am getting an identical message. Is there a fix for this or can it safely be ignored?
 Quote

Valcav

Anonymous
worried
I've just installed it and just received the same...

Results of the Security Check

1. Good! You seem to have removed the install directory already.
2. php_network_getaddresses: getaddrinfo failed: Name or service not known
3. php_network_getaddresses: getaddrinfo failed: Name or service not known
4. php_network_getaddresses: getaddrinfo failed: Name or service not known
5. php_network_getaddresses: getaddrinfo failed: Name or service not known
6. php_network_getaddresses: getaddrinfo failed: Name or service not known
7. php_network_getaddresses: getaddrinfo failed: Name or service not known
8. Good! You seem to have changed the default account password already.

Please fix the above issues before using your site!
 Quote

Valcav

Anonymous
confused
I've just installed it and just received the same...

That was on the root adress...

Now i've installed it in a new folder, and now its ok...
How is that possible???

PS: the 2 were version 1.5.1 ...

I don't know how or why...
Valcav
 Quote

iam

Anonymous
Quote by: Valcav

I've just installed it and just received the same...

That was on the root adress...

Now i've installed it in a new folder, and now its ok...
How is that possible???

PS: the 2 were version 1.5.1 ...

I don't know how or why...
Valcav


my experience, if you install gl in to your public_html directory without to create a private folder outside the webroot you will get this Security massage. if you install at a subdomain it is OK .
 Quote

Haakuturi

Anonymous
confused
So is it possible to correct this for those of us that installed in public_html/ ? I've got the same error messages >.<


Results of the Security Check

Good! You seem to have removed the install directory already.
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
php_network_getaddresses: getaddrinfo failed: Name or service not known
Good! You seem to have changed the default account password already.
Please fix the above issues before using your site!
 Quote

Status: offline

haakuturi

Forum User
Newbie
Registered: 02/10/09
Posts: 3
I have this as well, and also installed in the root directory >.<
 Quote

All times are EDT. The time is now 06:40 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content