Welcome to Geeklog, Anonymous Thursday, August 11 2022 @ 04:30 am EDT

Geeklog Forums

Install/Upgrade over 1.3.11sr1


WeyrCat

Anonymous
worried
Hi. I'm worried to run the "Upgrade" over my current because my DB Backup option does not work and I'd hate to lose everything. (I've moved years of posts into this thing, and would be truly mortified to lose all that data.)

I think I do need to upgrade though, even my SpamX doesn't work (which creates a few problems when I get hit with 563 Anonymous posts on several entries. Will upgrading overwrite everything? /Posts, background preferences, static pages, eh?

Thank you for your help.

weyrcat (at) gmail.com
http:/www.weyrcat.com/blog
 Quote

Status: offline

beewee

Forum User
Full Member
Registered: 08/05/03
Posts: 969
Location:The Netherlands, where else?
You have to upgrade tot GL1.41 first, and then to GL1.50. Your database should remain intact, but DO NOT UPGRADE WITHOUT BACKUP. You can't make a backup with your hosting control panel, or with phpMyAdmin?

And have a look at your plugins to make sure they work on GL1.50.
Dutch Geeklog sites about camping/hiking:
www.kampeerzaken.nl | www.campersite.nl | www.caravans.nl | www.caravans.net
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Not having a backup is not a good thing, even if you didn't plan to upgrade. If the built-in backup doesn't work for you, there are other options, eg. using phpMyAdmin.

Upgrading will make changes to the database structure. Your content (stories, etc.) will remain unchanged of course. However, you should have a backup (and know how to restore it!) just in case something goes wrong during the upgrade, which could potentially leave you with a version of the database that's neither compatible with the old nor the new version.

Contrary to what beewee said, you can upgrade directly from 1.3.11 to 1.5.0 in one step - Geeklog's upgrade script will perform all the necessary steps in between for you.

bye, Dirk
 Quote

Status: offline

beewee

Forum User
Full Member
Registered: 08/05/03
Posts: 969
Location:The Netherlands, where else?
Quote by: Dirk


Contrary to what beewee said, you can upgrade directly from 1.3.11 to 1.5.0 in one step - Geeklog's upgrade script will perform all the necessary steps in between for you.
bye, Dirk



Hey, that's new for me, thanks!
Dutch Geeklog sites about camping/hiking:
www.kampeerzaken.nl | www.campersite.nl | www.caravans.nl | www.caravans.net
 Quote

All times are EDT. The time is now 04:30 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content