Welcome to Geeklog Saturday, September 25 2021 @ 06:19 am EDT

Geeklog Forums

Few problems


drb

Anonymous
Hey all,
I have few small issues with GL here is what I use:

1. GL 1.4.1 installed fresh.
2. Chameleon: layout 1 stretched, with dark blue color scheme
3. Forum 2.7 installed fresh
4. Media gallery installed fresh with structure imported from 4images.
5. FCKeditor is set to enable in the conffig and here is the issue:
Story Editor --> Post mode = Advance Editor
When clicking in the text field to write a text it shrinks to a single line. Clicking on the + or - sign next to Intro text does change the size of the text field but once it gets the focus it will shrink back to one line.
How to fix that ?

2 Issue is with Media gallery. Trying to post a remote media YouTube link results in this:

An error has occurred:
2 - Cannot modify header information - headers already sent by (output started at /layout/chameleon/functions.php:337) @/layout/chameleon/functions.php line 335

any ideas.
drb

sorry for the double post the last one I posed at gllabs forum for chameleon but no replies yet..kind deserted

THNX
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Generally for trouble shooting you may additionally install the standard theme 'professional' and see if the edit problem still consists. Also you may disable the forum and gallery to see stp by step what happens.
 Quote

drb

Anonymous
Ok,
I switched off the Chameleon skin and restored the professional template
media gallery off as well as the forum is off

there was no change with the editor the text field sill resizes to one line when it gets the focus.

drb
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Well, try something Big Grin

You may copy over the subdirectory of the editor again. A file might be faulty or so.

What browser is it anyway?
 Quote

Status: offline

geiss

Forum User
Full Member
Registered: 10/02/04
Posts: 176
Location:Boise, Idaho
Hi again drb,

I don't think you were deserted over at gl Labs, people just get busy. Mark was out at a funeral the past couple of days, and I've been swamped at work. Nevertheless, we've both been able to acknowledge your posts over there, so please be patient with us. Big Grin

Regarding the Advanced Editor window size, I can't reproduce your issue on my test system with Chameleon, but if you can see the advanced editor toolbar buttons, look for the blue monitor button. In the Common Toolbar, it is the second to the last button on the right in the second row - it says Maximize the editor size. This will make that input window fullscreen. This has helped me when I've had alot to enter and didn't want to scroll around a lot.

Hope this helps, and we'll continue to help you out over at gl Labs' forum with your other issues. Big Grin

Thx!

Eric
Synergy - Stability - Style --- Visit us at glfusion.org
 Quote

drb

Anonymous
Yea Geiss,.sorry bout the deserted thing Oops!
I tried the blue box to the right and it works just right, but the txtfield resize still remains. It might be a faulty installation. will see...

thnx..

drb
 Quote

Status: offline

geiss

Forum User
Full Member
Registered: 10/02/04
Posts: 176
Location:Boise, Idaho
Yeah, if you are having problems even with the Professional theme, then you might want to replace your theme files with fresh copies from the geeklog v1.4.1 tarball, as well as refreshing the theme files for Chameleon. Perhaps something got messed up when you uploaded them to your webserver.

Also, what are your settings in config.php for:

$_CONF['postmode']

$_CONF['advanced_editor']


Thx!

Eric

Synergy - Stability - Style --- Visit us at glfusion.org
 Quote

drb

Anonymous
advanced_editor = true
right but I still have to select it from the drop down menu of the textbox..then the toolbar comes up and when I click on the textbox to type it shrinks to one line.
I installed it using the Fantastico...going to download the tarball see if that helps.

drb
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Actually I do remember such a behaviour but I can`t reproduce it now either. Check your JavaScript settings of the browser etc. The FCKeditor is depending on that. What browser is it?
 Quote

drb

Anonymous
Using FireFox. I tryed to update the FCKeditor messed up my site restored the "old one"...still same issues

drb
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
The problem with the FCKeditor resizing the window down to 1 line with FireFox is actually by design. There is a plugin that comes pre-installed with the editor called AutoGrow that tries to dynamically resize the edit window based on what is currently in the editor. Nothing there, it resizes to 1 line.

Turn it off by editing the fckconfig.js file in the public_html/fckeditor/ directory. Search for autogrow and either remove or comment out that line.

Keep in mind that you must completely clear your local browser cache to see any changes you make to the FCKeditor.

I believe we solved your Remote Media problems with Media Gallery in this thread at gllabs.

Thanks!
Mark
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 16/07/02
Posts: 1232
Location:Canada
The autogrow plugin for the FCKeditor was actually a feature that we Nextide funded and had Fred develop. We had a client project where I used the editor in a form with 5 or more textarea input fields. They really wanted this feature so the editor area would collapse but grow automatically as you entered new lines. You are able to define in the editor config file, how many lines to have it grow before the scrollbars will appear and as Mark noted, it can be disabled.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

All times are EDT. The time is now 06:19 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content