Welcome to Geeklog, Anonymous Tuesday, June 28 2022 @ 04:52 am EDT

Geeklog Forums

Errors during install

Page navigation


Brian

Anonymous
Hi, I've looked at other people's posts with very similar errors, but I just can't figure out what I need to change. I've edited the config.php and also lib-common.php and I'm getting the following errors during install....

Warning: require_once(system/databases/mysql.class.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/socalstandup.com/httpdocs/oasis/system/lib-database.php on line 117

Fatal error: require_once() [function.require]: Failed opening required 'system/databases/mysql.class.php' (include_path='.:.:'Wink in /var/www/vhosts/socalstandup.com/httpdocs/oasis/system/lib-database.php on line 117


Can you please tell me where the source of this problem is? I don't see anything missing or wrong in the config.php but I could be wrong.

Thanks!
Brian
 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 08/29/05
Posts: 985
Your $_CONF['path'] must not be set or you've edited your $_CONF['path_system'].
 Quote

brian

Anonymous
Quote by: jmucchiello

Your $_CONF['path'] must not be set or you've edited your $_CONF['path_system'].



Thanks for your reply Jmucchiello...

I believe I do have my paths filled out though. Here's what the paths section in config.php looks like... (I think I put my paths in places that were not even necessary because I kept getting errors.. there was 3 errors before and after putting them in other places it was reduced to 2.) I know, I'm not very savvy here. This one is a bit more complex than other scripts i've installed, even if the answer is right in front of my nose.. ha Thaks for your help... Here's the paths section of conifg.php


// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '\' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['/var/www/vhosts/socalstandup.com/httpdocs/oasis/'] = '/var/www/vhosts/socalstandup.com/httpdocs/oasis/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['/var/www/vhosts/socalstandup.com/httpdocs/signup/'] = $_CONF['/var/www/vhosts/socalstandup.com/httpdocs/signup/'] . '/var/www/vhosts/socalstandup.com/httpdocs/signup/';


 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Erm, you're supposed to leave the stuff to the left of the = sign as it is. So change those back to $_CONF['path'], etc.

bye, Dirk
 Quote

Brian

Anonymous
Quote by: Dirk

Erm, you're supposed to leave the stuff to the left of the = sign as it is. So change those back to $_CONF['path'], etc.

bye, Dirk



First off, I'd really like to thank you for your quick responses... I'm also buying the event plugin as soon as I get this installed correctly.

So, I edited the paths section and now there's 3 errors. I'll copy and paste the errors and then my new paths section. Thanks again...

Warning: require_once() [function.require-once]: Unable to access /path/to/geeklog/system/databases/mysql.class.php in /var/www/vhosts/socalstandup.com/httpdocs/oasis/system/lib-database.php on line 117

Warning: require_once(/path/to/geeklog/system/databases/mysql.class.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/socalstandup.com/httpdocs/oasis/system/lib-database.php on line 117

Fatal error: require_once() [function.require]: Failed opening required '/path/to/geeklog/system/databases/mysql.class.php' (include_path='.:.:'Wink in /var/www/vhosts/socalstandup.com/httpdocs/oasis/system/lib-database.php on line 117

--------------------

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '\' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['path'] = '/path/to/geeklog/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['/var/www/vhosts/socalstandup.com/httpdocs/oasis/']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['path_html'] = $_CONF['/var/www/vhosts/socalstandup.com/httpdocs/signup/'] . 'public_html/';
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
You're still not doing it right. All the $_CONF['something'] are variable names (technically: elements of an array) and need to be left alone - even if they happen to be on the right side of the = sign (sorry, missed that case).

And where it says '/path/to/geeklog/', you are supposed to fill in your actual path. So:
Text Formatted Code
$_CONF['path'] = '/var/www/vhosts/socalstandup.com/httpdocs/oasis/';

$_CONF['path_html'] = $_CONF['path'] . 'public_html/';

bye, Dirk
 Quote

Brian

Anonymous
Thanks a lot... It seemed to work, I didn't check the box on the next page, but then it tried to take me to http://www.socalstandup.com/admin/install/success.php

and it came up with "the webpage cannot be found" page... I believe it should be http://www.socalstandup.com/signup/admin/install/success.php since that's where the admin folder is, but even when I tried to navigate there manually it didn't work.

Thanks again...

 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
That's the bit about public_html in the documentation. For now, you would need to add /public_html to your $_CONF['site_url'].

bye, Dirk
 Quote

Brian

Anonymous
Oh, also... While we're at it... I emailed about that event plugin. Emailed to your paypal email address. Not sure if you check that or not. How long would it take to get invoiced for that. It's the reason I'm installing this.

Not sure what else I did wrong to lead me to the wrong screen at the end, but it does not seem to be successfully installed.

P.S. Dragon's Lair used to be my favorite game, Dirk the daring!!!

Brian

 Quote

Brian

Anonymous
Quote by: Dirk

That's the bit about public_html in the documentation. For now, you would need to add /public_html to your $_CONF['site_url'].

bye, Dirk

[/QUOTE

I changed the folder from /public_html to /signin... I thought that's what I had in the config.php
 Quote

Brian

Anonymous
Ah, okay, i see whatcha mean now. I changed it to /signup and went back on my browser and it said i didn't have to run the install script again. But it still doesn't seem to be working. page not found at /signin
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Brian

I emailed about that event plugin. Emailed to your paypal email address. Not sure if you check that or not. How long would it take to get invoiced for that. It's the reason I'm installing this.


My PayPal account address is also my normal email address - the one that can be found in almost every single one of Geeklog's .php files. Therefore, it is of course all over the place and receives a lot of spam. Try using the word "Geeklog" in the subject somewhere to increase your chances of the email making it through.

I don't remember any recent emails about the Calendar plugin. Or are you confusing me with Joe (who answered the first couple of your questions above)? Joe is doing the programming on that plugin, I have only offered to collect the money until he's done.

Also, there's no invoicing involved - you donate what it would be worth to you.

bye, Dirk
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Brian

Ah, okay, i see whatcha mean now. I changed it to /signup and went back on my browser and it said i didn't have to run the install script again. But it still doesn't seem to be working. page not found at /signin


signup or signin? Make up your mind :wink:

bye, Dirk
 Quote

Brian

Anonymous
Quote by: Dirk

Quote by: Brian

Ah, okay, i see whatcha mean now. I changed it to /signup and went back on my browser and it said i didn't have to run the install script again. But it still doesn't seem to be working. page not found at /signin


signup or signin? Make up your mind :wink:

bye, Dirk



My bad, signup... I have signup on the config file and on the directories.

In regards to the email... I actually sent 2... Both to paypal@portalparts.com It's for the event manager plugin...
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Brian

Both to paypal@portalparts.com It's for the event manager plugin...


Well, in that case you should be talking to Blaine. Completely different plugin than the one I was talking about above, it seems ...

bye, Dirk
 Quote

Brian

Anonymous
Oh! Maybe this is a 3rd party's plugin? In the description of the plugin, it says it integrates with the geeklog calendar... That's when I found you guys. Hopefully they did not mean something else. Here's a link... http://www.portalparts.com/paypal/product_detail.php?product=3
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Brian

My bad, signup... I have signup on the config file and on the directories.


Just guessing from the paths you posted: Maybe you also need to stick an "oasis" in there somewhere?

It really depends on how your webserver is configured, i.e. how your URL maps to the file system and the directories ...

bye, Dirk
 Quote

Brian

Anonymous
Quote by: Dirk

Quote by: Brian

My bad, signup... I have signup on the config file and on the directories.


Just guessing from the paths you posted: Maybe you also need to stick an "oasis" in there somewhere?

It really depends on how your webserver is configured, i.e. how your URL maps to the file system and the directories ...

bye, Dirk



Well this is how I did it. I could not make a directory outside the public folder, so i did the alternate install method of making 2 directories and password protecting the 2nd one. (oasis)

So this is how I have my paths now...

// This should point to the directory where your config.php file resides.
$_CONF['path'] = '/var/www/vhosts/socalstandup.com/httpdocs/oasis/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['path_html'] = $_CONF['/var/www/vhosts/socalstandup.com/httpdocs/signup/'] . 'public_html/';

Thank you..
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Brian

Oh! Maybe this is a 3rd party's plugin?


In a way. Blaine is one of the core Geeklog developers, but he's also selling add-ons via his website. I just wasn't aware of this particular plugin and so confused it with another one (well, and you confused me with him, which didn't help :wink:

bye, Dirk
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Brian

So this is how I have my paths now...


I hope not. Since this contains the same mistake as above again (changing the name of a $_CONF variable).

Poking around on what I assume your website is, you should have
Text Formatted Code
$_CONF['site_url'] = 'http://www.socalstandup.com/signup';

That URL seems to work, only it's giving a blank page now, probably due to the above mistake. Fix that, then try again.

bye, Dirk
 Quote

Page navigation

All times are EDT. The time is now 04:52 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content