Welcome to Geeklog Sunday, January 17 2021 @ 02:21 am EST

Geeklog Forums

Unregistered User Comments Accepted but not displayed


BMcDonald

Anonymous
I have the system set to not allow unregistered users to post comments, but the system is accepting them anyway. It's just won't display them. I got a person submit a comment this morning. I got an email notice, and when I log on, it shows another comment was submitted, but no comment is actually there. The number of comments on the story increased, but no actual comment displays. So there's no way to delete it so the number of comments are inaccurate. It should show "0" comments, but it shows "2" It sure would be nice if the system gave them an error page if an unregistered person submits a comment.

Any ideas?

Thanks
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Which Geeklog version are we talking about? We had a few bugs that still allowed comments to be posted under certain circumstances, even when it wasn't supposed to be possible. These bugs should all be fixed in 1.4.0 or later, though.

bye, Dirk
 Quote

BMcDonald

Anonymous
It's 1.4.1

I tested it by trying to post a comment without logging in. It accepted the post but didn't display it, just the count. Then I logged in to post it and it accepted it and displayed it so I could delete it. It's pretty straightforward. No strange circumstance.

My site is http://www.KickThemAllOut.com
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Something's wrong there - if comments are closed to anonymous users, they shouldn't even be able to get to the comment submission form (see here on geeklog.net, for example).

Are you sure you're using the original lib-comment.php and comment.php on your site?

bye, Dirk
 Quote

BMcDonald

Anonymous
I replaced lib-comment.php and comment.php from a fresh download and it's still doing the same thing. I just don't get it. Very strange. It sure would be nice to fix this.
 Quote

BMcDonald

Anonymous
DUH!

I just looked at the config file for the millionth time and finally saw what the problem was. I didn't set the comment config to require login before comments. Everything was set to zero. I just put a 1 on 'commentsloginrequired' and it's doing what it's supposed to do.

// +---------------------------------------------------------------------------+
// | MISCELLANEOUS SETTINGS |
// | |
// | These are other various Geeklog settings. The defaults should work OK |
// | for most situations. |
// +---------------------------------------------------------------------------+

// this lets you select which functions are available for registered users only
$_CONF['loginrequired'] = 0; // all of them, if set to 1 will override all else
$_CONF['submitloginrequired'] = 1;
$_CONF['commentsloginrequired'] = 1;
$_CONF['statsloginrequired'] = 0;
$_CONF['searchloginrequired'] = 0;
$_CONF['profileloginrequired'] = 0;
$_CONF['emailuserloginrequired'] = 1;
$_CONF['emailstoryloginrequired'] = 0;
$_CONF['directoryloginrequired'] = 0;
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
/* No Comment */ Mr. Green
 Quote

TIM

Anonymous
How do I limit "story comments to only registered users?"
I found this quote below searching through some of your old posts, however this is for version 1.4.0 or something. I am using 1.5.1 and would think it would be simpler than this.

can I limit it from admin control, configuration or something, if so where, because I have not found the option yet.

thanks, tim


Quote by: BMcDonald

DUH!

I just looked at the config file for the millionth time and finally saw what the problem was. I didn't set the comment config to require login before comments. Everything was set to zero. I just put a 1 on 'commentsloginrequired' and it's doing what it's supposed to do.

// +---------------------------------------------------------------------------+
// | MISCELLANEOUS SETTINGS |
// | |
// | These are other various Geeklog settings. The defaults should work OK |
// | for most situations. |
// +---------------------------------------------------------------------------+

// this lets you select which functions are available for registered users only
$_CONF['loginrequired'] = 0; // all of them, if set to 1 will override all else
$_CONF['submitloginrequired'] = 1;
$_CONF['commentsloginrequired'] = 1;
$_CONF['statsloginrequired'] = 0;
$_CONF['searchloginrequired'] = 0;
$_CONF['profileloginrequired'] = 0;
$_CONF['emailuserloginrequired'] = 1;
$_CONF['emailstoryloginrequired'] = 0;
$_CONF['directoryloginrequired'] = 0;

 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
The config.php options are now available from the Admin's Configuration panel:

Configuration > Geeklog > Users and Submissions > Users

bye, Dirk
 Quote

All times are EST. The time is now 02:21 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content