Welcome to Geeklog Monday, December 09 2019 @ 01:24 pm EST

Geeklog Forums

Cannot change the public_html directory


Status: offline

Johnny999

Forum User
Newbie
Registered: 02/11/07
Posts: 4
angry
I have spent hours trying to edit Geeklog so that it will run in the root directory and not in public-html. Nothing I do works.probably because I am not doing it correctly. I have read the directions and still cannot make it work. I changed the path and then I can't get Geeklog to run at all. All I see are errors.

Can anyone help me make the necessary changes to make this work?
 Quote

Status: offline

ofey

Forum User
Full Member
Registered: 18/03/05
Posts: 213
Location:Dublin, Ireland
I would be a good idea to post your errors and explain exactly what you did.
Those who say it can't be done, are usually interrupted by others doing it.
 Quote

Status: offline

Johnny999

Forum User
Newbie
Registered: 02/11/07
Posts: 4
Quote by: ofey

I would be a good idea to post your errors and explain exactly what you did.



The errors are probably irrelevant. The problem is when I try to edit config.php, I really don't understand exactly how/where to edit. When I have tried it, I just get errors showing me I messed up one or more of the paths.

I am trying to install geeklog at www.burlingtonnewsroom.com but it's looking like a lost cause.

If someone here has a few minutes and feel like lending your expertise to a dumbass (mainly me), it's possible to save hours and hours if someone just pops in the Path in a config.sys file for me and I can just copy it to the server and then move the files that need to be moved.

Thanks for any help getting me up and running before 2008! LOL!

John

P.S. You can also email me directly at vermont.john@yahoo.com
 Quote

Status: offline

nikebound

Forum User
Junior
Registered: 04/11/07
Posts: 15
Depending on your situation, you may or may not want to remove geeklog from the public_html directory. If you don't have someplace to stash the other directories that's not viewable, you probably won't want to pull geeklog out of the public directory.
I have godaddy & they set me up as /usr..../example/html/ that's nice but there's no access to any of the directories above /html/ - so everything in my ftp space is visible from the web.
I left the public_html directory & created a DNS entry for gl.example.com to point to it. I then put a .htaccess file in the root directory - redirecting everything to gl.example.com. Tossing .htaccess files into all of the other directories from geeklog, I set them to 'require valid_user' so that nobody can list the directories or anything else (I also did this for the public_html/admin directory.

I'm still not sure why godaddy would set up example/html/ without setting up example/cgi-bin or anything else as well, but that seems to be how it is.

If you really want to pull the public_html directory out, you need to change the 2 $_conf[''] settings for 'path' & 'url'
 Quote

Status: offline

Johnny999

Forum User
Newbie
Registered: 02/11/07
Posts: 4
Quote by: nikebound

Depending on your situation, you may or may not want to remove geeklog from the public_html directory. If you don't have someplace to stash the other directories that's not viewable, you probably won't want to pull geeklog out of the public directory.
I have godaddy & they set me up as /usr..../example/html/ that's nice but there's no access to any of the directories above /html/ - so everything in my ftp space is visible from the web.
I left the public_html directory & created a DNS entry for gl.example.com to point to it. I then put a .htaccess file in the root directory - redirecting everything to gl.example.com. Tossing .htaccess files into all of the other directories from geeklog, I set them to 'require valid_user' so that nobody can list the directories or anything else (I also did this for the public_html/admin directory.

I'm still not sure why godaddy would set up example/html/ without setting up example/cgi-bin or anything else as well, but that seems to be how it is.

If you really want to pull the public_html directory out, you need to change the 2 $_conf[''] settings for 'path' & 'url'



I am hosting on Godaddy as well. The problem is I am not changing the $_conf[''] settings for 'path' & 'url' settings correctly. Every combination I try messes it up. I just am not doing it right. Do you feel like taking a few minutes and making some quick changes to any files that need to be changed with the path info I can give you? That would help. The Geeklog is sitting dead at www.burlingtonnewsroom.com :-(



 Quote

Status: offline

nikebound

Forum User
Junior
Registered: 04/11/07
Posts: 15
did you install manually or through godaddy?
My automatic install SNAFU'd twice on the install & I ended up ftping it up from my home box.
 Quote

All times are EST. The time is now 01:24 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content