Welcome to Geeklog Tuesday, August 04 2020 @ 02:02 am EDT

Geeklog Forums

Media Gallery


Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
Hello,
I just installed latest version of geeklog software and I created a new website with subdomain www.mywebsite.org /ba of my old website www.mywebsite.org
I have installed media gallery 1.2.6. plugin on both of this websites and I have both websites on same server,with same name just new website have /ba on the end of domain name .
Can you tell me how can I transfer all albums and pictures from www.mywebsite.org to www.mywebsite.org/ba ?
Can I just switch some files in media gallery directories in my ftp server?
If I can..please tell me name of this files and path to guide and finde this files in plugin directories..
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Did you see this? http://www.geeklog.net/faqman/index.php?op=view&t=37 Did you edit the abolut path in the gallery settings?
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
Thanks for link.. Smile
How can I edit the abolut path in the gallery settings?
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
It is a bit hidden in "graphics opackage" /admin/plugins/mediagallery/cfgedit.php
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Denis,

If you want to 'move' Media Gallery from one site to another, you will have to perform an SQL dump of all the Media Gallery database tables and import them to the new site's database. Also, copy the entire contents of public_html/mediagallery/mediabojects/* to your new site.

There are no tools built into Media Gallery to do this, you'll need to use a DB tool such as phpMyAdmin to create the database dumps and to import them to the new site.

Thanks!
Mark
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
Hello,
i installed Mediagallery 1.2.6 on my new geeklog website.With ftp I transfered all pictures to this media gallery folders from my old geeklog website mediagallery.I transfered all pictures in 3 folders,followed instructions from PluginInstallOverview.jpg ,under :
<geeklog_dir>/public_html/mediagallery/mediabojects,
<geeklog_dir>/public_html/admin/plugins/mediagallery/mediabojects,
<geeklog_dir>/public_html/layout/mytheme/mediagallery/mediabojects,



and I can see that all this pictures is there in this folders /mediagallery/mediabojects but my mediagallery on my website look still empty and no one picture is not showing up.
What is wrong?
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Denis,

As I metioned in my previous post, you also need to export the Media Gallery database tables and import them into your new site. Just copying over the contents of the mediaobjects/* directories is only half of the process.

Extracting the old data out of the database and importing into the new database is not a trival task and unless you are very familiar with tools like phpMyAdmin, it may be more than you want to bite off.

I may be able to write a quick and dirty PHP script to export the old database and import into the new one. Unfortunately I'm fighting home repairs today and won't have time to look into it for a couple of days.

Thanks!
Mark

 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
In database I see :


gl_mg_media
gl_mg_media_albums -
gl_mg_media_album_queue
gl_mg_media_queue


Which one I need extract and import into new site?
This will be my first time and I don't like to mess up with data base..
If you can help me with this in couple days I can wait.
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
If you want to give it a try, export all the tables that start with gl_mg_. I'll look at writing a quick dump/restore (I think it would be a handy script to have around for others too) in the next day or two if you want to wait.

Thanks!
Mark
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
OK..
In phpMyAdmin I check marked all the tables that start with gl_mg_ and in Export block I highlighted all gl_mg_ ,I check marked to select "SQL" and I clicked on "Go".
Then huge tekst dokument "phpMyAdmin SQL Dump"showed up .
This is copy of one small part of this document:
-- phpMyAdmin SQL Dump
-- version 2.10.0.2
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Oct 20, 2007 at 10:17 PM
-- Server version: 4.1.22
-- PHP Version: 4.4.2

SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";

--
-- Database: `nine_gklg3`
--

-- --------------------------------------------------------

--
-- Table structure for table `gl_mg_albums`
--

CREATE TABLE `gl_mg_albums` (
`album_id` int(11) NOT NULL default '0',
`album_title` varchar(255) NOT NULL default '',
`album_desc` text NOT NULL,
`album_parent` int(11) NOT NULL default '0',
`album_order` int(11) NOT NULL default '0',
`album_cover` varchar(40) NOT NULL default '-1',
`album_cover_filename` varchar(255) default '',
`media_count` int(11) unsigned NOT NULL default '0',
`last_update` int(11) NOT NULL default '0',
`enable_comments` tinyint(4) NOT NULL default '0',
`exif_display` tinyint(4) NOT NULL default '0',
`enable_rating` tinyint(4) NOT NULL default '0',
`playback_type` tinyint(4) NOT NULL default '0',
`tn_attached` tinyint(4) NOT NULL default '0',
`enable_slideshow` tinyint(4) NOT NULL default '0',
`enable_random` tinyint(4) NOT NULL default '0',
`enable_shutterfly` tinyint(4) NOT NULL default '0',
`enable_views` tinyint(4) NOT NULL default '0',
`enable_sort` tinyint(4) NOT NULL default '0',
`albums_first` tinyint(4) NOT NULL default '1',
`full_display` tinyint(4) NOT NULL default '0',
`tn_size` tinyint(4) NOT NULL default '0',
`display_rows` tinyint(4) NOT NULL default '3',
`display_columns` tinyint(4) NOT NULL default '3',
`member_uploads` tinyint(4) NOT NULL default '0',
`moderate` tinyint(4) NOT NULL default '0',
`email_mod` tinyint(4) NOT NULL default '0',
`featured` tinyint(4) NOT NULL default '0',
`cbposition` tinyint(1) NOT NULL default '0',
`cbpage` varchar(20) NOT NULL default '',
`owner_id` mediumint(9) NOT NULL default '0',
`group_id` mediumint(9) NOT NULL default '0',
`mod_group_id` mediumint(9) NOT NULL default '0',
`perm_owner` tinyint(1) unsigned NOT NULL default '0',
`perm_group` tinyint(1) unsigned NOT NULL default '0',
`perm_members` tinyint(1) unsigned NOT NULL default '0',
`perm_anon` tinyint(1) unsigned NOT NULL default '0',
PRIMARY KEY (`album_id`),
KEY `album_parent` (`album_parent`),
KEY `last_update` (`last_update`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8mb4;

--
-- Dumping data for table `gl_mg_albums`
--

INSERT INTO `gl_mg_albums` VALUES (1, 'Syracuse', , 0, 10, '-1', '5491734814897f0176f821d0bc992176', 230, 1182686119, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 2, 26, 26, 3, 3, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (2, ' America', '', 0, 11, '-1', '89c6e9769462f60cc7f58e8f2803c2c8', 187, 1182379266, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 2, 26, 26, 3, 3, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (61, 'Norvegen', '', 0, 70, '-1', '77c761d8134c470c4bd344423cd389ad', 9, 1175927623, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 35, 26, 26, 3, 3, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (62, 'Attention', '', 0, 71, '-1', 'df82d7764aa7b3582e1c52bb483bfde4', 1, 1158536245, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 35, 17, 26, 3, 3, 2, 2);
INSERT INTO `gl_mg_albums` VALUES (63, 'Friends', 0, 72, '-1', '01cf2363a470b495dca1be9207cb2915', 31, 1176016784, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 35, 26, 26, 3, 3, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (64, 'Family', 0, 73, '-1', '184df115a4908900fb4782138ebda1fb', 8, 1163910905, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 35, 26, 26, 3, 3, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (67, 'Richy', 0, 76, '-1', 'd7cc3d730df0a0aa0ed2d36c80f057a4', 1, 1173278937, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 0, 0, 1, 'all', 35, 26, 26, 3, 2, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (66, 'Pets.', 0, 75, '-1', '75d5f9d0e9350e2c47dcdaa2ac05ff21', 1, 1172515833, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 0, 0, 0, 0, 1, 'all', 35, 26, 26, 3, 2, 2, 2);
INSERT INTO `gl_mg_albums` VALUES (65, 'Greetings', 0, 74, '-1', 'f71a196d676cefb14085c1d6a994b608', 2, 1167082101, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 0, 0, 1, 'all', 35, 26, 26, 3, 2, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (30, 'Australia', '', 0, 39, '-1', '', 0, 0, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 2, 26, 26, 3, 3, 2, 0);
INSERT INTO `gl_mg_albums` VALUES (31, 'Austria', '', 0, 40, '-1', 'bdf9f1cbdfb7f0e73a5f455a60d8effe', 17, 1176668827, 1, 0, 1, 2, 0, 1, 1, 1, 1, 1, 1, 0, 1, 3, 3, 1, 0, 1, 0, 1, 'all', 2, 26, 26, 3, 3, 2, 0);


Now...I don't know how to import this stuff in my new website. :banghead:
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Good, that is a great start to the export process! Make sure you check the Add DROP TABLE / DROP VIEW
box on the export screen as well, this will help on the import.

Probably your best bet on the export is to also check Save as file with NO compression. This will download a .sql file to your local computer.

Then, open up the new database and select the Import tab. It will ask for a filename to upload, upload the .sql file you just saved.

If your phpMyAdmin doesn't have an Import button, then click the SQL button. You may have the option there to upload the .sql file, or you can open it on your local computer, cut / paste the how thing into the input box in phpMyAdmin.

Hit Go, cross your fingers and hopefully that will get your Media Gallery going on the new site.

Thanks!
Mark
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
In my documents I created new tekst documents with names :
gl_mg_media
gl_mg_media_albums -
gl_mg_media_album_queue
gl_mg_media_queue
and there I copied teksts from exported gl_mg_ files.
Then,with phpMyAdmin in my new website database i clicked on "Import" and I highlighted "gl_mg_media" ,in the "Browse" i found my copy of "gl_mg_media" tekst and I clicked on "Go" ,but I received error message:
Error

SQL query:

--
-- Database: `my_gklg3`
--
-- --------------------------------------------------------
--
-- Table structure for table `gl_mg_albums`
--
CREATE TABLE `gl_mg_albums` (
`album_id` int( 11 ) NOT NULL default '0',
`album_title` varchar( 255 ) NOT NULL default '',
`album_desc` text NOT NULL ,
`album_parent` int( 11 ) NOT NULL default '0',
`album_order` int( 11 ) NOT NULL default '0',
`album_cover` varchar( 40 ) NOT NULL default '-1',
`album_cover_filename` varchar( 255 ) default '',
`media_count` int( 11 ) unsigned NOT NULL default '0',
`last_update` int( 11 ) NOT NULL default '0',
`enable_comments` tinyint( 4 ) NOT NULL default '0',
`exif_display` tinyint( 4 ) NOT NULL default '0',
`enable_rating` tinyint( 4 ) NOT NULL default '0',
`playback_type` tinyint( 4 ) NOT NULL default '0',
`tn_attached` tinyint( 4 ) NOT NULL default '0',
`enable_slideshow` tinyint( 4 ) NOT NULL default '0',
`enable_random` tinyint( 4 ) NOT NULL default '0',
`enable_shutterfly` tinyint( 4 ) NOT NULL default '0',
`enable_views` tinyint( 4 ) NOT NULL default '0',
`enable_sort` tinyint( 4 ) NOT NULL default '0',
`albums_first` tinyint( 4 ) NOT NULL default '1',
`full_display` tinyint( 4 ) NOT NULL default '0',
`tn_size` tinyint( 4 ) NOT NULL default '0',
`display_rows` tinyint( 4 ) NOT NULL default '3',
`display_columns` tinyint( 4 ) NOT NULL default '3',
`member_uploads` tinyint( 4 ) NOT NULL default '0',
`moderate` tinyint( 4 ) NOT NULL default '0',
`email_mod` tinyint( 4 ) NOT NULL default '0',
`featured` tinyint( 4 ) NOT NULL default '0',
`cbposition` tinyint( 1 ) NOT NULL default '0',
`cbpage` varchar( 20 ) NOT NULL default '',
`owner_id` mediumint( 9 ) NOT NULL default '0',
`group_id` mediumint( 9 ) NOT NULL default '0',
`mod_group_id` mediumint( 9 ) NOT NULL default '0',
`perm_owner` tinyint( 1 ) unsigned NOT NULL default '0',
`perm_group` tinyint( 1 ) unsigned NOT NULL default '0',
`perm_members` tinyint( 1 ) unsigned NOT NULL default '0',
`perm_anon` tinyint( 1 ) unsigned NOT NULL default '0',
PRIMARY KEY ( `album_id` ) ,
KEY `album_parent` ( `album_parent` ) ,
KEY `last_update` ( `last_update` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1;

MySQL said: Documentation
#1050 - Table 'gl_mg_albums' already exists


:banghead: :banghead: :banghead:
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Don't forget this step:



Make sure you check the Add DROP TABLE / DROP VIEW box on the export screen as well, this will help on the import.


Checking that box will put a delete table if already exists statement in the export which will fix that error.
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
Big Grin
I finally did it !
Thank You so much !!!
Almost all pictures are transfered to my new website ..Only,with some albums category I have this error:
An error has occurred:
2 - Division by zero @ /home/nine/public_html/ba/mediagallery/classMedia.php line 172

array(21) {
["this"]=>
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Great! The division by zero error is probably caused by missing thumbnail images. You might double check that everything FTP'ed over OK.

Version 1.2.6 of Media Gallery is actually pretty old. We are up to v1.5.0 now. You might want to consider upgrading, if you are up to that challenge (actually it is pretty simple). The later releases do a much better job of dealing with missing images, instead of erroring out, it will simply show a generic missing thumbnail. There are several other improvements and enhancements as well too.

Thanks!
Mark
 Quote

Status: offline

denis

Forum User
Chatty
Registered: 11/08/07
Posts: 69
Great! The division by zero error is probably caused by missing thumbnail images. You might double check that everything FTP'ed over OK.


What I supposed to check and how I will know what is missing and how can I fix it?
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
A typical problem that I found was that when the server produces the thumbnails they may have an owner and group which cannot be accessed by the ftp user Cry

The same may happen with automatically uploaded pics in the stories.

The solution for me was to completely backup a site within the webspace admin dashboard like cpanel or confixx, plesk etc. and download it.
 Quote

Status: offline

philipjohn

Forum User
Newbie
Registered: 06/12/07
Posts: 1
No i dont think that you can directly move files from one place to another. You will have to carry out a freash installation of geeklog software to the desired place i think so.. Please correct me if i am wrong.
http://www.unirecovery.co.uk - Data Recovery http://www.unirecovery.it - recupero dati[/url]
 Quote

All times are EDT. The time is now 02:02 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content