Welcome to Geeklog Sunday, December 05 2021 @ 02:09 am EST

Geeklog Forums

Bug in phpBBbridge?


Theophile

Anonymous
I've been using phpbbbridge plugin for nearly 2 years now with no trouble and no modification. Today, without warning, whenever I try to access the forum, I get this:
PHP Formatted Code
An error has occurred:
2 - Illegal string offset: -12 @ /home/.tamara/theophile/monopedilos.com/htdocs/forum/language/lang_english/lang_main.php line 899


And then this is followed by debug output which appears to be a rundown of the configuration settings.

The really odd part is if I remove the "www" from the URL and go with just the domain, everything works just fine.

See for yourself:
http://www.monopedilos.com/forum
http://monopedilos.com/forum

Anyone have any ideas about this? Thanks!
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
I just tried it and after a minute it was just the other way round. What are your settings in config.php especially url, cookies?
 Quote

Theophile

Anonymous
Oddly, it seems to be working fine now. :shock:

Maybe it was something in the hosting configuration that was being fooled with by the server admins?
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
It only works from my PC when I add the index.php

http://www.monopedilos.com/forum/index.php
http://monopedilos.com/forum/index.php

Please check your config.php and lib-common.php settings again!
 Quote

Theophile

Anonymous
I'm playing with it again, and even when adding the "index.php" it only works if the "www" is removed form the url.

Right now, http://www.monopedilos.com/forum/index.php returns:

"Unfortunately, an error has occurred rendering this page. Please try again later."

Unless I am logged in, in which case I get the above mentioned error.
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Quote by: 1000ideen

What are your settings in config.php especially url, cookies?

 Quote

Theophile

Anonymous
Oh, sorry. Oops!

PHP Formatted Code
<?php

$_PHPBBB_CONF['path_to_phpbb']     = '/home/.tamara/theophile/monopedilos.com/htdocs/forum/';           // Should end in a slash
$_PHPBBB_CONF['phpbb_url']         = 'http://www.monopedilos.com/forum';  // Should not end in a slash
$_PHPBBB_CONF['show_left_blocks']  = true;
$_PHPBBB_CONF['show_right_blocks'] = false;

// Sideblock configuration
$_PHPBBB_CONF['sideblock_num_topics'] = 5;
$_PHPBBB_CONF['sideblock_subject_limit'] = 60;

// Centerblock configuration
$_PHPBBB_CONF['show_centerblock'] = false;
$_PHPBBB_CONF['centerblock_num_topics'] = 10;
$_PHPBBB_CONF['centerblock_subject_limit'] = 40;
$_PHPBBB_CONF['centerblock_homepage_only'] = true;

// Centerblock location
$_PHPBBB_CONF['centerblock_after_featured'] = true;
$_PHPBBB_CONF['centerblock_page_bottom'] = false;

$_PHPBBB_CONF['version'] = 111;

?>


PHP Formatted Code
// +---------------------------------------------------------------------------+
// | (3) Site Settings                                                         |
// +---------------------------------------------------------------------------+

// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).
$_CONF['site_url']          = 'http://www.monopedilos.com';


PHP Formatted Code
// +---------------------------------------------------------------------------+
// | SITE STATUS                                                               |
// |                                                                           |
// | To disable your Geeklog site quickly, simply set this flag to false       |
// +---------------------------------------------------------------------------+
$_CONF['site_enabled'] = true;  // true or false

// Message shown when site is down
// When this starts with 'http:' visitors are redirected to that URL
$_CONF['site_disabled_msg'] = 'Monopedilos is down for upgrades. Please come back soon.';

// When set to true, this will display /detailed/ debug information in the event
// of a PHP error. ONLY set this to true with your non-production development
// environments!
$_CONF['rootdebug'] = false;

// +---------------------------------------------------------------------------+
// | SESSION SETTINGS                                                          |
// |                                                                           |
// | cookie_ip will store md5(remoteip + randomnum) as the session ID in the   |
// | cookie. This is more secure but will more than likely require dialed up   |
// | users to login each and every time.  If ipbasedsessid is turned off       |
// | (which it is by default) it will just store a random number as the        |
// | session ID in the cookie.                                                 |
// |                                                                           |
// | default_perm_cookie_timeout is how long you want the permanent cookie     |
// | to persist for (in seconds).  This can be overridden by the user in       |
// | their user prefs if they want.  If you set the default to 0, users will   |
// | have to log in again once their session expired.                          |
// |                                                                           |
// | session_cookie_time is how long you want the session cookie to persist    |
// | for.  Only really useful in scenarios where you don't want to allow       |
// | permanent cookies                                                         |
// +---------------------------------------------------------------------------+

$_CONF['cookie_session']                = 'gl_session';
$_CONF['cookie_name']                   = 'monopedilos';
$_CONF['cookie_password']               = 'password';
$_CONF['cookie_theme']                  = 'theme';
$_CONF['cookie_language']               = 'language';

$_CONF['cookie_ip']                     = 0;
$_CONF['default_perm_cookie_timeout']   = 28800;
$_CONF['session_cookie_timeout']        = 7200;
$_CONF['cookie_path']                   = '/';
$_CONF['cookiedomain']                  = ''; // e.g. '.example.com'
$_CONF['cookiesecure']                  = 0;

// Geeklog keeps track of when a user last logged in. Set this to false
// if you don't want that.
$_CONF['lastlogin']                     = true;
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Did you also check the $_CONF['path'] and the path in lib-common.php? Is there any redirect from the www domain to another?
 Quote

Theophile

Anonymous
I haven't made any modifications to lib-common.php except those required for the Bad Behavior 2 plugin.

The section from config.php:
PHP Formatted Code
// +---------------------------------------------------------------------------+
// | (2) Paths                                                                 |
// +---------------------------------------------------------------------------+

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '\' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['path']            = '/home/.tamara/theophile/monopedilos.com/geeklog-1.4.1/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
$_CONF['path_html']      = '/home/.tamara/theophile/monopedilos.com/htdocs/';
 


This discrepancy that occurs with the "www" only occurs when viewing the forum, not with the rest of the site. And as I type this, the problem is not even occurring. It only happens sometimes. What's with that? Could it be due to the time of day? Weird...
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Quote by: 1000ideen

It only works from my PC when I add the index.php

http://www.monopedilos.com/forum/index.php
http://monopedilos.com/forum/index.php



Interesting, right now from my PC it does not work in both cases unless I add the index.php at the end. Did you test that too?

Could there be anything wrong with the server settings?
 Quote

Theophile

Anonymous
I suppose anything's possible, but which server settings could cause something like this? I am hosted by Dreamhost.

Also, right now, everything is working, with or without "www" and with or without "index.php." I have a feeling later this afternoon/evening will be a different story.
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
Best to ask the support if they changed anything.

Compare: Trailing Slash Problem
http://httpd.apache.org/docs/2.0/misc/rewriteguide.html
 Quote

All times are EST. The time is now 02:09 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content