Welcome to Geeklog Thursday, April 02 2020 @ 07:22 pm EDT

Geeklog Forums

Captcha v.3 does not display images


Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
Hi all there, and first of all my very greatest compliments for the great work you put in Geeklog and in all the plugins. I'm now using geeklog for over two years on a Mac support site, and i'm very happy with all the features and the ease to use that it has. Since half a year, i'm getting at least a dozen spam registrations a day, so i've decided (after upgrading gl to 1.4.1) to install the CAPTCHA plugin, v 3.0.0 .
Installation was very smooth, and everything seems to work correctly, only there's no image Big Grin . I think i've setted everything correctly, from paths to permissions. I keep the gl system files in a directory above the webroot, as my web hosting doesn't have a non-web directory. But editing the paths in config.php everything works fine. I've tried with static and with GDlib, as i don't have imageMagick. Any suggestions for my problem?

Cheers,

Stefano Ferrara
http://www.imaccanici.org
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Stefano,

Let's see if we can get those images to show up...

First, switch back to static images, that is always a good starting point.

Second, make sure you have the check box check for Enable Registration

Third, double check to make sure your theme file has the proper {captcha} tag in it. For registration, look at layout/professional/users/registrationform.thtml, search for the {captcha} tag. If you don't find it, that would be the problem! You can look at the registrationform.thtml file that comes with Geeklog 1.4.1 to see where to put it.

If you do all these and still are not getting the images, let me know and we'll dig a little deeper.

Thanks!
mark
 Quote

Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
Hello Mark,

thanks for your reply Big Grin
I'm sorry but i've not explained well the problem Oops!

The image is there, the {captcha} tag is in the template, but the image won't load. Instead i get a "?", and even if i try to open the captcha.php directly i get this error. The control works fine, because if i enter some word into the captcha text field it won't let me register.
Maybe it has something to do with my hosting? Would a phpinfo help?

Thank you,

Stefano
http://www.imaccanici.org
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Stefano,

Thanks for the additional information.

Let's make sure the paths are all OK. CAPTCHA is looking for the static images in:

PHP Formatted Code

$_CONF['path'] . 'plugins/captcha/images/static/


If you take what is in your Geeklog config.php $_CONF['path'] , does the path CAPTCHA is using look correct to your installation?

If you can, check your web server's error log file and see if there is any information in there that might tell us why CAPTCHA can't open the static images.

Just to be sure, let's double check those permissions one more time. Make sure the plugins/captcha/images/static/* directories are readable by the web server.

Thanks!
Mark
 Quote

Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
Hi Mark,

i checked the paths and permissions, they are ok. I have 755 on the captcha images directory.

I got this from apache's error log when trying to display a captcha:

PHP Formatted Code
[Sat Jun 23 15:32:57 2007] [error] [client 85.18.66.21] Premature end of script headers: captcha.php, referer: http://www.imaccanici.org/users.php?mode=new


Any ideas? I really appreciate your help.

Thanks,

Stefano
http://www.imaccanici.org
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Stephano,

That error message makes me think there might be a corrupt file in there. Can you upload the distribution one more time and copy to all the right places. It sure looks like maybe captcha.php or one of the include files is not all there.

Thanks!
Mark
 Quote

Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
Thanks Mark, i'll try and let you know Big Grin

Stefano

Edit: Perhaps i should try another decompressing application, who knows Smile
http://www.imaccanici.org
 Quote

Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
Hi Mark, i'm very sorry but it didn't work. I uploaded the whole plugin again and also the images, reset permissions on folders and files, but nothing, the "?" Is still there when i enable captcha. At this point i tried to look trough the files, but found nothing that could help me solve the problem.

Thank you so much,

Stefano
http://www.imaccanici.org
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Stephano,

It sounds like there may be a path issue. Can you describe your setup in a little more detail, I recall you said some of the paths were not 'standard'. If you don't want to post that publically, email me at mark@gllabs.org.

Thanks!
Mark
 Quote

Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
Hi Mark,

sorry for my late answer, i was at beach Big Grin So here is my gl path configuration:

the webroot: /web/htdocs/www.imaccanici.org/home/ - Here are all the files that are normally in "public_html". Please note that in my ftp i can't see any folder before this, let's say if i want to put something outside the webroot, i can't.


the gl system folder: /web/htdocs/www.imaccanici.org/home/privt/ - Here are all folders that normally are in the parent directory of "public_html", say language, config.php, system......

Now in config.php i have configured the following:


PHP Formatted Code
$_CONF['path']            = '/web/htdocs/www.imaccanici.org/home/privt/';


and

PHP Formatted Code
$_CONF['path_html']         = '/web/htdocs/www.imaccanici.org/home/';



So, the paths are simply inverted, but everything works fine for geeklog. Now, when captcha tries to load a static image, it uses


PHP Formatted Code
$_CONF['path'] . 'plugins/captcha/images/static/' . $this->imageset . '/' . $filename, 'r')


That should resolve in /web/htdocs/www.imaccanici.org/privt/plugins/captcha/images/static/default - simple/filename

I hope that helps Big Grin And again thank you for your help Mark.

Stefano
http://www.imaccanici.org
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Stefano,

The beach sound fun, wish I could go Smile

It looks like all the paths are resolving properly. I'm sure it is something simple and I'm trying to make it more difficult than I should.

Let's back up a bit and make sure everything is as it should be:

1. In the plugins/captcha/images/static/default/ directory is there a file called imageset.inc?

2. Set the configuration so you are using static images and choose the default set.

3. Are you aware of anything on your site / host that injects ads or header records into the HTML. For example, on a free GoDaddy hosted site, GoDaddy automatically injects an ad banner at the top of every HTML request, this can really screw up CAPTCHA.

4. I peeked at your site, the only thing I see that is a bit different is that there is a blank space before the HTML header (this is why I asked the question #3). I don't know if that space would cause a problem, but I thought I would mention it.

Other than that, I'm out of ideas....I'll be happy to trouble shoot it remotely if you feel comfortable giving me access to the site.

Thanks!
Mark
 Quote

Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
Hi Mark Big Grin

The imageset.inc file is there, so i think that's not the problem. I really don't know if my hosting does some sort of header-injiections, but i don't think so. The blank spaces in the html source are new for me, i never noticed them before. Maybe i should ask my hosting provider (Aruba.it). The only banners i use in the site are GoogleAds, so i don't think they would cause a problem. Anywat, i disabled them to see if there was something wrong with them, and the blank spaces didn't go away. If you want to troubleshoot it directly on the site, i can email you the autentication data.

Many thanks Mark!

Stefano
http://www.imaccanici.org
 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 29/08/05
Posts: 985
Edit: Perhaps i should try another decompressing application, who knows Smile [/p]
There are people who have reported problems with using WinZip. Is that what you are using? The Installing Geeklog page suggest WinRAR instead.
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Stefano,



If you want to troubleshoot it directly on the site, i can email you the autentication data.


I think this may be the best path right now. Shoot me the details to mark@gllabs.org and we'll see if we can get this thing working.

Thanks!
Mark
 Quote

Status: offline

predatorfe

Forum User
Newbie
Registered: 22/06/07
Posts: 12
Location:Castellammare di Stabia (Italy)
I would like to express my very greatest gratitude to Mark, who helped me solve the problem i had with the captcha plugin troubleshooting directly on the site.
If i can do something, please let me know Big Grin

Thank you

Stefano
http://www.imaccanici.org
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
No problem, glad we got it fixed.

As an FYI for others, the problem was tracked down to a blank line after the closing ?> in a plugin language file. Basically, CAPTCHA sends the image directly to the browser and must send a mime type header to the browser before any other content is sent. The blank line in the language file was getting out to the browser first, causing the mime type header to be ignored, which then breaks the image.

I appreciate Stefano working with me on this and letting me actually touch the site, made finding the issue much easier!

Thanks!
mark
 Quote

Status: offline

trampoline

Forum User
Full Member
Registered: 24/02/06
Posts: 392
Quote by: predatorfe

Hi Mark, i'm very sorry but it didn't work. I uploaded the whole plugin again and also the images, reset permissions on folders and files, but nothing, the "?" Is still there when i enable captcha. At this point i tried to look trough the files, but found nothing that could help me solve the problem.

Thank you so much,

Stefano



Do you have ImageMagic OR GD Libraries installed ?

GD Comes with Entropies php5 installation and Image Magic is also a seperate download from Entropy web site.

www.entropy.ch
 Quote

All times are EDT. The time is now 07:22 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content