Welcome to Geeklog Saturday, September 26 2020 @ 01:21 pm EDT

Geeklog Forums

Install problem


Status: offline

rob62

Forum User
Newbie
Registered: 29/05/07
Posts: 3
Location:MI
determined
Will someone please help!!!!


Page 1:

Hint: The complete path to this file is /home/content/l/i/b/libby86/html/geeklog/public_html/admin/install/install.php
and it appears your Path to Geeklog is /home/content/l/i/b/libby86/html/geeklog

My path is: mydomain.com/geeklog/public_htm/admin/install/install.php

config.php being in the geeklog directory

Page 2:

Parse error: parse error, unexpected T_STRING in /home/content/l/i/b/libby86/html/geeklog/config.php on line 362


Line 362:

$_CONF['site_enabled'] = true; // true or false


:banghead: :banghead: :banghead: :banghead:
Thanks to all who help this Newbie
 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 29/08/05
Posts: 985
Parse error: parse error, unexpected T_STRING in /home/content/l/i/b/libby86/html/geeklog/config.php on line 362

This usually means there is a missing quote mark or parenthesis or bracket or something on a previous line. If you are comfortable with code, comment out a few lines above 362 to find the line causing the error. If not, reply to this with 10 or so lines of your config.php just before line 362.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany

rob62

Anonymous
Thanks for responding.



Quote by: jmucchiello

Parse error: parse error, unexpected T_STRING in /home/content/l/i/b/libby86/html/geeklog/config.php on line 362


This usually means there is a missing quote mark or parenthesis or bracket or something on a previous line. If you are comfortable with code, comment out a few lines above 362 to find the line causing the error. If not, reply to this with 10 or so lines of your config.php just before line 362.




I do not know the code but do know about paths and syntax errors. Eariler I found a syntax error which got me to Page 1.

Here is the code you asked for:

// Please note that this does not work when safe_mode is on!
//
// For more information, see this discussion on geeklog.net:
// http://www.geeklog.net/forum/viewtopic.php?showtopic=21232
// $_CONF['timezone'] = 'Etc/GMT-6'; // e.g. 6 hours behind GMT
// Bob ADDED THE SCRIPT BELOW FROM THE ABOVE FORUM.
// IF IT DON'T WORK, TRY '/GMT-4
require_once('/path/to/config.php'Wink;

if ( !empty($_CONF['timezone'])
&& !ini_get("safe_mode"Wink) {
putenv("TZ=".$_CONF['timezone']='US/MICHIGAN);
}
// +---------------------------------------------------------------------------+
// | SITE STATUS |
// | |
// | To disable your Geeklog site quickly, simply set this flag to false |
// +---------------------------------------------------------------------------+
$_CONF['site_enabled'] = true; // true or false


 Quote

rob62

Anonymous
Thanks for responding.



I did this and found one error which got me to Page 1. I do not know the language yet.
 Quote

Dat

Anonymous

require_once('/path/to/config.php'Wink;

[/p]


Change the require once code.

PHP Formatted Code
require_once('/home/content/l/i/b/libby86/html/geeklog/config.php');
 Quote

rob62

Anonymous
Quote by: Dat


require_once('/path/to/config.php'Wink;



Change the require once code.

PHP Formatted Code
require_once('/home/content/l/i/b/libby86/html/geeklog/config.php');
[/p][/QUOTE]

I tried many variations of the path and they all gave the exact same error message on page one. :banghead: :banghead: :banghead: :banghead: :banghead:
 Quote

rob62

Anonymous
determined
Update:

I rem the time zone out and still get the same message on page 1.
 Quote

Status: offline

jmucchiello

Forum User
Full Member
Registered: 29/08/05
Posts: 985
Is that require_once in your config.php? That is completely wrong. How'd it get there?

You might want to extract a clean config.php from an archive and start over with it because there should be no require_once statements in the config.php.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
As Joe said: Remove that require_once and that timezone code from your config.php - it doesn't belong there.

Get your site working first, then you can start worrying about the timezone.

bye, Dirk
 Quote

All times are EDT. The time is now 01:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content