Welcome to Geeklog Sunday, April 21 2019 @ 10:45 am EDT

Geeklog Forums

GL 1.4.1 Windows 2003 MSSQL PHP 5.2.1


Status: offline

maggs

Forum User
Newbie
Registered: 11/04/07
Posts: 14
Hi, I would like to setup a new GL install with these versions. Are there any tips out there for this setup? Is anyone running on this setup?

Steve

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1345
I pretty much do. No real problems, just make sure you have all the required libraries loaded in PHP.
One of the Geeklog Core Developers.

Status: offline

maggs

Forum User
Newbie
Registered: 11/04/07
Posts: 14
Thanks, how do I check if they are loaded correctly? Is there anything special I need to do in IIS?

Steve

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1345
Have you already attempted the setup?

PHP windows installer is not to bad. You can select a fair number of libraries from within the php install to install (check the geeklog install docs for the ones required). It also sets up IIS for you as well to use PHP.

You can put this code in a test.php file and load it through your website to see information about your php installation. If it doesn't work then you know that either php is not installed correctly or IIS is not setup correctly. This will also list what libraries are loaded.

PHP Formatted Code

<?php
phpinfo();
?>
 

One of the Geeklog Core Developers.

Status: offline

maggs

Forum User
Newbie
Registered: 11/04/07
Posts: 14
I tried an install and get to the install page where I select mssql as the db and click next and get this error.

Fatal error: Call to undefined function mssql_connect() in C:\geeklog-1.4.1\system\databases\mssql.class.php on line 124

I have made all the neccessary changes to the config.php in the db section for db name user password and also changed the db type to mssql.

My PHP says this as per the test you gave me.

System Windows NT XXXXXXX 5.2 build 3790
Build Date Feb 7 2007 23:10:31
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"
Server API ISAPI
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\Program Files\PHP\php.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, compress.zlib
Registered Stream Socket Transports tcp, udp
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*

Another strange thing is that I edited the php.ini and changed register_globals to on but the install page says it is off.

Any help appreciated.

Steve

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1345
Any changes you do to the php.ini file you will have to stop and then start the web service (not just the web site). You can find service under Computer Management in the control panel.

You are missing the mssql extension, that is why it cannot connect. In the php.ini file under extensions make sure that the php_mssql.dll is not commented out. Also make sure that the dll exists in you extension folder (most likely under your php folder). If the file is not there you will have to download it off of the php web site.
One of the Geeklog Core Developers.

Status: offline

maggs

Forum User
Newbie
Registered: 11/04/07
Posts: 14
Getting closer now, the install went ok after adding the mssql.dll except that the success.php did not display and said it couldn't render. Now if I look in the db all the tables were created, I checked the users and it has 3 records so it appears it went ok. When I go to my main index.php I get this:

Unfortunately, an error has occurred rendering this page. Please try again later.

Is there a way to get a more descriptive error message to debug?

Steve

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1345
Put this line

ini_set ('display_errors', '1'Wink;

right after this line

error_reporting( E_ERROR | E_WARNING | E_PARSE | E_COMPILE_ERROR );

(right near the begining) in the lib-common.php file located in the public_html folder. This should flip the errors on.

One of the Geeklog Core Developers.

Status: offline

maggs

Forum User
Newbie
Registered: 11/04/07
Posts: 14
Closer again. I can login to the /admin/index.php and everything looks ok. I turned on rootdebug in config.php and these are the errors For the root of the site now. I checked the directory in question and it looks right. The file parserfactory.php line 31 is:

// Require pear HTTP_REQUEST
require_once('HTTP/Request.php'Wink;
/**

I don't understand how the system can find the admin files ok but not the root files. It seems like a minor error in lib-common.php The line in lib-common.php is;

*/
require_once( 'c:/geeklog-1.4.1/config.php' );


An error has occurred:
2 - require_once(HTTP/Request.php) [function.require-once]: failed to open stream: No such file or directory @ C:\geeklog-1.4.1\system\classes\syndication\parserfactory.class.php line 31

array(6) {
["fid"]=>
string(1) "1"
["_CONF"]=>
&array(170) {
["path"]=>
string(17) "c:/geeklog-1.4.1/"
["path_html"]=>
string(29) "c:/geeklog-1.4.1/public_html/"
["site_url"]=>
string(23) "http://www.zonadocs.com"
["site_admin_url"]=>
string(29) "http://www.zonadocs.com/admin"
["site_mail"]=>
string(17) "admin@example.com"
["site_name"]=>
string(12) "Geeklog Site"
["site_slogan"]=>
string(26) "Another Nifty Geeklog Site"
["path_system"]=>
string(24) "c:/geeklog-1.4.1/system/"
["path_log"]=>
string(22) "c:/geeklog-1.4.1/logs/"
["path_language"]=>
string(26) "c:/geeklog-1.4.1/language/"
["backup_path"]=>
string(25) "c:/geeklog-1.4.1/backups/"
["path_data"]=>
string(22) "c:/geeklog-1.4.1/data/"
["path_images"]=>
string(36) "c:/geeklog-1.4.1/public_html/images/"
["have_pear"]=>
bool(true)

plus more of the debug info.

Status: offline

jmucchiello

Forum User
Full Member
Registered: 29/08/05
Posts: 985
Are you sure you aren't missing files in your install? Did you use WinZIP to open the tarball?

Status: offline

maggs

Forum User
Newbie
Registered: 11/04/07
Posts: 14
I used winrar. The files are there where they are supposed to be and look ok in an editor. I have also checked for white space in all config files to no avail. The PHP and SQL must be ok as I can access the admin pages. I'm running out of ideas. I've read just about every post relevant and none of those solutions appear to work for me. I think I havn't got IIS setup right and or the paths are incorrect.
In IIS the root of the site points to the public_html folder which is where it's supposed to be I think.

Status: offline

randy

Forum User
Newbie
Registered: 18/01/03
Posts: 11
Quote by: maggs



["have_pear"]=>
bool(true)

.



If I'm reading that correctly, you've set the have_pear config.php setting to true... meaning that GL will try to look for your local PEAR installation rather than the PEAR installation that comes with GL. Try setting that to false to use the GL supplied pear directory.
The config.php file has 2 settings:

$_CONF['have_pear'] = false;
$_CONF['path_pear'] = $_CONF['path_system'] . 'pear/';

Just ensure that the path_pear setting does indeed point to the local GL supplied pear directory.

All times are EDT. The time is now 10:45 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content