Welcome to Geeklog Monday, August 10 2020 @ 05:02 am EDT

Geeklog Forums

Forum Installation Help


animalhelp

Anonymous
determined
Ok, I am back....I was able to get geeklog installed, but the forums would not install and I need them, so I went as far as getting new linux hosting, transfering everything there. The new geeklog install went great. But I am still having trouble installing the forums. Now I have done this before on another site and it went perfectly. Geeklog is running fine, my register _globals are ON, and everything appears ok. I have tried removing and using fresh downloads of the forum plugin multiple times, but each time I try to run the forum install from inside geeklog I get this error message : An error has occurred: 2 - fopen(/home/httpd/vhosts/disaster.animalhelp.com/httpdocs/gl_private/logs/error.log): failed to open stream: Permission denied @ /var/www/vhosts/disaster.animalhelp.com/httpdocs/lib-common.php line 1807 Dirk, my friend, the geeklog god, if you could help - or one of you other geeklog experts, I am more then happy to give you access so you could try to fix it for me...I mean it must be something little. I promise, I have followed installation instructions to a T, not missing any steps, files, folders, AND I had my mouth open just right and both feet on the floor. I just can't figure out why these forums won't work this time, when for my other site they loaded on the first try and run great. Thanks! Jodi
 Quote

animalhelp

Anonymous
Also, I read in some posts that you need to make sure permissions are set for read for all files and folders. I have been going through every file and they are all set for all read. Do they all need to be set for execute also?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: animalhelp

Geeklog is running fine, my register _globals are ON


You shouldn't actually need that any more.


Quote by: animalhelp

An error has occurred:
2 - fopen(/home/httpd/vhosts/disaster.animalhelp.com/httpdocs/gl_private/logs/error.log): failed to open stream: Permission denied @ /var/www/vhosts/disaster.animalhelp.com/httpdocs/lib-common.php line 1807


error.log and a couple of other files and directories have to be made writable. Please refer to the installation instructions again.

bye, Dirk
 Quote

animalhelp

Anonymous
Thank you again Dirk, I had read in another forum topic (on forum install) from you to make sure everything had read permissions. I had gone through to make sure everything had those read permissions. But...It was indeed the write permissions that were causing the problem.

I know you must get flustered with those of us who just can't seem to get this right and keep begging for the same help over and over, but what appears logical to you is rocket science to us! You are wonderful, and again I bow to your godliness!!!


 Quote

All times are EDT. The time is now 05:02 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content