Welcome to Geeklog Thursday, January 27 2022 @ 12:33 pm EST

Geeklog Forums

media gallery 1.4.6 problems


Baddrink

Anonymous
confused
I installed media gallery 1.4.6 and ive got a few questions, the first is about the random image block media gallery created. Ive got two media galleries one for avatars and the other is for random images and the random image block pulls from both of the galleries , is there a setting or some code i can change so it pulls from only one gallery?


My next question is about uploading images, ive used the ftp method for large batches i want to add to a gallery but the only problem is it converts animated gifs to jpg's , ive also noticed that if i use the other media gallery upload option and check "do not covert original to jpg" it still converts the original to a jpg. Is there something im missing or some code change that needs to be done?
 Quote

Status: offline

buckwildbill

Forum User
Chatty
Registered: 16/06/05
Posts: 47
On the Edit Album screen there is a check box to exclude the album from the random image block.

Are you sure the original is being converted to a jpg? There are 3 images created during upload. A thumbnail, a display image, and the original. The thumbnail and display image will always be converted to jpg but the original should stay gif if you have "do not convert original to jpg" checked. I just tested this in my gallery and it seemed to work right.

There is more documentation available at:
http://www.mediagallery.org/
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Quote by: Baddrink


My next question is about uploading images, ive used the ftp method for large batches i want to add to a gallery but the only problem is it converts animated gifs to jpg's , ive also noticed that if i use the other media gallery upload option and check "do not covert original to jpg" it still converts the original to a jpg. Is there something im missing or some code change that needs to be done?



Bill was correct in his answer, Media Gallery will create a display image and thumbnail image that are always JPGs, but it should leave the original alone when you have "do not convert original to jpg". I have also double checked it and it seems to be working as it should.

Animated GIFs are a problem for Media Gallery, with my method of creating static display and thumbnail images, it just doesn't work well with the animated stuff. It is something I hope to address and fix in a future release, but for now, Media Gallery just isn't the best solution if you have a ton of animated GIFs to display.

Thanks!
Mark
 Quote

Baddrink

Anonymous
Well i checked and it seems that the files do uplad a gif file but when you click on the thumbnail your still looking at the jpg it created for a thumbnail. Its like i have 3 files 2 are jpg and one a gif, the gif you cant actually see even if you click on the thumbnail. :banghead:
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Baddrink,

As I said earlier, for doing animated GIFs, Media Gallery may not be the best option. But, let's make sure you understand how Media Gallery is working.

Upload image -> Media Gallery creates 2 images, a display image and a thumbnail.

View album -> Shows the thumbnails -> Click a thumbnail, shows the display image -> Click the display image, see the full/originally uploaded image (this should be your animated GIF).

You must make sure you have Display Full (original) Image in the Album Edit set to Always so folks can get to the original image.

Hope this helps clear things up a bit.

Thanks!
Mark
 Quote

baddrink

Anonymous
I think im following what you said as far as media gallery creating two new images, however even if i click the display image i dont see any animation, which like you said media gallery might not be the right tool for this. However when i click download it does try to save it as a gif file so it is pointing to the correct image. I did some playing and found the location the display image was in and uploaded the original gif just remnamed .jpg and the animation works fine which is why im not quite understanding why it doesnt play fine when looking at the display image. I checked the gallery setting and "Display Full (original) Image" is set to always , actually the option is greyed out all together.
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 08/02/04
Posts: 393
Location:Texas
Baddrink,

If the Display Full (original) Image is greyed out, that means you have Discard Original Images enabled in the Media Gallery System Options. Which tells Media Gallery to delete the original image, make sure you turn that off and see if things improve a bit.

Thanks!
Mark
 Quote

All times are EST. The time is now 12:33 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content