Welcome to Geeklog Sunday, February 17 2019 @ 03:27 pm EST

Geeklog Forums

FCKeditor toolbar


Status: offline

dewdoo

Forum User
Chatty
Registered: 03/01/04
Posts: 65
I am having a problem getting the fckeditor toolbar to load. I am using spacequad contemporary updated theme for geeklog 1.4.1. In the config.php the toolbar will load w/professional theme. I get an error when it contemporary theme loads

Error: GeeklogeditorBaseUrl is not defined
Source file : http://mywebsite/javascript/storyeditor_fckeditor.js

Thank you for any help on this


Status: offline

dewdoo

Forum User
Chatty
Registered: 03/01/04
Posts: 65
No else having problems using other themes. I have been trying to fix this problem all night and still the toolbar in fcleditor doesn't load. :banghead:

Status: offline

dewdoo

Forum User
Chatty
Registered: 03/01/04
Posts: 65
Good 'ol Mark E came to the rescue again. Thanks Mark for all your help. It was a theme issue, that wasn't updated completely.
OK, I think I found it. That variable is defined in
advanced_editor_header.thtml, it looks like your
advanced_editor_header.thtml needs to be updated, just copy the one
from Professional over and you should be good to go!

Thanks!
Mark


Once I have done this everything was working!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
I have just upgraded to GL1.4.1 from GL1.4.0sr5 where FCK worked and now I am getting errors.

Stories: As admin when I try to create a story I get an error that toolbar-1 doesn't exist? I have recopied all the files over and still have the same error. The toolbar works fine when I am not logged in and click contribute. If I log in as admin I get the error that toolbar 1 does not exist. If I am logged in as a user no problem.

Comments: When I am either logged in or not comments toolbar is fine for either admin or general user.

Static pages: As admin I get this error when I try and create a new static page:

An error has occurred:
2 - file_exists(): open_basedir restriction in effect. File(/editor_advanced.thtml) is not within the allowed path(s): (/home/e-smith/files/ibays/geeklog/:/tmp:/opt/geeklog:/usr/bin) @ /home/e-smith/files/ibays/geeklog/html/admin/plugins/staticpages/index.php line 82


Can anyone suggest what I may have done wrong, please. The issue seems to be with admin users only.

Thanks in advance.
KEV
(Note: I am doing all this on an offline site before upgrading my online site to make sure I am doing everything correctly)

Live everyday as if it was your last!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
confused
:helpme: I still can't work out why this is happening. Any suggestions please.

Regards

Kev
Live everyday as if it was your last!

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: k74

IStatic pages: As admin I get this error when I try and create a new static page:

An error has occurred:
2 - file_exists(): open_basedir restriction in effect. File(/editor_advanced.thtml) is not within the allowed path(s): (/home/e-smith/files/ibays/geeklog/:/tmp:/opt/geeklog:/usr/bin) @ /home/e-smith/files/ibays/geeklog/html/admin/plugins/staticpages/index.php line 82/p]


That appears to be a bug.

In the file admin/plugins/staticpages/index.php find the line that reads
PHP Formatted Code
$template_path = staticpages_templatePath ('admin');
(line 99) and move it to the start of the function (between the 'global ...' and the 'if ...'Wink.

bye, Dirk

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
cheerful
:shakehands:

Thanks for that Dirk I will give it a go and let you know.

Regards

Kev
Live everyday as if it was your last!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
Dirk

Note: Errors are only when logged in as Admin-

After making the change in the static page as suggested, the error has changed:

Toolbar set "editor-toolbar 3" doesn't exist

I also get the same error (as Admin only) when trying to contribute:

Toolbar set "editor-toolbar 1" doesn't exist


Any suggestions on why this is occuring Confused: These errors did not exist in GL1.4.0sr5, nor did I get these errors with a custom mod Blaine did for me for GL1.3.11 in early 2006 before FCK became part of GL (stories only).

Everything else seems to be working fine with GL1.4.1 other than FCK on my system. Great work on this version to you and all the GL team.

Thanks for your help. :shakehands:

Kev


Live everyday as if it was your last!

Status: offline

Blaine

Forum User
Full Member
Registered: 16/07/02
Posts: 1233
Location:Canada
I'm assuming you have replaced the complete fckeditor directory and files under your public_html with the new GL 1.4.1 version. You should have a myconfig.js file in the fckeditor directory where the toolbars are defined.

Geeklog components by PortalParts -- www.portalparts.com

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
Quote by: Blaine

I'm assuming you have replaced the complete fckeditor directory and files under your public_html with the new GL 1.4.1 version. You should have a myconfig.js file in the fckeditor directory where the toolbars are defined.



Your ussumption is correct. I couldn't work out why this was happening so I deleted all my existing files and upload all the new ones instead of copying over the existing, and I still got the same errors.

I checked to make sure all the files are there and they are including the myconfig.js. I can see the three toolbars in there, and can only assume it is all correct as it is being found for everyone but admins.

Everything else seems to be working fine with GL1.4.1 on my setup.

Any suggestions would be much appreciated as this is a great function that I would really like to get working. Up until GL1.4.0 I was using your custom mod you did for me Blaine which worked fine. All went bellyup with GL1.4.1. All will work out in the end I do feel. Big Grin

Thanks in advance for your help.

Kev
Live everyday as if it was your last!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
:helpme:

I have deleted all files and reinstalled,and still I am having problems with FCK when logged in as admin. The errors only occur when trying to post a story or create a static page, it is saying ' Toolbar set "editor-toolbar .." doesn't exist.

It works fine for admin in comments and for all other users in comments and stories.

I am happy to even go back to the fck editor version in GL1.4.0sr5 if possible and to run GL1.4.1 for everything else.

Can anyone suggest a fix.

Thanks in advance

Kev Big Grin
Live everyday as if it was your last!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
excited
I have updated info on this FCK editor problem I have been having. I now believe it is a bug as I have always been doing my testing on my laptop(as I always have for all installs and plugins). The laptop uses the latest IE explorer and Win XP. Tonight I tested it on my wifes desktop pc which is running the latest IE explorer and Win XP and I found the following:

When I tested FCK on the desktop as admin -

When creating a Static Page I get the error:

Toolbar set "editor-toolbar 3" doesn't exist

& when trying to contribute the FCK editor works and displays properly.

The editor works correctly for admins and general users when posting a comment.

Can anyone shed some light on this Confused:

Thanks

Kev
Live everyday as if it was your last!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia

That appears to be a bug.

In the file admin/plugins/staticpages/index.php find the line that reads
PHP Formatted Code
$template_path = staticpages_templatePath ('admin');
(line 99) and move it to the start of the function (between the 'global ...' and the 'if ...'Wink.

bye, Dirk


FYI

I still have to place this change in as this fault still occured on the desktop pc.

regards

Kev :shakehands:

Any suggestions on why it may only affect the static page editor on the desktop pc and why I am may get a different error on the laptop would be great.
Live everyday as if it was your last!

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
As soon as I installed GL1.4.1, I upgraded the fckeditor to 2.3.2. I am not sure if this will help your problem.

Maybe you can try that. This is how I did it and it is easy:

Rename the current /fckeditor directory to /fckeditor2.3 because that's what it is.
Download the FCKeditor 2.3.2 and upload it to /fckeditor directory.
Move the myconfig.php from the /fckeditor2.3 to the new /fckeditor directory.

Hope this helps.

Sam

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
cheerful
Thanks samstone I might give that a go and see what happens.

:shakehands:

Kev
Live everyday as if it was your last!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
Quote by: samstone

As soon as I installed GL1.4.1, I upgraded the fckeditor to 2.3.2. I am not sure if this will help your problem.

Maybe you can try that. This is how I did it and it is easy:

Rename the current /fckeditor directory to /fckeditor2.3 because that's what it is.
Download the FCKeditor 2.3.2 and upload it to /fckeditor directory.
Move the myconfig.php from the /fckeditor2.3 to the new /fckeditor directory.

Hope this helps.

Sam



Thanks Sam

I tried what you suggested and it was easy but I still get the same issues.

At the moment I am able to utilise FCK in stories fine, but not in comments or staticpages.
I'll keep working at it.

Regards

Kev
Live everyday as if it was your last!

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
I found the bug that was giving me all the grief with FCK. It is IE7. I just installed Firefox, which I should have done long ago and it all works fine, I can see FCK in comments, static pages and stories.

IE7 was even giving me grief with uploading files onto my server with filemanager, inmemorariam and media gallery. What a pain that has all been. I never thought IE would be the trouble as I have always used it and never had trouble before.

Thanks to all that gave me help and suggestions.

:shakehands:
Live everyday as if it was your last!

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
I use both IE7 and FireFox and have no problem.

Sam

Status: offline

k74

Forum User
Full Member
Registered: 19/09/04
Posts: 128
Location:Australia
Below is a quote from my IT guy whom sets up my server.

IE 7 is still presenting problems even to me (I believe I mentioned this to you a day or so ago as well), with random lock ups etc. However, that said, I am able to upload to Common Room using either IE7 or Firefox. But, what I have found so far is that IE7 presents different problems to different people, just depending on what they have on their PCs and what sites they are visiting. IE6 was by far more stable.



He found that he could upload files to my site no problems in IE7 when I could not and have to use Firefox.

I have never had issues before with IE as my browser but since upgrading to IE7 have a weird issues mainly with my geeklog site-(FCK editor & GLmenu). But I just had to modify things so they worked now that I have found this to be the issue.

Thanks again for your help and patience.

Kev :shakehands:
Live everyday as if it was your last!

All times are EST. The time is now 03:27 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content