Welcome to Geeklog Sunday, August 09 2020 @ 11:07 am EDT

Geeklog Forums

error on garden theme when use gl 1.4.1


Nameless

Anonymous
After I upgrade from GL 1.4.0 or install new 1.4.1, when I click on read more link in stories, I see that error message: Fatal error: Call to undefined function mb_eregi_replace() in /home/s/i/t/sitename/www/system/lib-mbyte.php on line 179. It is only when I use garden layout.
 Quote

nameless

Anonymous
Im sorry, I have that error also on garden skin. I have site on ovh.org, maybe it can help You? Frown
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
I don't think this is a problem with the theme but rather with the server setup (or maybe even a bug in Geeklog).

It looks like your server has the PHP multibyte extensions enabled, but that one function (mb_eregi_replace) which is part of that extension is not available.

Which PHP version are you on?

bye, Dirk
 Quote

Nameless

Anonymous
PHP 5.1.6. Site work fine on GL 1.4.0, but there is not lib-mbyte.php file in system directory. This is some information from phpinfo file:

Configure Command
'./configure' '--enable-discard-path' '--prefix=/usr/local/php5' '--with-config-file-path=/usr/local/php5/lib' '--enable-sigchild' '--enable-magic-quotes' '--enable-short-tags' '--with-exec-dir=/home' '--with-openssl' '--disable-rpath' '--enable-libgcc' '--with-zlib' '--enable-bcmath' '--enable-calendar' '--with-gdbm' '--with-db3' '--enable-dbase' '--enable-xslt' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-exif' '--enable-mbstring' '--disable-mbregex' '--enable-filepro' '--enable-ftp' '--with-gd' '--enable-gd-native-ttf' '--with-jpeg-dir' '--with-png-dir' '--with-ttf' '--with-t1lib' '--with-gettext' '--with-imap' '--with-kerberos' '--with-imap-ssl' '--with-mcrypt' '--with-mhash' '--with-mysql' '--with-jpeg-dir' '--with-png-dir' '--with-tiff-dir' '--enable-sysvsem' '--enable-sysvshm' '--enable-wddx' '--with-gnu-ld' '--with-expat-dir' '--with-pear' '--with-pdo-mysql' '--with-curl' '--with-freetype-dir' '--with-mysqli' '--with-xsl=/usr/lib'

Server API
CGI

Thread Safety
disabled

Registered Stream Filters
string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, zlib.*

Maybe it helps?
 Quote

Nameless

Anonymous
tired
Grrr Evil , I try to commented out some lines from: lib-common.php, lib-mbyte.php and lib-story.php, and now lib.comment.php need it :/ I think I go back to version 1.4.0 and say 1.4.1 bye, bye :/ Thank for patients. Nameless (Im GL.net user and I wait 4 password retieval Wink ) :banghead:
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Nameless

PHP 5.1.6. (...) '--enable-mbstring' (...) '--disable-mbregex'


That appears to be the problem: You server has the multibyte extensions enabled, but the multibyte regular expressions are disabled. Geeklog's lib-mbyte.php isn't prepared for that case.

Is your site using UTF-8? If it isn't, you could patch lib-mbyte.php to not use the multibyte extension at all.

bye, Dirk
 Quote

Status: offline

Nameless

Forum User
Newbie
Registered: 20/02/06
Posts: 4
Location:Poland
Uff, Im logged Smile Yes, my site use utf-8. This a polish site and polish letters character. My WWW server is free for registrations but dont work werry good, for example with iso-8859-2, polish letters dont look good but with utf-8 is better (names of days and manths is no good, You can see "?", but other letters looks good). In a result of this, I think, I must use utf-8 Frown Now I dont have enough time to spend for site testing. I think, I will do this tomorrow Wink . Thanks for help!
allways use Google search, but sometimes use Delete.Net.PL! ;)
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
FYI: Oliver came up with this simple change to lib-mbyte.php to address this problem. See if that helps.

bye, Dirk
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by: Dirk

FYI: Oliver came up with this simple change to lib-mbyte.php to address this problem. See if that helps.



Looks like I'm experiencing the same issue here Frown
The above link doesn't work Frown
Also how can I "patch lib-mbyte.php to not use the multibyte extension at all"

Thanks for your help Smile

Robert
Geeklog Polish Support Team
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by: Robin

The above link doesn't work Frown
Also how can I "patch lib-mbyte.php to not use the multibyte extension at all"


Server move. CVS and the project site are currently down. You can, however, grab the nightly tarball and use the lib-mbyte.php from there.

bye, Dirk
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by: Dirk

You can, however, grab the nightly tarball and use the lib-mbyte.php from there.


So I've grabed. Problem's gone Smile
Thank you Dirk :shakehands:

Robert
Geeklog Polish Support Team
 Quote

All times are EDT. The time is now 11:07 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content