Welcome to Geeklog, Anonymous Monday, December 05 2022 @ 07:49 pm EST

Geeklog Forums

Parse errors Desperate help needed


Rokman

Anonymous
confused
Parse error: syntax error, unexpected T_PUBLIC, expecting ']' in Parse error: syntax error, unexpected T_PUBLIC, expecting ']' in /plugins/journal/functions.inc on line 333 it is saying expecting a ] on line 333 but where is it missing the ] if I have not made changes to the journal feature This is something totally new to me I came home and tried to access my website and this is the error that I recieved. There have been no changes since to the site and it was working fine last night. I havent even been into the journals in a long time. How do I get by this to access the site and fix the problem or remove the plugin? I cant even get to the main pages of the site as it is looking for this bracket. I have found line 333 and don't see where it is missing a ] "\n" . $LANG01[60] . :helpme: Island Rokman Love of Seduction
 Quote

Rokman

Anonymous
confused
"\n</td></tr><tr><td><a href='" .$_CONF[site_url] ."/comment.php?type=journal&cid=" .$A['je_id']. "'>" . $LANG01[60] .

for some reason all the code did not post, anyway, any help would be appreciated.
 Quote

Status: offline

jordydme

Forum User
Full Member
Registered: 11/03/05
Posts: 135
Any info in your error log
 Quote

Status: offline

Rokman

Forum User
Newbie
Registered: 09/23/06
Posts: 5
yes the same thing is in the error log starting from Dec 29th, the thing is only ysterday did it stop letting me in the site.

Cheers
Rokman
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Which version of the Journal plugin is that? There are 3 or so slightly different versions floating around ...

The version that's available for download from geeklog.net doesn't have the code you quoted in line 333 of the functions.inc (or anywhere near that line).

If you stil have the original or a backup, try uploading the functions.inc again - it may have been corrupted.

bye, Dirk
 Quote

Status: offline

Rokman

Forum User
Newbie
Registered: 09/23/06
Posts: 5
I did try to upload the original functions.inc file but it still says the error If I downlowd a newer version and upload it to my server is this going to allow me to access the site or do I have to unintall the first one. Trouble is I can't even get into the admin pages to make any changes. How can I bypass the plugin so that I can un-install it. Just deleting it as far as I know wont work as that is what I tried when I had the forums plugin distroy my site 5 months ago. I really dont want to have to uninstall the whole geeklog again what a pain in the ass that is. I have most of the pages already backed up in html format but still a pain to reinstall everything.
Cheers
Rokman
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
To disable the plugin, go into your database (using phpMyAdmin). In the table gl_plugins, find the entry for the journal plugin and set the pi_enabled field to 0. That should get your site back up.

bye, Dirk
 Quote

All times are EST. The time is now 07:49 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content