Welcome to Geeklog, Anonymous Thursday, December 08 2022 @ 12:20 am EST

Geeklog Forums

Captcha function errors


polar82

Anonymous
I uploaded all the captcha files as the readme says, go into plugins in admin, click install, click install again on the next page, and get this followed by a looooooong string of stuff.

An error has occurred:
2 - fopen(/home/con/logs/captcha.log) [function.fopen]: failed to open stream: Permission denied @ /hsphere/local/home2/onewildt/perpcon/plugins/captcha/functions.inc line 247

Any ideas?

In my error log this is all I get:

*** dummy entry ***
Mon Jan 1 21:00:41 2007 - Attempting to install the captcha Plugin
Mon Jan 1 21:00:41 2007 - Registering captcha plugin with Geeklog
Mon Jan 1 21:01:15 2007 - Attempting to install the captcha Plugin
Mon Jan 1 21:01:15 2007 - Registering captcha plugin with Geeklog
Mon Jan 1 21:01:32 2007 - Attempting to install the captcha Plugin
Mon Jan 1 21:01:32 2007 - Registering captcha plugin with Geeklog
Mon Jan 1 21:02:23 2007 - Attempting to install the captcha Plugin
Mon Jan 1 21:02:23 2007 - Registering captcha plugin with Geeklog
Mon Jan 1 21:05:30 2007 - Attempting to install the captcha Plugin
Mon Jan 1 21:05:30 2007 - Registering captcha plugin with Geeklog

Thanks
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
From the error you quoted, it looks like it can't create/open the captcha.log file in the logs/ directory. Double check the permission on that file and the logs/ directory and make sure the web server has write permissions.

Hope this helps...

Thanks!
Mark
 Quote

Polar82

Anonymous
OK, I created the file since it didn't exist and gave it write permissions and that fixed that. I tested registering a new user and it said once the application was approved, an email with the password would be sent. I don't want to have to approve new members. It went ahead and added the user without moderation from me so it's not relevant in that sense, but I'd like to change that message back to the "your password has been emailed" bit. Could you tell me where that bit of language is and in the future, if I decide to moderate new registrations, where would I turn that on/off?
Thanks!
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
Check your geeklog config.php file and see what you have set for:

Text Formatted Code

$_CONF['submitloginrequired']
 

If 1, then you get the 'approval required' action, if set to 0, they are emailed their password and you should not have to approve them.

Thanks!
Mark
 Quote

me again

Anonymous
When I set this to 0 I still have to moderate new users, no change at all. The config documentation says this is for moderating story submissions not users, so can anyone tell me where I can turn off new user registration moderation?

Thanks!
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
polar82,

Geez, you are right, I think I've had too many late nights. The correct config.php setting for determining if user moderation is enabled is:
Text Formatted Code

$_CONF['usersubmission']  = 0; // 1 = new users must be approved
 

Make sure this is set to 0 in your config file and new users should not be moderated.

Sorry 'bout that!

Thanks!
Mark
 Quote

polar82

Anonymous
No problem friend, I appreciate your help!
 Quote

All times are EST. The time is now 12:20 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content