Welcome to Geeklog Thursday, June 04 2020 @ 08:50 pm EDT

Geeklog Forums

Bumbling and Fumbling Help Please !!!!!!


Island Rokman

Anonymous
Lost
I got this terrible error thoughout my php site when I attempted to install forum 2_0_137.zip it seemed to have corrupted my data base for the site. I am sure all the pages are still there (Ihope )
I could not even get back to admin or anything to get it all fixed to uninstall so I deleted the files that contained forum but that didnt seemed to recover all the work that I had done.
How can I repair it or do i have to start again.? Doh! - that was a mistake
Cheers
Rokman
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
Is your php site a Geeklog site? and if so, where did you get the forum script that you refer to? It seems unfamiliar.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
More detailed information would certainly help. Like error messages you are getting and the Geeklog version you're on.

2_0_137 sounds like an really old version of the forum. Still shouldn't give you that sort of trouble, but the forum is up to versions 2.3.2 / 2.5rc1.3 now. See Blaine's site for more information.

Just guessing, but if you now have a forum plugin that's only halfway installed, you could try going into your database (use phpMyAdmin or whatever you have handy) and see if you have a "forum" entry in your gl_plugins table. If so, set the pi_enabled field to 0. That should get your site back up (minus the forum).

Otherwise, see above: More details, please.

bye, Dirk
 Quote

Island Rokman

Anonymous
yes I am using a geeklog site, the plugin I got from a link on this site under plugins. As far as I know it is the latest version, it was one of the choices that came with my Hosting package.

I installed it then when I went back to next page and got another error. luckilly so I thought I could just uninstall it. It never installed correctly in the first place so uninstalling it I had to delet the folders and files. This is the error it produced.

Warning: main(/public_html/LOS/plugins/forum/functions.inc): failed to open stream: No such file or directory in /home/loadstar/public_html/LOS/lib-common.php on line 5632

Fatal error: main(): Failed opening required: 'public_html/LOS/plugins/forum/functions.inc' (include_path='/public_html/LOS/system/pear/:.:/usr/lib/php:/usr/local/lib/php') in /public_html/LOS/lib-common.php on line 5632

now is it something in the data base that is calling this file to look for those files or what is the file that would make these calls fixing it I dont foresee a problem as it looks like all I have to do is delete the forum part. I have reinstalled another copy and have started rebuilding but it would be nice not to have to reinvent the wheel so to speak and if I can at least retrieve the data then I can transfer to the other folder.
 Quote

Island Rokman

Anonymous
Ih ave reinstalled a new version in another folder added plugin journal and when trying to install it got this error message

Warning: main(/home/loadstar/public_html/LOS2/plugins/journal/language/english.php): failed to open stream: No such file or directory in /home/loadstar/public_html/LOS2/admin/plugins/journal/install.php on line 36

Fatal error: main(): Failed opening required '/home/loadstar/public_html/LOS2/plugins/journal/language/english.php' (include_path='/home/loadstar/public_html/LOS2/system/pear/:.:/usr/lib/php:/usr/local/lib/php') in /home/loadstar/public_html/LOS2/admin/plugins/journal/install.php on line 36

any suggestions?

Cheers
Island Rokman
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Island Rokman: Warning: main(/home/loadstar/public_html/LOS2/plugins/journal/language/english.php): failed to open stream

Make sure there is a file called english.php in that directory and that it (and the directories it's in) is readable for the webserver.

bye, Dirk
 Quote

All times are EDT. The time is now 08:50 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content