Welcome to Geeklog, Anonymous Tuesday, October 04 2022 @ 06:24 am EDT

Geeklog Forums

Where's my Ping?


Status: offline

DubiousChrisJ

Forum User
Regular Poster
Registered: 05/10/05
Posts: 114
Hey all,
I just updated to the 1.4 package, and am going through all the steps to add all the custom hacks back. However, one thing which was a major reason I upgraded, I can't seem to find. According to the Docs, I should see a 'Ping' column on my stories admin page, to use for pingbacks and trackbacks. It's not there. Any suggestions?
Luhme summa dat GL.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Make sure your theme is up to date, specifically the admin directory. You may also be missing the image we display in that column (sendping.png), although it should display an alt text if that's the case.

bye, Dirk
 Quote

Status: offline

DubiousChrisJ

Forum User
Regular Poster
Registered: 05/10/05
Posts: 114
Dirk, I manually replaced all the theme files, still no ping column. Then, I viewed story.php from the full version tarball, and ping is not part of the story array. Am I smoking crack? Where should I expect to see it?
Luhme summa dat GL.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by DubiousChrisJ: Then, I viewed story.php from the full version tarball, and ping is not part of the story array.

Not sure what you mean by "story array". When you open story.php in an editor and search for "ping" you should find a piece of code checking if the current user has 'story.ping' rights. If you have that, then you have at least the correct version of story.php.

Next, check that trackbacks, pingbacks, and/or pings (whichever of the three you want) are actually enabled in config.php.

For the "ping" column in story.php, you need to have $_CONF['ping_enabled'] = true;

bye, Dirk
 Quote

Status: offline

DubiousChrisJ

Forum User
Regular Poster
Registered: 05/10/05
Posts: 114
OK, I'm logged in as super user. The code you mentioned is present in story.php. All the options for ping and trackback are enabled in config.php. And still, ping is not showing up in the story column. Is there any other place where permissions could be overridden? If chmod settings were not correct for the new trackback folder, would that prevent the ping column from showing up? I'm not a total n00b, and my inability to get this to show up is frustrating the hell out of me.
Luhme summa dat GL.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
And your user does have story.ping permissions?

Just to make sure we're talking about the same thing: this is how it should look like.

bye, Dirk
 Quote

Status: offline

DubiousChrisJ

Forum User
Regular Poster
Registered: 05/10/05
Posts: 114
Yeah, mine looks the same, just minus the ping column. I am logged in as super user...doesn't the Super User have all access by default?
Luhme summa dat GL.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by DubiousChrisJ: I am logged in as super user...doesn't the Super User have all access by default?

Not necessarily. When checking for a specific right ('story.ping' in this case) you really have to have it.

Check if your Story Admin group has that right.

bye, Dirk
 Quote

Status: offline

DubiousChrisJ

Forum User
Regular Poster
Registered: 05/10/05
Posts: 114
Hmmm...

Security Groups
This group is a core dubiousprofundity.com Group. Therefore the groups that this groups belongs to cannot be edited. Below is a read-only list of the groups this group belongs to.
All Users


--------------------------------------------------------------------------------

Rights
This group is a core dubiousprofundity.com Group. Therefore the rights for this group cannot be edited. Below is a read-only list of the rights this group has access to.









(story.edit) (story.moderate)




Luhme summa dat GL.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
I assume you did run the install script in upgrade mode (or you would have all sorts of other, more obvious problems ...). So not sure why that right is missing.

First of all make sure you have a 'story.ping' entry in your gl_features table. If you don't, add it (ft_name = 'story.ping', ft_descr = 'Ability to send pings, pingbacks, or trackbacks for stories', ft_core = 1). Make a note of the ft_id it gets.

Then, find your Story Admin group's id. Usually, it's 3, but better double-check. Then do a
Text Formatted Code
INSERT INTO gl_access (acc_ft_id, acc_grp_id) VALUES (24, 3);
 
replacing the "3" with the id of your Story Admin group and the "24" with the id of the 'story.ping' feature.

bye, Dirk
 Quote

Status: offline

DubiousChrisJ

Forum User
Regular Poster
Registered: 05/10/05
Posts: 114
That did it! Thanks, Dirk. I appreciate your taking the time to work through this with me.
Luhme summa dat GL.
 Quote

All times are EDT. The time is now 06:24 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content