Welcome to Geeklog, Anonymous Monday, January 30 2023 @ 10:04 am EST

Geeklog Forums

Showing a block on the homepage only problem


Status: offline

Laugh

Site Admin
Admin
Registered: 09/27/05
Posts: 1450
I would like to show a block on the homepage only. I have set the block topic setting to "homepage only" but the problem is it only appears for http://sitename/index.php and not for http://sitename or http://sitename/

Most of my users visit me with the last two urls and not the one containing index.php. Is there a setting that allows me to add more urls to what I would define as the homepage? or at least make the home page without index.php (even though that is what is called first by IIS when you just typed in my domain name)

Thanks for any replies
One of the Geeklog Core Developers.
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 09/27/05
Posts: 1450
Yeeaah! I figured out the problem. Dirk you may want to update COM_isFrontpage in a future version to fix this issue. In IIS 6 you can set default documents to run if a domain name is just given for a URL. I had capitalized Index.php here so when the line below was run in COM_isFrontpage it would fail since they didn't match. If this line was all uppercase it would fix the problem.

if(( $scriptName $pathonly[1] . '/index.php' ) OR



One of the Geeklog Core Developers.
 Quote

All times are EST. The time is now 10:04 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content