Welcome to Geeklog Monday, December 16 2019 @ 01:07 am EST

Geeklog Forums

1&1 web host issues


Status: offline

jbpaul17

Forum User
Chatty
Registered: 14/05/04
Posts: 49
Location:New York City
confused
Hello,

I am working on setting up my second Geeklog site on 1&1 servers, but am getting a 403 Forbidden error when testing my install settings (http://www.crystalandjeff.com/admin/install/check.php). Has anyone else setup a site on 1&1 and had similar issues? And yes, I have CHMOD'ed the permissions for the files as necessary.

Any help would be greatly appreciated, thanks!
Jeff.
site: www.crystalandjeff.com
 Quote

andyofne

Anonymous
Use 1and1 for five geeklog sites. no problems at all.
 Quote

Status: offline

jbpaul17

Forum User
Chatty
Registered: 14/05/04
Posts: 49
Location:New York City
confused
I've checked with 1&1 support and they are not able to identify why my install on http://www.crystalandjeff.com does not work either. Can anyone else provide info on why a 1&1 install of Geeklog may not work?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Well, at least http://www.jeffandcrystal.com/public_html/index.php gives me a more familiar error message ...

The 403s are odd, but I think your main problem (apart from wrong database information in your config.php) is that you've set it up such that "public_html" is part of the URL. You may want to read the bit about public_html in the installation instructions again.

bye, Dirk
 Quote

Status: offline

jbpaul17

Forum User
Chatty
Registered: 14/05/04
Posts: 49
Location:New York City
confused
The site is www.crystalandjeff.com, NOT www.jeffandcrystal.com. And I'm still seeing a 403 error on my site: http://www.crystalandjeff.com
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Whoops. Must have missed a redirect while I was poking around ...

Anyway, the 403s are not something Geeklog would produce. That must be an issue with the server setup - either by 1&1 or by a .htaccess that you have on the server.

bye, Dirk
 Quote

ajohnson

Anonymous
This is kind of verbose, but might give you an idea:

http://www.checkupdown.com/status/E403.html
 Quote

Status: offline

jbpaul17

Forum User
Chatty
Registered: 14/05/04
Posts: 49
Location:New York City
confused
I've setup geeklog at /gklg/ in my web host root. So, underneath /gklg/ is: backups, data, language, logs, plugins, public_html, sql, system, & config.php. I've then set my crystalandjeff.com DNS to point to /gklg/public_html and CHMOD'ed the directories as mentioned in the install file. This still gives me a 403 error. Am I missing something?
 Quote

Status: offline

bjudson

Forum User
Junior
Registered: 01/01/04
Posts: 34
I use 1&1 with no problems at all.

First thing make sure 1&1 has finished setting you up.
Make sure you have your External Domain set up to point to the site 1&1 makes for you. IE s10003.onlinehome.us points to http://www.crystalandjeff.com/

put everything from your public_html directory into the root of your ftp account, and create a directory called /geeklog (or something) for your config.php file and other sytems files.

put a file called .htaccess in that directory with the line:
Deny from all

in it and nothing else (not the [Quote part either). This will prevent people from pulling your configuration info.

Make sure you have created a database for geeklog from the 1and1 control panel. Get the username, password, database name, and database host that 1and1 assigns you. Put these fields in your config.php file.

set your _CONF['virtual'] (I may have made up this line so if its not there by default add it) virtual directory to your virtual path (find this out by going to the install.php file and seeing what it says the current directory is) on 1and1 this will be someething line '/homepages/xx/a111111111/htdocs'

your _CONF['path'] to _CONF['virtual'] . '/geeklog';
_CONF['path_html'] = _CONF['virtual'] . '/';

finally edit your lib-common.php (in your root directory) and set the require_once path... to

require_once( '/homepages/xx/x1111111111/htdocs/geeklog/config.php' );

be sure to edit the xx and x111111111 to your path as was dispalyed from the install.php file.
 Quote

Status: offline

zyx

Forum User
Junior
Registered: 10/06/06
Posts: 25
If all else fails, make sure that you have public_html in the web directory. Most 1 and 1 servers (at least the Linux Ones) have their web directory as htdocs. You will need to put public_html files into htdocs (i think). Then you would need to fix the config.php file, but if all else fails, try that.

Just my two cents My two cents
 Quote

Status: offline

bjudson

Forum User
Junior
Registered: 01/01/04
Posts: 34
Not sure why my post above is completely blank now. It was there last night after I posted it. anywho... here it is again....

I use 1&1 with no problems at all.

First thing make sure 1&1 has finished setting you up.
Make sure you have your External Domain set up to point to the site 1&1 makes for you. IE s10003.onlinehome.us points to http://www.crystalandjeff.com/

put everything from your public_html directory into the root of your ftp account, and create a directory called /geeklog (or something) for your config.php file and other sytems files.


put a file called .htaccess in that directory with the line:
PHP Formatted Code
Deny from all

 

in it and nothing else.This will prevent people from pulling your configuration info.

Make sure you have created a database for geeklog from the 1and1 control panel. Get the username, password, database name, and database host that 1and1 assigns you. Put these fields in your config.php file.

set your
PHP Formatted Code
$_CONF['virtual']

 
(I may have made up this line so if its not there by default add it) virtual directory to your virtual path (find this out by going to the install.php file and seeing what it says the current directory is) on 1and1 this will be someething line '/homepages/xx/a111111111/htdocs'

your
PHP Formatted Code
$_CONF['path'] to _CONF['virtual'] . '/geeklog';

 
PHP Formatted Code
$_CONF['path_html'] =$_CONF['virtual'] . '/';

 

finally edit your lib-common.php (in your root directory) and set the require_once path... to

PHP Formatted Code
require_once( '/homepages/xx/x1111111111/htdocs/geeklog/config.php' );

 


be sure to edit the xx and x111111111 to your path as was dispalyed from the install.php file.
 Quote

Status: offline

bjudson

Forum User
Junior
Registered: 01/01/04
Posts: 34
groggy
After a million edits on the previous post, I figured out why it was coming out blank.

Part way through the post I had the Square bracket followed by the Word Quote indicating that the users should not put those symbols into thier .htaccess file. Because I didn't close them, the post was completely blank!

Note to self: Don't do that.
 Quote

Status: offline

bjudson

Forum User
Junior
Registered: 01/01/04
Posts: 34
Also looking at your site, I see the standard 1&1 files are coming up Forbidden too (crystalandjeff.com/missing.html). Either you have pointed your crystalandjeff.com (External Domain) to the wrong location, or 1and1 has a permission problem on the directory they set up for you.

-Ask them to delete it, and recreate it if necessary.
 Quote

Status: offline

jbpaul17

Forum User
Chatty
Registered: 14/05/04
Posts: 49
Location:New York City
confused
Thanks for all the help and input, but I'm still getting the same errors from my 1and1 hosted site. I have put in many tickets to 1and1 to assist on this matter and have got very basic responses that lead me to believe their customer support are not actually reading my emails and instead giving me a response akin to "please reboot your computer and try again". For all these reasons I would recommend against using 1and1 for Geeklog hosting and would recommend my former hosting company, VizaWeb, for their standard Geeklog installs and support. At this point I am completely fed up with 1and1 and am willing to pay the much higher prices for VizaWeb hosting. Uggghhh, what a horrible feeling that such a large hosting company like 1and1 could deliver such horrible support.
 Quote

Status: offline

bjudson

Forum User
Junior
Registered: 01/01/04
Posts: 34
Sorry to hear about that. Like I said I have had nothing but a good experience with 1and1.

Did you ask them to delete your site, and give you a new one?
 Quote

Status: offline

ajohnson

Forum User
Junior
Registered: 16/06/06
Posts: 26
With all the mention of 1&1, I took a look at their site. From the information on their hosting plans, I can't tell if any of them are on Linux/Apache servers. 1&1 seems to be M$ centric. I sent an email to support, got a couple of responses back, but as jbpaul17 mentioned, they don't seem to actually read the email. I never did get a straight answer.

Even though Godaddy breaks Geeklog in a couiple of ways, I'll stick with Godaddy.
 Quote

Status: offline

bjudson

Forum User
Junior
Registered: 01/01/04
Posts: 34
I use the 1&1 beginner for my sites. They seem to do adequately, only thing I'm missing is cron jobs, which you need to upgrade to business for. But at least with 1and1 I have access to my web logs, and it doesn't rip out accept-headers: and the such.

I used to bang the GoDaddy drum, myself and while you get people who anser the phone and such, you don't really get anybody who knows anything, and even if you did, they can't do anything about it because you don't matter! So I pay 1and1 less to not matter and get better functionality!

btw - 1and1 offers Linux sites (under their "hosting" tab) and microsoft hosting (under their "ms hosting" tab).

-Astrogen
 Quote

Status: offline

ajohnson

Forum User
Junior
Registered: 16/06/06
Posts: 26
It's not that I'm beating Godaddys drum, but rather it is what I know. I am looking for another host, but I do not want to regret making a move. Part of not regretting is getting all the facts. 1&1 isn't willing or able to get me the details so I need to pass on them.
 Quote

All times are EST. The time is now 01:07 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content