Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
When the advanced editor is enabled for non storyadmins, their story disappears when hitting preview, if preview are disabled the same thing happens when hitting submit.
With the advanced editor switched off, and only use the plain textbox all works as it should..
When logged in as storyadmin everything is ok.
What could be wrong?

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
*bump*

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
No one knows?

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
The problem is that 'text' mode is appearing as the current default post mode and the editor is appearing. If you toggle the post mode to 'html' and then use preview, the content will be preserved.
Geeklog components by PortalParts -- www.portalparts.com

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Ah.. I see..

Then there is a problem here:
from my config.php
Text Formatted Code
// +---------------------------------------------------------------------------+
// | Support for custom templaes to support advanced Rich Text Editor          |
// | Checked in comment.php, submit.php, admin/story.php and                   |
// | staticpages/index.php. If set true and advanced template exists           |
// | Note: If enabled, the default postmode will be html                       |
// +---------------------------------------------------------------------------+
$_CONF['advanced_editor'] = true;
 


And still the default postmode for article are plaintext.
This could be fixed by setting $_CONF['postmode'] = 'html';
but then if the advanced editor is disabled for comments the users vill run into problems there instead if they dont see the difference.

Could this be altered so that submitting an article also "autosense" whitch postmode to use?

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
This is fixed in CVS already for the upcoming GL release.
Geeklog components by PortalParts -- www.portalparts.com

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Aha
Tnx Blaine!