Welcome to Geeklog, Anonymous Thursday, August 18 2022 @ 03:23 pm EDT

Geeklog Forums

Regular user cannot submit story


Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
When the advanced editor is enabled for non storyadmins, their story disappears when hitting preview, if preview are disabled the same thing happens when hitting submit.
With the advanced editor switched off, and only use the plain textbox all works as it should..
When logged in as storyadmin everything is ok.
What could be wrong?
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
*bump* Can someone help me
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
No one knows?
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
The problem is that 'text' mode is appearing as the current default post mode and the editor is appearing. If you toggle the post mode to 'html' and then use preview, the content will be preserved.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
Ah.. I see..

Then there is a problem here:
from my config.php
Text Formatted Code
// +---------------------------------------------------------------------------+
// | Support for custom templaes to support advanced Rich Text Editor          |
// | Checked in comment.php, submit.php, admin/story.php and                   |
// | staticpages/index.php. If set true and advanced template exists           |
// | Note: If enabled, the default postmode will be html                       |
// +---------------------------------------------------------------------------+
$_CONF['advanced_editor'] = true;
 


And still the default postmode for article are plaintext.
This could be fixed by setting $_CONF['postmode'] = 'html';
but then if the advanced editor is disabled for comments the users vill run into problems there instead if they dont see the difference.

Could this be altered so that submitting an article also "autosense" whitch postmode to use?
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
This is fixed in CVS already for the upcoming GL release.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
Aha Wink
Tnx Blaine!
 Quote

All times are EDT. The time is now 03:23 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content