Welcome to Geeklog, Anonymous Friday, December 02 2022 @ 08:04 am EST

Geeklog Forums

Help lil probelm


Cragsterboy

Anonymous
ok when im installing geeklog, i click next to go on to the second page and i get this error!


Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/path/to/geeklog/system/databases/mysql.class.php) is not within the allowed path(s): (/home/hangout/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/hangout/public_html/crag/geeklog/system/lib-database.php on line 117

Warning: require_once(/path/to/geeklog/system/databases/mysql.class.php) [function.require-once]: failed to open stream: Operation not permitted in /home/hangout/public_html/crag/geeklog/system/lib-database.php on line 117

Fatal error: require_once() [function.require]: Failed opening required '/path/to/geeklog/system/databases/mysql.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/hangout/public_html/crag/geeklog/system/lib-database.php on line 117


Can u help me please?
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 02/15/02
Posts: 725
Quote by Cragsterboy: Can u help me please?

Hopefuly Wink

There are two files where you're supposed to specify the path to config.php:

1. config.php
Text Formatted Code
// This should point to the directory where your config.php file resides.
$_CONF['path']            = '/path/to/geeklog/'; // should end in a slash
 


2. lib-common.php
Text Formatted Code
* Make sure to include the name of the config file,
* i.e. the path should end in .../config.php
*/
require_once( '/path/to/geeklog/config.php' );
 


You cannot leave it as is. Smile

HTH
Robert
Geeklog Polish Support Team
 Quote

Cragsterboy

Anonymous
OK done wat u said but it still does it!

i think its got somethig to do with the database Question
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
The key line to your error message is:


Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/path/to/geeklog/system/databases/mysql.class.php) is not within the allowed path(s):


You (or your hosting provider) is running PHP with open_basedir restriction. This basically limits what directories a PHP script can open files. Here is the blurb from php.net about it...


Limit the files that can be opened by PHP to the specified directory-tree, including the file itself. This directive is NOT affected by whether Safe Mode is turned On or Off.

When a script tries to open a file with, for example, fopen() or gzopen(), the location of the file is checked. When the file is outside the specified directory-tree, PHP will refuse to open it. All symbolic links are resolved, so it's not possible to avoid this restriction with a symlink.


You will need to contact your hosting provider and ask them to include your Geeklog directories in the list, or to turn off the restriction for you site.

Hope this helps!

Mark
 Quote

All times are EST. The time is now 08:04 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content