Welcome to Geeklog Tuesday, June 25 2019 @ 05:38 pm EDT

Geeklog Forums

glPopMail plugin public beta test


Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
I am curently looking for people to test and give feedback on my new plugin

The plugin is a POP3 webmail client ( yes thats realy what i said!)


If your interested in helping out reply to this post or drop me an email via this sites email user functionality
glFusion - Technology Fused with Style - www.gllabs.org

Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
Some screen shots of the latest version of glPopMail



inbox

login

compose new msg

displaying a html email

credits page




As you can see it is comeing along nicely
glFusion - Technology Fused with Style - www.gllabs.org

ironmax

Anonymous
Hi Trinity,

I tested the plugin and found that I cannot compose new mail or reply to mail. As you can see from the link, you will notice that there is no typing box for the content body msg area. Let me know if you see what I'm refering to and if you need further pics

here

Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
i replyed to you in a email ironmax about this. this is a rendering issue with IE.


If you are curently testing this plugin for me please use firefox for right now. i willl fix browser querks last


glFusion - Technology Fused with Style - www.gllabs.org

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Hello
I've just installed the plugin and here's what I get upon logging into the email account:
PHP Formatted Code
Warning: htmlentities(): charset `ISO-8859-2' not supported, assuming iso-8859-1 in /demo/html/mail/index.php on line 191

Warning: htmlentities(): charset `ISO-8859-2'
not supported, assuming iso-8859-1 in /demo/html/mail/index.php on line 192
 


The above is I believe generated for every mail header (means 10 times) and then there is :
PHP Formatted Code
Warning: Cannot modify header information - headers already sent by (output started at /demo/html/mail/index.php:191) in /demo/html/lib-common.php on line 811
 


Headers are downloaded

PS
Getting back to testing
Geeklog Polish Support Team

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
After clicking Web Mail under Admin menu I get this:
PHP Formatted Code
Fatal error: Call to undefined function: admin_list() in /demo/html/admin/plugins/glPopMail/index.php on line 372
 

Geeklog Polish Support Team

Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
by the way you have to use this plugin with with geeklog 1.4 and up.

htmlenities is a standard php builtin function
glFusion - Technology Fused with Style - www.gllabs.org

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by trinity: by the way you have to use this plugin with with geeklog 1.4 and up.


And 1.4.0sr2 it is
Geeklog Polish Support Team

Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
well there isnt any admin page at the moment thats just a place holder
glFusion - Technology Fused with Style - www.gllabs.org

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Further to my previous post regarding encoding errors. Where can I change/add ISO-8859-2? The server that gives me this error is pop3.wp.pl


Also, I can't get into my gmail account I get this error message Connect to address pop.gmail.com:
connection refused
Geeklog Polish Support Team

Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
well the be honest i dont remeber where i set it let me look though the code and see if i can find it and make it settable in config.php. as far as gmail i need to add ssl suport for that to work.
glFusion - Technology Fused with Style - www.gllabs.org

ironmax

Anonymous
Okay, after careful consideration and delving into the code, I have figured out that the install did not fully do its job on the database entries. I had to manually install the database by hand and then the plugin finally started working like it was intended to work. After working with it, I had to set the tmp_glpopmail dir to 777 and all sub-dir that get created by the mail accounts that get opened. Works great. Even works with IE.


Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
A few words regarding functionality:

1. If I mistype my credentials there comes a message error etc. and link Try Again. However if there is an error in either name or password clicking on Try again won't help. So I have to go to User Functions click on Web Mail and enter all info again that's rather annoying.

2. In the inbox I have let say 100 mails. It's broken by 10 per screen. Ok let say I want to delete all of the ten. SO I click Mark all messages knowing it should mark only the ten I see however it marks all messages in the Inbox.

Robert
Geeklog Polish Support Team

ironmax

Anonymous
Quote by Robin: A few words regarding functionality:

1. If I mistype my credentials there comes a message error etc. and link Try Again. However if there is an error in either name or password clicking on Try again won't help. So I have to go to User Functions click on Web Mail and enter all info again that's rather annoying.


This is something thats gonna have to be worked out. I've noticed that as well. However, for the most part I beleave the plugin is funtioning as it was intended to function during a beta test cycle.

Quote by Robin:
2. In the inbox I have let say 100 mails. It's broken by 10 per screen. Ok let say I want to delete all of the ten. SO I click Mark all messages knowing it should mark only the ten I see however it marks all messages in the Inbox.

Robert


This again is something that can be addressed, however, I am not sure that this can be fixed. I have the same problem as everyone else does when mass deleting using a checkmark all mail function. I have even seen it on hotmail's version of their webmail system.

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by ironmax:However, for the most part I beleave the plugin is funtioning as it was intended to function during a beta test cycle.

Just trying to help

Q to Trinity: Do you want any functional feedback or just regarding bugs and stuff?
Geeklog Polish Support Team

Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
all feed back is apreciated. I will try and get a new version passed around next week for you all to play with
glFusion - Technology Fused with Style - www.gllabs.org

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by trinity: all feed back is apreciated.

When I click on a Reply button there is a form From To and so on. However the field From is empty. This should be filled with currently logged user's credentials i.e. his/her mail.
Geeklog Polish Support Team

Status: offline

trinity

Forum User
Regular Poster
Registered: 30/01/05
Posts: 80
well the thing is i need to ad a feture that alows the loged in user to set that there default reply to email is most peopls email address isnt the same as the username and server they login with.
glFusion - Technology Fused with Style - www.gllabs.org

Status: offline

ItsCurly

Forum User
Junior
Registered: 05/12/05
Posts: 24
Sounds good, and looks great, thats the only thing stopping me so far using geeklog as a PIM.

I'd love to test it for you, you can get me via the email link.

Curly

All times are EDT. The time is now 05:38 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content