Welcome to Geeklog Saturday, September 21 2019 @ 09:33 pm EDT

Geeklog Forums

login requires reload to work


Status: offline

kyngchaos

Forum User
Junior
Registered: 29/03/06
Posts: 23
I've had this problem for a while - GL 1.3.x, now in 1.4 - but it hasn't been enough of a problem to worry about. But now it's affecting the advanced editor.

When anyone logs in, it goes back to the main page with no indication that the login failed, but doesn't succeed either. Hit the reload button in the browser, and now the user is logged in. Affects Safari, FireFox (Mac/Win) and Explorer (Win), haven't tested others. The new issue with the advanced editor is that when the user tries to preview a new story, the content is dropped, yet the subject stays. If the story is saved immediately without previewing, it works.

I have another site, same GL, similar config (just the domain and naming options differ), same PHP version and options. It has no such problems.

Status: offline

bcbrock

Forum User
Chatty
Registered: 04/02/03
Posts: 64
by chance, is your $_CONF['site_url'] variable defined with an IP address?

I've had similar (not identical) issues on my test server when I've used an ip address there.
~Brian

Status: offline

kyngchaos

Forum User
Junior
Registered: 29/03/06
Posts: 23
no IP - actually, I leave the site URL empty of an address and just have a relative path to the site's subfolder. Same as on the site that works except there is no subfolder there.

I used to put the full 'http://www.mydomain.com' in the site_url, but that isn't really necessary for any links in the site's pages and just bloats the web page code with zillions of superfluous http://www.mydomain.com/ prefixes to all site links. When I did have the domain name in the site_url it had the same login problem.

Maybe it's the extra subfolder in the site_url (I use a subfolder to keep it separate from the public, static site).

Status: offline

kyngchaos

Forum User
Junior
Registered: 29/03/06
Posts: 23
Must have something to do with the site being in a subfolder of the domain (www.mydomain.com/mysite/index.php). I just moved the whole site to the root (www.mydomain.com/index.php), reconfigured, and the login problem disappeared. Maybe a mismatched cookie? in both cases I had the cookiedomain config'd as .mydomain.com and the cookiepath as '/', tho I think I tried setting the cookiepath to the subfolder in the original case with no luck.

The advanced editor problem still exists, but I should add a little explanation: it's when I click the normal 'Preview" button at the bottom of the advanced editor page, not the "Preview" that is in the blue menubar at the top of the editor, that Preview does work. So, maybe the fancy show/hide menu at the top for the various sections of the advanced editor page are confusing the form submission for a preview.

All times are EDT. The time is now 09:33 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content