Welcome to Geeklog Friday, July 03 2020 @ 11:48 pm EDT

Geeklog Forums

I'm ready to give up on Geek Log


Status: offline

overdubn

Forum User
Newbie
Registered: 14/04/06
Posts: 1
I am having difficulty figuring out what to put in the area of the lib-common.php file on line 69. On a Linux server when launching the install.php and entering the path to the config.php file, I get the following error: Warning: main(/glog/system/databases/mysql.class.php): failed to open stream: No such file or directory in /home/content/d/c/i/dcidigital/html/glog/system/lib-database.php on line 117. I have tried every conceivable path option here set/reset priv to 755. Nothing works. this software is WAY too difficult to set up. My path setting are probably wrong, but could someone give me a clue ? Thanks.
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
If path setting is difficult, you might find it difficult setting up most other scripts.

First, you need to know your paths, and there is no way for us to know. If you are using a hosting company to host your site, the best way is to ask them what is the path to your homepage.

Please let us know your paths here so that we can help.

Sam
 Quote

Status: offline

THEMike

Forum User
Moderator
Registered: 25/07/03
Posts: 141
Location:Sheffield, UK
overdubn, the error message appears to have given you everything you need to know to fix the problem.

Geeklog tries to load the file mysql.class.php from the path specified in $_CONF['path_system'] by default this is generated from $_CONF['path'] with system appended.

Your install is trying to include /glog/system/databases/mysql.class.php, this indicates that you have your path set to:
PHP Formatted Code

$_CONF['path'] = '/glog/';

 


Now, as you are likely to be on shared hosting, I highly doubt that glog is actually in the root folder as that path indicates.

The actual error message says where the problem occurred:
PHP Formatted Code

No such file or directory in /home/content/d/c/i/dcidigital/html/glog/system/lib-database.php on line 117

 


Which means you should have your path set as follows in config.php

PHP Formatted Code

$_CONF['path'] = '/home/content/d/c/i/dcidigital/html/glog/';

 


Then geeklog will correctly set the path to the other *_path entries in $_CONF if you have not explicitly altered those settings.
 Quote

All times are EDT. The time is now 11:48 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content