Welcome to Geeklog, Anonymous Saturday, April 13 2024 @ 08:51 am EDT

Geeklog Forums

HELP ME PLEASE.


Santosh

Anonymous
confused
HI I´M NEW TO GEEKLOG. COULD SOMEBODY TELL ME WHAT'S THE MEANING OF THIS? I GET IT WHEN I TRY TO UPLOAD IMAGES TO AN ALBUM WITH MEDIA GALLERY.

Warning: move_uploaded_file(/home/vedanta/public_html/vedanta/mediagallery/mediaobjects/orig/4/42728ea3105074a7e98a324187bed839.jpg): failed to open stream: Permission denied in /home/vedanta/public_html/vedanta/mediagallery/lib-upload.php on line 664

Warning: move_uploaded_file(): Unable to move '/tmp/phpjyzvpw' to '/home/vedanta/public_html/vedanta/mediagallery/mediaobjects/orig/4/42728ea3105074a7e98a324187bed839.jpg' in /home/vedanta/public_html/vedanta/mediagallery/lib-upload.php on line 664
[/CODE]
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
It means that you do not have the proper permissions setup on the mediaobjects/ directory. The user the web server runs as must have write permissions to the mediagallery/mediaobjects/* directories.

Now, depending on your hosting service, or the operating system, how you give those permissions varies. Can you give me some details on your environment?

Also, if you go into Admin Only->Media Gallery->Configuration and save, does it tell you everything is OK there (If you are running Windows OS on your server, the permission checks do not work properly in Media Gallery, I'm working on fixing that).

Hang in there, we'll get it fixed up and going.

Thanks!
Mark
 Quote

thanx mevans

Anonymous
Alright, i shall look into these things and get back to you. Thanx for ur help anyway.
Smile
 Quote

Santosh

Anonymous
Hi mevans,
I changed the permissions to write (chmod 777) but yet get the same error. However, within the code on line 664 you have Chmod 0644. Could this be overwriting the permission?
Warning: move_uploaded_file(/home/vedanta/public_html/vedanta/mediagallery/mediaobjects/orig/b/b96c6bc5a5d280bf9224a34a9d603283.jpg): failed to open stream: Permission denied in /home/vedanta/public_html/vedanta/mediagallery/lib-upload.php on line 664

Warning: move_uploaded_file(): Unable to move '/tmp/phpQduEjm' to '/home/vedanta/public_html/vedanta/mediagallery/mediaobjects/orig/b/b96c6bc5a5d280bf9224a34a9d603283.jpg' in /home/vedanta/public_html/vedanta/mediagallery/lib-upload.php on line 664
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
That shouldn't make a difference where I change to 0644, that is after the upload is processed.

Just curious when you changed the permissions, did you do it for all the sub directories under mediabojects/* ?

Each of them will need to allow the web server to write to them.

Thanks!
Mark
 Quote

Santosh

Anonymous
Mevans,
That was great advice mate! It helped. Thanx a ton and keep up the good work.

 Quote

Santosh

Anonymous
Sad What does this mean now????

Warning: Division by zero in /home/vedanta/public_html/vedanta/mediagallery/classMedia.php on line 172
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
I hope that is caused by images you uploaded before fixing the permission problems. Media Gallery was trying to calculate the size of the thumbnail and since it didn't find the image, it causes this error.

Try deleting everything you uploaded before the permissions were fixed and then you should be good to go.

Thanks!
Mark
 Quote

Santosh

Anonymous
Thank YOU Marc!
I shall do that right away..but just one thing ( phew! will my ignorance ever end!)
...The image in random pic on the home page doesnt show up. It shows only a broken link. What could this mean.

thanx in anticipation again.
 Quote

Status: offline

mevans

Forum User
Full Member
Registered: 02/08/04
Posts: 393
Location:Texas
The random image is probably the same problem with the divide by zero error, before the permissions where corrected, the uploads failed (actually the copy of the uploaded image) but Media Gallery still put the entry into the database. Once you delete those initial uploads and basically start over with the permissions correctly set, everything should fall into place.

Thanks!
Mark
 Quote

All times are EDT. The time is now 08:51 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content