Welcome to Geeklog, Anonymous Tuesday, May 21 2024 @ 12:42 am EDT

Geeklog Forums

"Post a Comment" missing when one comment is listed


DemonBrew

Anonymous
Geeklog 1.4.0sr1 using Smooth Blue theme. I _know_ this is a theme issue, but want to see if there is a work around.

When no comments have yet been posted for a story, the "0 Comments" and "Post a Comment" links are both there. Once someone has posted a comment, story only displays "1 Comment". Users only have the ability to reply to that one comment, not create a new one.

When I switch to Profesisonal theme, both "1 Comment" and "Post a Comment" are displayed. Problem can be duplicated using demo.geeklog.net

Is there a file I can edit to duplicate the functionality in Smooth Blue? Or - is there a theme that works in 1.4 besides Professional that handle this problem?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
It's not an "issue" with the theme, it's a design decision.

Check the story template files. {post_comment_link} is the variable you're looking for.

bye, Dirk
 Quote

DemonBrew

Anonymous
Ok, "issue" was the wrong word. But thanks, that got me in the right direction. I'm posting my solution so others may benefit.

In the {geeklog}public_html layout Smooth Blue folder, I edited storybodytext.thtml to be:

Text Formatted Code
<table border="0" cellpadding="3" cellspacing="0" width="100%">
              <tr><td align="center">{edit_link} {page_selector}<br>
                                     {readmore_link} {post_comment_link}<br>
                                     {start_comments_anchortag}{comments_with_count}{end_comments_anchortag} {start_trackbacks_anchortag}{trackbacks_with_count}{end_trackbacks_anchortag}
              </td></tr>
            </table>

 

Basically, just copied and pasted from the professional theme's storytext.thtml. Thanks again Dirk for the quick reply.
 Quote

Status: offline

Laugh

Site Admin
Admin
Registered: 09/27/05
Posts: 1468
Location:Canada
Thanks for the tip, have you been able to get the FCKEditor to work with your theme?
One of the Geeklog Core Developers.
 Quote

All times are EDT. The time is now 12:42 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content