Welcome to Geeklog Monday, December 16 2019 @ 01:06 am EST

Geeklog Forums

G2Bridge support

Page navigation


Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
There is no template file specifically for the random photo, we simply build a block and fill it.
but if you may, the block function is in plugins/G2Bridge/functions.inc
function phpblock_G2B_rand_photo()

Geeklog does not allow for php in the footer, but you could create a staticpage, enable php execution, and set the contents to:
PHP Formatted Code

echo phpblock_G2B_rand_photo();
 

and make this a centerblock at the bottom of the page

-s

FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

greenteagod

Forum User
Junior
Registered: 08/04/07
Posts: 19
New bit of a boggle here. I recently moved my blocks from left to right, and now am getting a message stating "You need to enable sidebar blocks in your Gallery 2 theme configuration." When I am actually viewing the rest of the gallery these blocks show up correctly.

www.super-crush.com
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
Funny, I was just working on a new version, to fix the new way GL checks for anonymous users.
I'll look into that tonight also and get back to you.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

greenteagod

Forum User
Junior
Registered: 08/04/07
Posts: 19
Any luck on it? Sort of odd behavior =D
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
I'm sorry, not sure why I no longer get notified of responses to this forum Exclamation

I believe I have it licked, as well as some other minor adjustments.

If you could give it a try and let me know.
http://www.flashyourweb.com/filemgmt/index.php?id=8

Thanks
-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

greenteagod

Forum User
Junior
Registered: 08/04/07
Posts: 19
Editing my previous post. The blocks do work, but for some reason they only jump to the photo when you are logged in. When not logged in clicking a photo takes you back to the main gallery page. Perhaps a setting I missed in the custom.php?
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
I've just released v.2.0 of the G2Bridge plugin.
I've added the ability to display my XML MiniSlideShow in a block via the G2Bridge admin, very cool Smile

get it here.

Please give it a try and lt me know what you think.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

greenteagod

Forum User
Junior
Registered: 08/04/07
Posts: 19
Excellent excellent. I did notice though that setting it "centered" still looks like it's set to the left. Also I was wondering if it would be possible to have a fade transition that simply faded into another photo instead of fading all the way out and fading back in, if you get my meaning.
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
Actually, I have a version like that which has no loader component, and better transitions.
But alas I've had little time to work on it of late.

We are about to release a transcode module to convert (most) any video to flashvideo from within Gallery2.

That coupled with our XML Media Player should be an awesome combination.

But I'll keep you updated Smile

-s


FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

falkon

Forum User
Junior
Registered: 12/02/03
Posts: 21
Just trying out Geeklog again after a long layoff. Love the usability of the new 1.4.1 version. I also have Gallery 2.2.2 installed. I just installed the new G2Bridge 2.0 plugin. The plugin created the blocks as expected. However, I also expected it to wrap the the gallery page. Is this not the case? If not, is there a quick and easy way to wrap Gallery 2 inside of Geeklog 1.4.1?

Thanks in advance,

Richard
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
the uri to gallery via the bridge should be yoursite.com/G2Bridge/index.php

you can change whether or not left and right blocks appear and some other options in the path_to_geeklog/plugins/G2Bridge/config.php

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

falkon

Forum User
Junior
Registered: 12/02/03
Posts: 21
Thanks! Now, going direct to that url I see my gallery nicely wrapped. However, when I click on a random image in a block I get this error: The requested URL /G2Bridge/v/test/blockt_md.jpg.html was not found on this server.

Also, when I log off as a user I get this error: Fatal error: Undefined class name 'galleryembed' in /home/knoxqbcl/public_html/plugins/G2Bridge/functions.inc on line 149

My gallery is installed in a folder called "gallery". Here are my path entries in /plugins/G2Bridge/config.php:

*/
$_G2B_CONF['public_dir'] = 'G2Bridge';

/* I think with Gallery 2.1 we have finally done away with the path confusion. I have set these to the default with gallery2 in your public_html directory.
You should only need to change these IF gallery2 is NOT in your public_html directory.
*/

$_G2B_CONF['G2_path'] = $_CONF['path_html'].'/gallery'; // full system path to your gallery2 install no trailing /

$_G2B_CONF['embedUri'] = $_CONF['site_url'].'/'.$_G2B_CONF['public_dir'].'/index.php'; // full url to your G2Bridge or public_dir index.php

$_G2B_CONF['g2Uri'] = $_CONF['site_url'].'/gallery/'; // full url to you gallery2 with trailing /

Thanks again for your help,

Richard
 Quote

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
the logout problem - Sorry I need to get the fixed version up on geeklog.net:
functions.inc line ~147
PHP Formatted Code
function plugin_user_logout_G2Bridge( $uid )
{
    G2B_G2_init();
        GalleryEmbed::logout( array('embedPath' => $_G2B_CONF['embedUri']) );
}


need to call the init function.

as for the urlrewrite.
Quote from admin/readme.html
# If you have G2's URL Rewrite module installed, deactivate and remove it. Re-install it through the embedded version after you've completed the installation of the plugin and verified that the installation works properly. This will ensure that the correct paths are used for rewriting.


-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com
 Quote

Status: offline

falkon

Forum User
Junior
Registered: 12/02/03
Posts: 21
That did it, thanks!
 Quote

Page navigation

All times are EST. The time is now 01:06 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content