Welcome to Geeklog Monday, October 18 2021 @ 03:58 am EDT

Geeklog Forums

Can't Install ANY plugins!!!!!


Status: offline

ethereal1

Forum User
Newbie
Registered: 14/03/06
Posts: 12
freakingout

Ok, I am VERY frustrated! I have three plugins I am trying to install, forum (2.0_1.37 OR 2.3.2_1.3.9), menu (1.2_1.3.6 OR 1.6.1_1.3.6 OR 1.6.3_1.3.Cool, contact 1.1_1.3.6 with NO success. I DO see them in the plugins page, but when I click on any (there is only one version at a time listed, I don't have all the versions in there at once) I get the page with the install button, I click on the install button, it seems like something happens but the page with the install button never changes, I see no success messages, or messages of any kind and the page still says "plugin not installed"! What the heck is that about? Also I see nothing in the error log that would help me figure it out myself or even to present here as to what might be happening.

Now, this is on my local server, not accessible to the world so unfortunately I can't direct anyone to see it. I ALWAYS install here first, get things working the way I want and THEN upload to live site. (good business pratice imho) but I DESPERATELY need someone to tell me what I may be missing! I have followed the directions in each of the plugins (to the best of my knowledge, including dir perms) so you can see the reason for the frustration.

ANY help would be GLADLY accepted!

Ethereal Banging your head

P.S. I am using Geeklog 1.4.0sr2, MySQL - 4.1.16, PHP Version 5.0.4, Apache/2.0.54 (Fedora)
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 16/07/02
Posts: 1232
Location:Canada
Enable PHP Register_Globals.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

ethereal1

Forum User
Newbie
Registered: 14/03/06
Posts: 12
freakingout
Quote by Blaine: Enable PHP Register_Globals.


Unfortunately I have, I did quite a bit of checking in the different forums here before posting and that was one of the things I found. However, it didn't resolve my issue. But I appreciate the response.

Ethereal

P.S. STILL Banging your head !
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Double-check that register_globals is indeed "off".

bye, Dirk
 Quote

Status: offline

ethereal1

Forum User
Newbie
Registered: 14/03/06
Posts: 12
stressed
Quote by Dirk: Double-check that register_globals is indeed "off".

bye, Dirk


I don't understand, Blaine said to Enable PHP Register_Globals, and you're saying to turn them off? Which is it? I HAD them off when I first tried any of the plugins and when I got the behavior I described, I researched in these forums and found something that said to turn them on, so I did, restarted the webserver and tried again and still got the same behavior. So, I am beginning to believe that it may not have anything to do with it, but I wouldn't know in regards to geeklog.

Ethereal Banging your head
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by ethereal1:
Quote by Blaine: Enable PHP Register_Globals.


Unfortunately I have,

Have you restarted the server after?
Geeklog Polish Support Team
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by ethereal1:I don't understand, Blaine said to Enable PHP Register_Globals, and you're saying to turn them off? Which is it?


As for Geeklog it doesn't matter whether it's off or on however majority of plugins still require register_globals=ON.
Geeklog Polish Support Team
 Quote

Status: offline

ethereal1

Forum User
Newbie
Registered: 14/03/06
Posts: 12
determined
Quote by Robin:
Quote by ethereal1:
Quote by Blaine: Enable PHP Register_Globals.


Unfortunately I have,

Have you restarted the server after?


Yep. I am not new to running a webserver, just pretty new to geeklog. Very Happy

Wow! This is the FASTEST responses I have EVER had on ANY forum I have joined! At THIS rate I will have a resolution very soon! Awesome guys!

Ethereal Banging your head
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by ethereal1: I don't understand, Blaine said to Enable PHP Register_Globals, and you're saying to turn them off? Which is it?

Sorry, it should be "on" (Note to self: Don't reply to forum posts when you're already halfway out through the door ...).

Use the file admin/install/info.php or just create a new one containing only the line
PHP Formatted Code
<php phpinfo(); ?>
 
and check that it really says that register_globals is "on".

Geeklog itself now works with register_globals=off, but many plugins (especially the ones you mention) still require it to be "on".

Oh, and since you're on PHP 5, also ensure that register_long_arrays is "on" (same reason here - Geeklog itself will work, many plugins won't).

bye, Dirk
 Quote

Status: offline

ethereal1

Forum User
Newbie
Registered: 14/03/06
Posts: 12
cheerful
THANK YOU DIRK!!!

Apparently I had added both of those manually and didn't catch that they were elsewhere in the php.ini so I was turning them on and they were getting turned off again. Doh! - that was a mistake WOO HOO!!! I installed the forum plugin and it worked!

Thanks to all for your help! I may go from really liking Geeklog to loving it VERY rapidly now!!!

Ethereal Chest-Slam Celebration
 Quote

garapata

Anonymous
sorry but i cant find register_globals...where can i find it?

thx.
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 04/08/03
Posts: 1298
You have to ask your hoster. Or check the file www.yoursite .com/admin/install/info.php
 Quote

garapata

Anonymous
sorry but i cant find register_globals...where can i find it?

thx.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
:rtfm: Start here: Will Geeklog work with register_globals=off?
 Quote

alias

Anonymous
i get this error when installing plugins as well
Warning: fopen("/some/path/logs/error.log", "a"Wink - Permission denied in /some/path/public_html/lib-common.php on line

i did all the GL suggestions on file/dir permissions and registers turned on and still get the same error

this is one thing about GL that makes it very difficult, plugins are not automatic like wordpress, the file permission setup seems a bit weird too seems too much back n forth and manually resetting things just to install a plugin, not a fun thing

by the way, this form captcha on the forums is hardly readable, recommend getting clearer images
 Quote

All times are EDT. The time is now 03:58 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content