Welcome to Geeklog, Anonymous Wednesday, July 06 2022 @ 03:22 pm EDT

Geeklog Forums

Publising articles

Page navigation


Radu Topan

Anonymous
Hello

If anyoane publish an article it will apear on the front page right away I want to change that so I will have to approved first. HELP
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 02/15/02
Posts: 725
Quote by Radu Topan:If anyoane publish an article it will apear on the front page right away I want to change that so I will have to approved first.


The answer to this lies in config.php Smile
Also if I may suggest something please spend some time reading the documentation, FAQ, etc.
Also before you post a question try searching the forum as it may happen someone already asked the question and got an answer.
Geeklog Polish Support Team
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Radu Topan: If anyoane publish an article it will apear on the front page right away I want to change that so I will have to approved first.

Articles submitted by normal users will end up in the submission queue by default, unless you switched that off yourself in config.php.

Articles by users in the Story Admin group (actually, users with story.submit or story.edit permissons) will show up right away. Tell them to set the draft flag.

bye, Dirk
 Quote

Radu Topan

Anonymous
hello

ii search config.php but i can not find that line. can you please tell me what line it is?

Thanks
 Quote

Radu Topan

Anonymous
I found this and change it but does nothing:

// Submission Settings

// enable (set to 1) or disable (set to 0) submission queues:
$_CONF['storysubmission'] = 0;
$_CONF['eventsubmission'] = 0;
$_CONF['usersubmission'] = 1; // 1 = new users must be approved

I change it to one but with no effect is there anything else to change?

Thanks
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Text Formatted Code
// enable (set to 1) or disable (set to 0) submission queues:
$_CONF['storysubmission'] = 1;
 

bye, Dirk
 Quote

Radu Topan

Anonymous
I did but does not work, is there anything else?
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 02/15/02
Posts: 725
Quote by Radu Topan:If anyoane publish an article it will apear on the front page right away

Let's go back to square one Smile
If you say "anyone" what do you mean by that:
a) a registered user
b) a user with Admin rights
c) a user with Story Admin rights

I'm getting a little confused here because unless you changed anything submission of stories should work as Dirk described earlier. It means that any registered user who submits a story has to wait for this story approval by an Admin.
If this is the Admin user his/her stories are published right away. The only way to postpone stories by Admin users is to check the draft flag.
Geeklog Polish Support Team
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 08/04/03
Posts: 1298
Hm, sometimes one forgets to FTP the file to the webspace or one hits the wrong subdir... this could be one solution.
 Quote

Radu Topan

Anonymous
By anyoane I ment anonymous. So is anonymous it is publising a story than it will appear right away on the front page without to wayt for approval from an admin. How can I change that?
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 02/15/02
Posts: 725
Quote by Radu Topan:So is anonymous it is publising a story than it will appear right away on the front page without to wayt for approval from an admin.

Shocked This is very strange what you are saying.
Unfortuantely I cannot test it as your site is unavailable.
I don't know what modifications you've done however by default anyone can submit different things like stories, links, etc. including anonymous. On the other hand by default everything ends up in submission queue and must be approved by Admin.

Geeklog Polish Support Team
 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 08/04/03
Posts: 1298
Funny, I just checked the German version of the config which I usually find a bit better commented, maybe because German is a bit more difficult?

Text Formatted Code
// Beitraege muessen von einem Moderator freigegeben werden (1) oder sind
// sofort verfuegbar (0)
$_CONF['storysubmission'] = 1;
$_CONF['eventsubmission'] = 1;
$_CONF['usersubmission']  = 0; // entsprechend fuer User-Anmeldungen

 


1 means enabling cuing up!!! 0 means it does NOT need to be approved.

Text Formatted Code
// enable (set to 1) or disable (set to 0) submission queues:
$_CONF['storysubmission'] = 1;
$_CONF['eventsubmission'] = 1;
$_CONF['usersubmission']  = 0; // 1 = new users must be approved

 


"enable" means "enable cuing up" (set to 1)
 Quote

Radu Topan

Anonymous
praying it will work Ok it does not work

// enable (set to 1) or disable (set to 0) submission queues:
$_CONF['storysubmission'] = 1;
$_CONF['eventsubmission'] = 1;
$_CONF['usersubmission'] = 0; // 1 = new users must be approved

the switch for storysubmission does not work. The only thing I did after installing the script from Fantastico i uploaded my old data base in top of the new one. is there anything to change in the DB in order to make it work?

please help
praying it will work

 Quote

Status: offline

1000ideen

Forum User
Full Member
Registered: 08/04/03
Posts: 1298
The only thing I did after installing the script from Fantastico i uploaded my old data base in top of the new one. is there anything to change in the DB in order to make it work?


Uh, you should give some more details like what version is it, what theme, what did you do in general, upgrading from what to what?
 Quote

Radu Topan

Anonymous
hello
i installed a fresh copy form Fantastico with the theame that comes with "professional" (really bad theame) and i reloded my old data base and did nothing elese in .... general!!! But the switch does not worked after I reloded my old data base
 Quote

Radu Topan

Anonymous
praying it will work praying it will work praying it will work praying it will work
 Quote

Radu Topan

Anonymous
HELP PLEASE praying it will work praying it will work praying it will work
 Quote

Status: offline

Robin

Forum User
Full Member
Registered: 02/15/02
Posts: 725
Quote by Radu Topan:i reloded my old data base and did nothing elese in

You could try examining your groups and check whether you add at some point Anonymous to Root group or some other one.
So under Admin Menu go to Groups and edit them, under List Users, and check if there is or isn't anonymous added to any of them.

Quote by Radu Topan:"professional" (really bad theame)

That's not very polite to write such remarks.
Geeklog Polish Support Team
 Quote

Radu Topan

Anonymous
Sorry

i will try
 Quote

Radu Topan

Anonymous
ok

Now i get this error when i go to edit the groups

Warning: fopen(/home/ortonet/public_html/logs/error.log): failed to open stream: Permission denied in /home/ortonet/public_html/lib-common.php on line 1702
 Quote

Page navigation

All times are EDT. The time is now 03:22 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content