Welcome to Geeklog Thursday, October 28 2021 @ 04:09 am EDT

Geeklog Forums

filemgmt how to change icons


Status: offline

donm1021

Forum User
Chatty
Registered: 31/12/05
Posts: 56
I am using the filemgmt plugin, and the site I am creating will allow uploads of word docs, excel files, and powerpoint.

I would like to offer the corresponding icon for each application instead of the disk looking icon - does anyone know how to change that icon?

Thanks!

 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
You could simply replace the images/download.gif

The code that creates the entry for a downloadable file is in include/dlformat.php (both in the public filemgmt directory).

bye, Dirk
 Quote

Status: offline

donm1021

Forum User
Chatty
Registered: 31/12/05
Posts: 56
Yeah, I thought about changing the download.gif... but then the icon would be the same for every file, and that's what I am trying to change,

Here on this site, I see that you have setup categories (Add-ons, Geeklog, Themes), and each category has it's own icon at the top of the page. How do you set that icon for the downloads area?

That an alternative for what I am trying to do.

 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
When you set up a new category, you can also add an icon. Doesn't work for sub-categories, though and I think there's a bug that won't let you change the icon later (unless you change it directly in the database).

bye, Dirk
 Quote

Status: offline

donm1021

Forum User
Chatty
Registered: 31/12/05
Posts: 56
Dirk - I set up the categories and added an icon - however, the icons don't appear? I viewed the source for the page and the icons are there... but they don't appear? very strange.

I just checked again and I am using the Contemporary_v1 theme... using this theme the icons don;t appear at all. However I switched to the professional theme and the icons appear to be broken images?

Is it a permissions (CHMOD) issue? I looked and the icon images are in the filemgmt_data/category_snaps/ directory

(**Note - Maybe this will help anyone else that runs into this - I changed the configuration of the filemanager category thumbnails directory to filemgmt/images and the images began to work fine. It appears that anything that is put into the category_snaps directory doesn't get read? Bug?)
 Quote

All times are EDT. The time is now 04:09 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content