Welcome to Geeklog Tuesday, August 04 2020 @ 12:47 am EDT

Geeklog Forums

CALENDER , please HELP FAST


Status: offline

Senja

Forum User
Junior
Registered: 23/01/05
Posts: 22
confused
Could someone help me with the language in events . I want to delete the namn of the day , because I can`t get the norwegian languages for the day : like Tuesday 07/02/06 , I will just have 07/02/06 , and not the day . Is there any place I can edit ???
Chest-Slam Celebration
 Quote

Status: offline

Mu Satach

Forum User
Junior
Registered: 30/01/03
Posts: 16
the templates that the calendar use are in the layout folder
geeklog/public_html/layout/professional/calendar/
geeklog/public_html/layout/professional/calendar/dayview/
geeklog/public_html/layout/professional/calendar/weekview/

but after looking at the code, I don't know if that will fix the problem your talking about. It looks like the day & date are both apart of the same variable

{ currentday }

which is why your seeing Thursday, 02/02/06 instead of Torsdag, 02/02/06

Ni!
 Quote

annon

Anonymous
does date settings in config.php have any effect ?
 Quote

Status: offline

Senja

Forum User
Junior
Registered: 23/01/05
Posts: 22
Editing config.php , gives no effect on the calender
 Quote

Status: offline

eg0master

Forum User
Regular Poster
Registered: 21/07/05
Posts: 73
Location:Stockholm
It works fine if you set the correct locale in config.php and have the norwegian locale installed on your webserver. Had similar problem with the swedish locale and had to install/compile a swedish locale in order to make it work.
Geeklog Plugins: http://plugincms.com
 Quote

Status: offline

Senja

Forum User
Junior
Registered: 23/01/05
Posts: 22
I will try that.. My config.php is correct , with locale no_No , but I am not shure how to set my webserver to the norwegian locale ?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Senja: I will just have 07/02/06 , and not the day . Is there any place I can edit ???

The calendar (calendar_event.php, actually) uses $_CONF['shortdate'] which, by default = '%x'.

'%x' is the "preferred time representation for the current locale without the date". So this automatically includes the day. If you want something else, you'll have to piece it together from the list of those % placeholders, as listed in the documentation or in the PHP manual.

Something like $_CONF['shortdate'] = '%d/%m/%y';

bye, Dirk
 Quote

Status: offline

Senja

Forum User
Junior
Registered: 23/01/05
Posts: 22
Is there another place than config.php to set the :$_CONF['shortdate'], I have set it in this file , but it is not working
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Sorry, it's using 'shortday' only for all-day events. For events that have a start and end time, it's using the current user's preferred date format (which they can set in their preferences) or $_CONF['date'] (for anonymous users and for users who left the setting at "system default").

bye, Dirk
 Quote

Status: offline

eg0master

Forum User
Regular Poster
Registered: 21/07/05
Posts: 73
Location:Stockholm
Quote by Senja: I will try that.. My config.php is correct , with locale no_No , but I am not shure how to set my webserver to the norwegian locale ?

You do not need to set the webserver to the norwegian locale, it must only be available. If you're running a *nix webserver use 'locale -a' command to see all installed locales.
Geeklog Plugins: http://plugincms.com
 Quote

Status: offline

Senja

Forum User
Junior
Registered: 23/01/05
Posts: 22
confused
Is there no way to edit so I can get my norwegian days , not in english , like tuesday , I want Tirsdag .... Geeklog is a very good script and program , there must be a way to EDIT please Rolling Eyes
 Quote

Status: offline

Mu Satach

Forum User
Junior
Registered: 30/01/03
Posts: 16
Is your setting in the config.php file
PHP Formatted Code
$_CONF['locale']          = 'no_No';

 
or
PHP Formatted Code
$_CONF['locale']          = 'no_NO';

 

on my site, "no_No" does not work, but "no_NO" does.

if that doesn't work then you'll need to contact the server admin, or if you are the admin, do some digging on how to install the locale
Ni!
 Quote

Status: offline

eg0master

Forum User
Regular Poster
Registered: 21/07/05
Posts: 73
Location:Stockholm
Exactly, the locale string is case sensitive.
Geeklog Plugins: http://plugincms.com
 Quote

All times are EDT. The time is now 12:47 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content