Welcome to Geeklog Wednesday, December 01 2021 @ 11:27 pm EST

Geeklog Forums

a way to disable Forum Menu block?


Status: offline

Mina

Forum User
Junior
Registered: 02/10/05
Posts: 34
Hi, I am trying to disable Forum Menu block. I thought I was able to do it using Admin Block option. I did uncheck "Enable" to disable that block. It seems to be working fine when I click on other options. However, whenever I click on the forum index.php, the Forum Menu block comes back... Do you think this is a bug?
Can you please help resolving this issue?

Thanks so much in advance!!
 Quote

Status: offline

Mina

Forum User
Junior
Registered: 02/10/05
Posts: 34
I actually just found a workaround. plugins/forum/config.php has the following code:
PHP Formatted Code
$CONF_FORUM['leftblocks'] = array ('forum_menu');

 


I commented out and it is now removed. I can now enable/disable by using Admin block option. I am thinking that code shouldn't be there at first place as everything appears to be working properly without it.
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 16/07/02
Posts: 1232
Location:Canada
Quote by Mina: I actually just found a workaround in plugins/forum/config.php

I commented out and it is now removed. I can now enable/disable by using Admin block option. I am thinking that code shouldn't be there at first place as everything appears to be working properly without it.

That is not actually a work around but the designed option to add any additional blocks (in this case the forum user-options) that should appear when on the forum page. If you leave it blank then just the enabled leftblocks appear.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

All times are EST. The time is now 11:27 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content