Welcome to Geeklog Saturday, September 21 2019 @ 09:34 pm EDT

Geeklog Forums

Strange Error after publishing story


Tahir Khalid

Anonymous
blank
Hi,

I am currently using Geeklog as supplied by my hosting company (I believe its v1.3.11r1) and I have encountered a strange problem after submitting a news story.

Geeklog was installed using my hosting accounts CPanel interface through Fantastico. The installation went ahead fine and everything worked straight away. I promptly adminstered the site and disabled some blocks that were not required and then copied the Professional layout to create my own custom layout for my site.

The new layout worked fine as I had only changed the CSS file and header, footer and left thtml files (very small changes).

I was able to publish two stories and one featured story without a problem. I then took a featured story and created a static page out of this as I wanted the article to be made available to the public at all times - the static page was created successfully and worked first time.

I then attempted to create a new story today however once I published the story I was no longer able to view the story from the front page (during editing I was able to see the preview). I have checked the MySQL database and the story is present with all of the text etc and I cannot see anything out of the ordinary for the record in the database (compared the entry with previous stories).

When I attempt to view the story from the front page by either clicking on the title, the Read link or the right hand box link I get the following error message:

Fatal error: Only variables can be passed by reference in /home/turrok/public_html/apocalypse/lib-common.php on line 2617

I have checked the source file in question and cannot see anything unusual however I am not certain what the error is as I do not have knowledge of how geeklog was developed.

Has anyone else experienced this and what was the workaround/fix?

*The only option is to manually delete the record from the database however I am not confident in doing this incase the missing record adversely effects the operation of geeklog*

You can visit the site here:

http://www.vurso.com/apocalypse

Click on the middle story (heading New Recruits

Thanks in advance,

Taz

Tahir Khalid

Anonymous
I decided to delete the offending records from the MySQL database and then recreate the story which seems to have fixed the problem.

I would still like to know why this error occurred and what was done to resolve it.

Thanks,

Taz

Tahir Khalid

Anonymous
cheerful
Upgraded to 1.3.11sr3 - this seemed to fix the problem!

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
For the sake of completeness: There was a change in recent PHP versions and Geeklog's code has been updated accordingly. Hence the error message you were getting and why it went away when you upgraded.

bye, Dirk

All times are EDT. The time is now 09:34 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content