Welcome to Geeklog, Anonymous Monday, December 05 2022 @ 11:23 pm EST

Geeklog Forums

Inmemoriam_1.0.1_1.3.11


Status: offline

MaXi_XCeL

Forum User
Junior
Registered: 03/09/03
Posts: 22
Hi Guys,

I've installed the inmemorial plugin in my geeklog but when I try to create an ablum, or submit an admin setting i receive the following error:

Text Formatted Code
Fatal error: Call to undefined function: mysql_real_escape_string() in \mypath\to\geeklog\plugins\inmemoriam\functions.inc on line 1586
 


Can't find anything about it. Any suggestions?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
According to the PHP manual, that function only exists as of PHP 4.3.0, so you're probably running on an older version.

bye, Dirk
 Quote

Status: offline

MaXi_XCeL

Forum User
Junior
Registered: 03/09/03
Posts: 22
Right again Dirk! Thanks a lot!
 Quote

Status: offline

MaXi_XCeL

Forum User
Junior
Registered: 03/09/03
Posts: 22
Another question. Maybe Im reading it wrong. In edit album you are able to set the album as featured and select the position and topic.

i am thinking that when i select a topic the album will only show as featured in that topic. But it shows in all topics and on index.

What's wrong (with me Laughing )

Thanks! David
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
you just found a bug! thank you and I'll fix it momentarily
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
in your functions.inc file, replace the function plugin_centerblock_inmemoriam() with this one:
Text Formatted Code
//creates a centerblock on the index page
function plugin_centerblock_inmemoriam($where=1,$page=1,$topic =''){
    global $INM_CONF, $_TABLES, $INM_TABLES, $_USER;

    $pi_name = $INM_CONF['pi_name'];     // Plugin name
    $retval = '';

    if (DB_getItem($INM_TABLES['settings'], 'anonview') == 0 && $_USER['uid'] <= 1){
        return '';
    }
    // Retrieve Centerblock Settings
    $result = DB_query("SELECT id, cntrblktype, cntrblkpage, cntrblkpos FROM {$INM_TABLES['albums']} WHERE featured='1'" . COM_getPermSQL('and'));

    // Check user has rights to view this cb, if so, do it.
    if (DB_numRows($result) == 1) {
        list($id,$type,$cntrblkpage,$cntrblkpos) = DB_fetchArray($result);
        // If enabled only for homepage and this is not page 1 or a topic page, then set disable flag
        if ($cntrblkpage == 'none'){
            if ($page > 1 OR $topic != ""){
                $cntrblkenable = 0;
            } else $cntrblkenable = 1;
        // If enabled for all pages and this is not page 1, then set disable flag
        } elseif ($cntrblkpage == 'all'){
            if ($page > 1 ){
                $cntrblkenable = 0;
            } else $cntrblkenable = 1;
        // If enabled for a single topic and this is it, then enable
        } elseif ($cntrblkpage == $topic){
            $cntrblkenable = 1;
        }

        // Check if there are no featured articles in this topic and if so then place it at the top of the page
        if ($topic != "") {
            $wheresql = "WHERE tid='$topic' AND featured > 0";
        } else {
            $wheresql = "WHERE featured = 1";
        }
        $query = DB_query("SELECT count(*) as count FROM {$_TABLES['stories']} $wheresql");
        $result = DB_fetchArray($query);
        if ($result['count'] == 0 && $cntrblkpos == 2) {
            $cntrblkpos = 1;//top of page
        }

        if ($cntrblkenable AND $cntrblkpos == $where) {
            if (DB_getItem($_TABLES['plugins'],'pi_enabled', 'pi_name = "' .$pi_name. '"')){
                $retval = inm_featuredAlbum($id,$type);
                return $retval;
            }
        }
    }
}
 
 Quote

Status: offline

MaXi_XCeL

Forum User
Junior
Registered: 03/09/03
Posts: 22
Really nice Smile Thanks! David Its a deal - shaking hands
 Quote

Status: offline

k74

Forum User
Full Member
Registered: 09/19/04
Posts: 128
Location:Australia
determined
I have just installed the plugin, its great Mach just as your other plugins have been.

One question and I have a feeling it may be something on my end, I am able to upload MP3 files however when I hit play it won't open the file but there is no error logged that I can find. I can play MPEG and quicktime files with no problem and JPEGS. I haven't been able to get GIFS to work yey either even though I have the appropriate GD setup and enabled them in the config file as stated in the install file.

Any suggestions on how I mightovercome these issues?

Thanks in advance, Kev. Very Happy
Live everyday as if it was your last!
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
Quote by k74: I am able to upload MP3 files however when I hit play it won't open the file but there is no error logged that I can find.
does anything happen at all? goes to another page or anything? my suspicion is that your browser may not be configured to automatically open/play mp3's--unlikely however.
Quote by k74: I haven't been able to get GIFS to work yey either even though I have the appropriate GD setup and enabled them in the config file as stated in the install file.
that one stumps me. Have you tried a different library? imagemagick or netpbm?
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
give this a try, k74

edit $INM_CONF['aud_ext'] in Inmemoriam's config.php file:

change this: '.mp3' => 'audio/mpeg3',
to look like this: '.mp3' => 'audio/mpeg',
 Quote

Status: offline

k74

Forum User
Full Member
Registered: 09/19/04
Posts: 128
Location:Australia
Quote by machinari: does anything happen at all? goes to another page or anything? my suspicion is that your browser may not be configured to automatically open/play mp3's--unlikely however.


It goes to a a download box? On my online site I have been using File Management plugin for people to open MP3 and Video files. This has worked OK. The files open with windows edia player on my browser straight away.

[QUOTE by : machinari]that one stumps me. Have you tried a different library? imagemagick or netpbm?[/QUOTE]

I have only used GD as it came installed on the server and has worked for everything so far (with the exception of the Upage plugin which I think may need netpbm?) GIF's open with no trouble on the site as I use them for logo's and advertisements.
Live everyday as if it was your last!
 Quote

Status: offline

k74

Forum User
Full Member
Registered: 09/19/04
Posts: 128
Location:Australia
Quote by machinari: give this a try, k74

edit $INM_CONF['aud_ext'] in Inmemoriam's config.php file:

change this: '.mp3' => 'audio/mpeg3',
to look like this: '.mp3' => 'audio/mpeg',


Thanks for all your suggestions machinari, I will try this. I hope to get this working as it is more what I am after rather than using the file managment plugin for this purpose.

Regards

Kev
Live everyday as if it was your last!
 Quote

Status: offline

k74

Forum User
Full Member
Registered: 09/19/04
Posts: 128
Location:Australia
cheerful
Thanks for that suggestion machinari. The MP3's work now.

Is the rating system supposed to work with 1.3.11 or 1.4..0 only?

Regards

Kev
Live everyday as if it was your last!
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
the rating system works with 1.3.11 and 1.4. It's the comment functions that will not work with 1.3.11.

the GD library doesn't actually have anything to do with whether a gif can be viewed when used inside a regular img tag on your site. Inmemoriam, however, uses the GD lib to render the file. I would recheck your GD version according to the comments in Inmemoriam's config.php file. There really is no other reason that I can think of that would disable gifs in inmemoriam.
 Quote

Status: offline

k74

Forum User
Full Member
Registered: 09/19/04
Posts: 128
Location:Australia
cheerful
Thanks machinari for your help. I will look into the GD issue.

However I still can't seem to get the rating system working, it comes up with:

Current rating: N/A Voters: 0

But I can't see where to make an actual vote.

It isn't really a necessary function for all my sites but I do have one where this will be handy if it did work.

Any how it is a great plugin, easy to install and looks fantastic. Another terrific plugin by machinari thanks for all your hard work. Hope you still get enough time to strum on the guitar and play with the kids. Have a ggood weekend.

Regards

Kev

Live everyday as if it was your last!
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
Quote by k74:
But I can't see where to make an actual vote.
it is set up to not be able to vote for your own submissions. maybe that is the issue.
 Quote

Status: offline

k74

Forum User
Full Member
Registered: 09/19/04
Posts: 128
Location:Australia
embarrassed
That would answer my question clearly. That is an extremeley good function.

Its a deal - shaking hands
Regards

Kev
Live everyday as if it was your last!
 Quote

reddy

Anonymous
cheerful
Is there a way to change the wording in the menu area at the top of the page from inmemoriam to Photo Gallery. I want to leave it inmemoriam evrywhere else but in the menu at the top of the page. In the header.thtml all it says is {menu_elements} and I don't know where to find them.

Thank you for any help!! Bob Very Happy
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
Quote by reddy: Is there a way to change the wording in the menu area at the top of the page from inmemoriam to Photo Gallery.
have a look at the language file: $LANG_INM01[1].
 Quote

Status: offline

reddy

Forum User
Newbie
Registered: 09/27/05
Posts: 7
Location:Nampa, Idaho
happy
Thank you!!! Very Happy That did the trick!!!
Have a blessed day!!
 Quote

All times are EST. The time is now 11:23 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content